05 phoenix - Polaris ATV Forum
ATV General Discussion General Discussions about Polaris ATVs.

 
LinkBack Thread Tools Display Modes
post #1 of 2 (permalink) Old 10-30-2010, 12:58 PM Thread Starter
Junior Member
 
jjzg24's Avatar
 
Join Date: Oct 2010
Location: illinois
Posts: 2
05 phoenix

I have a 05 phoenix 200, it is fine in reverse but, as soon as it is in forward it makes a very loud popping noise and wont move. Could this be a clutch problem?
jjzg24 is offline  
Sponsored Links
Advertisement
 
post #2 of 2 (permalink) Old 10-30-2010, 04:42 PM
Polaris ATV Legend
 
Bruce!'s Avatar
 
Join Date: Feb 2009
Location: Port Angeles WA
Posts: 20,003
Welcome to the board!

I tried setting my password to "penis" but it said my password wasn't long enough...
Bruce! is offline  
Reply

  Lower Navigation
Go Back   Polaris ATV Forum > Polaris ATV Discussions > ATV General Discussion

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Polaris ATV Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Thread Thread Starter Forum Replies Last Post
Phoenix snorkels ?? rotaxdave1 Polaris Phoenix 5 01-27-2015 06:31 PM
Do you like your Phoenix? shadetree Polaris Phoenix 29 01-03-2014 03:12 PM
2005 phoenix pottsville30 Polaris Phoenix 2 04-07-2011 08:29 AM
phoenix 200 MADOG1234 Polaris Phoenix 3 09-26-2010 04:41 PM
phoenix backfire rooter52 ATV Repair and Maintenance 4 05-06-2009 01:08 PM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome