1994 polaris 400l 4x4 - Polaris ATV Forum
ATV New Members If you are new here please post in this section so everyone can get to know you. This will be a kind of icebreaker section for new members.

 
LinkBack Thread Tools Display Modes
post #1 of 2 (permalink) Old 03-21-2011, 06:51 PM Thread Starter
Junior Member
 
rick taylor's Avatar
 
Join Date: Mar 2011
Location: abbotsford bc
Posts: 1
1994 polaris 400l 4x4

carb problems. starts good enough but just wont build snappy rpm when i have the air cleaner on.bogs out at half throttle .
rick taylor is offline  
Sponsored Links
Advertisement
 
post #2 of 2 (permalink) Old 03-21-2011, 08:01 PM
Polaris ATV Legend
 
Bruce!'s Avatar
 
Join Date: Feb 2009
Location: Port Angeles WA
Posts: 20,004
Welcome to the board!

I tried setting my password to "penis" but it said my password wasn't long enough...
Bruce! is offline  
Reply

  Lower Navigation
Go Back   Polaris ATV Forum > Polaris ATV Discussions > ATV New Members

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Polaris ATV Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Thread Thread Starter Forum Replies Last Post
1994 400l fail polaris1994 ATV Repair and Maintenance 8 11-14-2010 02:48 PM
1994 400L won't start xsperf ATV Repair and Maintenance 6 09-06-2010 05:33 PM
1994 400l Rebuild littlesweetboy ATV Repair and Maintenance 2 08-15-2010 04:06 PM
1994 Polaris 400L 2x4 will not start? Dkoke ATV Repair and Maintenance 2 07-09-2010 04:04 PM
1994 400L no fire kratz ATV Repair and Maintenance 4 08-24-2009 01:38 PM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome