2010 850 xp problems - Polaris ATV Forum
ATV New Members If you are new here please post in this section so everyone can get to know you. This will be a kind of icebreaker section for new members.

Reply
 
LinkBack Thread Tools Display Modes
post #1 of 21 (permalink) Old 09-18-2010, 11:45 AM Thread Starter
SIG
Junior Member
 
SIG's Avatar
 
Join Date: Sep 2010
Posts: 1
2010 850 xp problems

Hi guys, I have been reading these post for a while now. I started before I made my mind up to buy a 2010 850 xp eps. I really love the machine. The power and ride are second to none. My problem is the rear end noise/problems. I have had it back to the dealer twice to have it checked out and I was assured that everything I was hearing was normal. Six months and ten days later a guy that I work with takes the plunge and buys a 2011 850xp. As he is thanking me for recommending the Polaris I tell him we should get together and go riding. I also asked if the noise in the rear end has bothered him and he said he didn't notice any noise so I thought I was being over critical of my machine. When we got together to ride I asked if I could take his machine for a ride because I was still wondering if the noise that I can hear is normal. His machine didn't make a bit of noise when compared to mine! Mine clicks and howls like real aggressive tires going down a paved road all the time. Since it was new and I have been told two times at the dealer that "that's just the way the new Polaris 850s are" Now my warranty is up I can see myself getting stuck with a huge bill because they will find a problem this time. It really sucks that someone puts $10,000 of their hard earned money on a machine and still has to worry about putting more money into it with only 12 hrs and 105 miles. My last machine was a Honda 450es that is ten years old with over 3700 miles on it and all that I have had to do is normal oil, grease, filter changes and two batteries. I will let you know how things turn out at the dealer. If they tell me I'm stuck with the bill the Polaris will be headed down the road. I wont stand by a company that doesn't stand by it's customers. This seemed like the best place for me to vent my anger. Thanks.
SIG is offline  
Sponsored Links
Advertisement
 
post #2 of 21 (permalink) Old 09-18-2010, 12:19 PM
Supporting Vendor
 
Thor's Avatar
 
Join Date: Aug 2009
Location: Prescott AZ & McHenry IL
Posts: 3,797
I would suggest try another dealer. My first 09 850XP develop the clicking noise in the rear. It was 6 months out of warranty but my dealer called Polaris and they replaced the rear axles free of charge. Best of luck!

BTW Welcome to the forum!


Owner of Thor's TheATVSuperStore.com. Where we test what we sell and only sell the best!

2012 Sportsman 850XP Touring. 2015 RZR 900 4.
Thor is offline  
post #3 of 21 (permalink) Old 09-18-2010, 04:21 PM
Polaris ATV Legend
 
Bruce!'s Avatar
 
Join Date: Feb 2009
Location: Port Angeles WA
Posts: 20,003
Welcome to the board!

I tried setting my password to "penis" but it said my password wasn't long enough...
Bruce! is offline  
Sponsored Links
Advertisement
 
post #4 of 21 (permalink) Old 09-18-2010, 06:39 PM
Extreme ATV Enthusiast
 
terb's Avatar
 
Join Date: Sep 2009
Location: Phoenix AZ/Luna NM
Posts: 163
Mine clunks bad going from forward to reverse and from reverse to forward and they say that's normal but it has very little wine driving down the road. I have 1200 miles on mine. Buy a Grizzly 700 next time!!!

2014 XP850 Red
2012 CRF450X
2009 Red Grizzly 700 EPS
2009 Silver Rhino 700
2010 Haulmark 28' race trailer

Last edited by terb; 09-18-2010 at 06:44 PM.
terb is offline  
post #5 of 21 (permalink) Old 09-28-2010, 12:26 PM
ATV Enthusiast
 
Gilly's Avatar
 
Join Date: Apr 2010
Location: Esterhazy Saskatchewan
Posts: 30
Noise!

Mine also makes noise, but no clunking or clicking. Just a kind of a timed howl comin from the rear end somewhere. Its definately not a solid sound but one with a beat that speeds up as I do. It sounds like this -- -- -- -- instead of like this ----------, know what I mean? It almost sounds like something is warped, but I cant find anything. It kinda bugs me but its been like that from day one. Mine is a 2009 850. My dad just bought a 2010 and his does the exact same thing. I think its normal. mine has 1400 miles and his has 200 miles and the noise is pretty much identical.
Gilly is offline  
post #6 of 21 (permalink) Old 09-28-2010, 02:49 PM
Polaris ATV Junkie!
 
slyder01's Avatar
 
Join Date: Mar 2010
Location: Manchester, PA
Posts: 673
if you had it at the dealer twice for that problem, they are suppose to report to polaris any problems like that. That way in the future, if something does break out of warranty, it will get fixed for you at no charge.

For future reference here is what I found by talking to polaris, Call them and report any problem with your machine even if it's been at the dealer or not for repairs. ( Just in case your dealer did NOT) The customer service reps will take your vin# and put your report in their database, that way, if something does happen, you are covered

If there's a trail I ride em'...
If there is no trail I make one...
RIDE ON !!

2010 Sportsman 850 XP EPS
2008 Sportsman 400 H.O.
slyder01 is offline  
post #7 of 21 (permalink) Old 09-28-2010, 07:35 PM
Polaris ATV Junkie!
 
Smoothbassman's Avatar
 
Join Date: Jan 2010
Location: York, PA
Posts: 1,140
Send a message via AIM to Smoothbassman Send a message via Skype™ to Smoothbassman
Quote:
Originally Posted by slyder01 View Post
if you had it at the dealer twice for that problem, they are suppose to report to polaris any problems like that. That way in the future, if something does break out of warranty, it will get fixed for you at no charge.

For future reference here is what I found by talking to polaris, Call them and report any problem with your machine even if it's been at the dealer or not for repairs. ( Just in case your dealer did NOT) The customer service reps will take your vin# and put your report in their database, that way, if something does happen, you are covered
Agreed. There has been a noise in the rear of my quad for some time now. I had it documented and signed by the dealer to CYA. I have a copy of the report and plan on taking it back in to address sometime soon as the sound is still there after two more months of riding.

  • Polaris 3500 Winch
  • Viking Hause Fairlead and Safety Thimble
  • Elka Stage 2 Triple Rate Shocks with Rebound
  • Front Lock n Ride Storage Box
  • WES Lock and Ride Rear Touring Box
  • Rotopax Front Storage Fuel Cells
  • Hand Warmers
  • Garmin GPSMap 62S
  • 27" Grim Reapers
  • 8000K HID Lights
  • Ricochet Full Skid Kit
  • Go Pro Hero 3 Black Edition
Smoothbassman is offline  
post #8 of 21 (permalink) Old 11-15-2010, 01:29 PM
Junior Member
 
Dillon1483's Avatar
 
Join Date: Nov 2010
Posts: 14
Angry Noise in reverse.

2010 xps 850 EPS

I also hear a noise in reverse that sounds like clicking. Not sure what it is and the warranty ended a few months ago. Click click click. Hmmm what to do.
Dillon1483 is offline  
post #9 of 21 (permalink) Old 11-15-2010, 01:50 PM
Polaris ATV Junkie!
 
North Branch's Avatar
 
Join Date: Nov 2009
Posts: 555
I believe there was a recall on some of the XP axles. Apparently, they should have recalled them all.

Seriously, I know some folks who have had the axles replaced... only to have the same issue a short time latter. I guess those of you with XP's will know sometime down the road if it is a serious problem... or not.

Good luck with them.
North Branch is offline  
post #10 of 21 (permalink) Old 11-15-2010, 01:53 PM
Polaris ATV Junkie!
 
North Branch's Avatar
 
Join Date: Nov 2009
Posts: 555
Quote:
Originally Posted by terb View Post
Mine clunks bad going from forward to reverse and from reverse to forward and they say that's normal but it has very little wine d riving down the road. I have 1200 miles on mine. Buy a Grizzly 700 next time!!!
or a 750 King Quad w/EPS.
North Branch is offline  
Reply

  Lower Navigation
Go Back   Polaris ATV Forum > Polaris ATV Discussions > ATV New Members

Tags
850 xp , noise , rear end , warranty

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Polaris ATV Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Thread Thread Starter Forum Replies Last Post
Winch problems for 2010 550 EPS edgexc Polaris XP 9 02-17-2011 06:25 PM
2010 Polaris Sportsman 500 ho radiator problems cctguru14 ATV Performance Modifications 5 12-02-2010 08:54 AM
2010 Polaris 500 HO -fan problems Bill705 Polaris Sportsman 3 09-24-2010 04:29 PM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome