Polaris ATV Forum
Go Back   Polaris ATV Forum > Polaris ATV Technical Discussions > ATV Performance Modifications

ATV Performance Modifications Have Modifications? Want to ask about a mod? Having problems with a certain mod? Ask and post here! Carbs, Exhausts, Engines, Etc...

Reply
 
LinkBack Thread Tools Display Modes
  #1 (permalink)  
Old 03-09-2013, 02:11 PM
Moomba's Avatar
ATV Enthusiast
 
Member #33670
Join Date: Jan 2013
Location: Indiana
Posts: 78
Check engine light on already!

Quick question for all those that know more than me - which is all of you!

I have a 2013 850 XP Sportsman. The other day was the first time I have used this ATV to push snow (had an 07 sportsman 500 previously to push snow) and the check engine light came on. I have 41 miles and about 12 hours on this machine.

Here are the details.

I pushed my first driveway without any issues. I loaded the 850 onto the trailer, left it running and went to my next job which was about 15 miles away. It was still snowing when I left. When I got there, I hoped on, put it in reverse, hit the throttle and it died. No big deal, I started it back up, put it in reverse and tried again. The engine light came on and it ran fine as long as I didn't give it throttle. If I tried to throttle, it sounded like I was choking it out. I let off and it was fine (engine light now blinking).

So I took it home, ran the check and it gave me 520194 - 2 and 7 which relates to Throttle Safety Signal. The 520194-2 is the Signal out of Range and the 520194-7 is Throttle Stuck. The signal out of range I have no clue about. The throttle was not stuck because I could move it and I can hear it moving within the throttle body. So then I took the air filter off because thats what I always do when something doesn't run right and a mouse had made him a nice little home in there. The filter seemed like it was half off but I don't think anything got up in there. I put it back together and started it up and it ran fine. No engine light, nothing. So now I stared to wonder if I really had any issues with it. It was early in the morning plus it was a new ATV so I was guessing myself.

I went back out pushing snow but this time shut it off in between driveways. I pushed 3 more driveways and it did it again. Now I'm pissed. I figured out that if I just played with the throttle it would take off and run correctly but it continued to act up. I figured I spent an extra 2 hours just fighting thru the issue with the next 4 driveways.

I called the dealership I bought it from and they said to bring it in. Normally I would but the dealership is about 70 miles away. I'm wanting to know if anyone else has had this issue and how they fixed it. I don't want to drive all that way for a simple fix. The air box was dry, the plugs were dry, checked all the wires around the throttle and around the fuel injection and made sure they were all pushed in and connections tight. The fuel was the same I used in my truck with no issues. Any help or advice would be great! Thanks and sorry for the long ass story!
Reply With Quote
Sponsored Links
PolarisATVForums is the premier Polaris ATV Forum on the internet. Registered Users do not see these ads, So Register, It's Free!
  #2 (permalink)  
Old 03-09-2013, 02:57 PM
Moomba's Avatar
ATV Enthusiast
 
Member #33670
Join Date: Jan 2013
Location: Indiana
Posts: 78
I may have put this in the wrong thread!
Reply With Quote
  #3 (permalink)  
Old 03-09-2013, 09:34 PM
Amdforever's Avatar
Polaris ATV Junkie!
 
Member #26260
Join Date: May 2012
Location: Las Vegas, NV
Posts: 1,099
If its under warranty, I'd take it to them first. You messing with stuff could void any warranty claim after they realize you've been tampering with it. Much easier for them to say you did it while trying to fix it.
Reply With Quote
  #4 (permalink)  
Old 03-09-2013, 09:50 PM
Bruce!'s Avatar
Polaris ATV Legend
Premium Member
 
Member #193
Join Date: Feb 2009
Location: Port Angeles WA
Posts: 20,002
Welcome to the board!
Reply With Quote
  #5 (permalink)  
Old 03-10-2013, 05:38 AM
bgirard420's Avatar
Polaris ATV Legend
 
Member #11494
Join Date: Jan 2011
Location: Rhode Island
Posts: 4,608
Have you tried adjusting the throttle freeplay?
__________________
2013 Polaris XP 850 HO LE EPS
  • Full Ricochet Armor (Black Anodized), ATV GURU Cobra F & R Brush Guards, Polaris L&R rear box w/Backrest & Bags, Scrambler LE Hand Guards, Symtec Heat Demon Grips, Rotopax 2+2
2010 Polaris 500 HO
  • 25" GBC Spartacus, EPI Clutch Kit, Full Ricochet Armor, Polaris 2500 lb Winch Rear Box & Hand Guards, SuperATV Bumpers
Reply With Quote
  #6 (permalink)  
Old 03-10-2013, 06:29 AM
Diesel man 03's Avatar
Polaris ATV Junkie!
 
Member #7294
Join Date: Sep 2010
Location: Wisconsin
Posts: 1,487
Throttle free play seems to need attention.
Reply With Quote
  #7 (permalink)  
Old 03-10-2013, 06:53 PM
Moomba's Avatar
ATV Enthusiast
 
Member #33670
Join Date: Jan 2013
Location: Indiana
Posts: 78
The throttle seems to be OK. There is atleast 1/8" of free play in it. I'm just going to take it back to the dealer and let them mess with it. Thanks for the help!
Reply With Quote
  #8 (permalink)  
Old 06-10-2013, 10:23 PM
turboshelby's Avatar
Extreme ATV Enthusiast
 
Member #35082
Join Date: Mar 2013
Location: Nebraska
Posts: 172
Re: Check engine light on already!

Plowing snow usually involves a lot of lock to lock steering. Cable free play can change on tight turns, especially if the cable has been moved, like when you install a windshield etc.

Sent from my XT907 using Tapatalk 2
__________________
2009 850 EPS - 2500 miles and counting
2009 550 EPS - 8200 miles and counting
2006 500 EFI - 18,700 miles and *SOLD*
Reply With Quote
  #9 (permalink)  
Old 08-03-2013, 06:54 PM
gat's Avatar
gat gat is offline
ATV Enthusiast
 
Member #31463
Join Date: Oct 2012
Location: wells maine
Posts: 77
what was the problem on the 520194 - 2 code?
__________________
2011 sportsman xp eps stealth black
sti hds se wheels with swamplite tires
polaris deluxe rear bumper brushguard
polaris extreme front brushguard
lock & ride front cargo box
aluminum products a-arm gaurds
aluminum products skid plates
polaris 2500lb winch
k&n filter
Reply With Quote
Reply

Lower Navigation
Go Back   Polaris ATV Forum > Polaris ATV Technical Discussions > ATV Performance Modifications


Search tags for this page

2010 polaris 550 xp 520194 3

,

2013 moomba check engine light

,

2013 polaris 850 check engine light

,

2013 polaris sportsman 850 xp check engine light

,

2013 polaris sportsman xp 850 check engine light

,

520194 check lights polaris

,

check engine light

,

check engine light on my 2013 850 xp

,

polaris 520194 3 snowmobile

,

polaris 850xp throttle stuck code

,

polaris check engine codes

,

polaris sportsman 520194 2

Click on a term to search our sites for related topics.

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
Engine stalls/ check engine light flashes 2quick ATV Repair and Maintenance 4 05-26-2013 07:32 AM
Check engine light FuntanaS ATV General Discussion 2 10-17-2012 01:44 PM
Check engine light scott_r ATV Repair and Maintenance 3 05-13-2012 06:05 AM
Check engine light lilbuddy3 ATV General Discussion 4 04-05-2012 11:55 AM
hot/check engine light pottsville30 Polaris Sportsman 11 06-27-2010 12:39 PM

Motosport.com


All times are GMT -8. The time now is 09:03 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.