clutch drive or belt problems? - Polaris ATV Forum
ATV Repair and Maintenance Having problems? Doing a rebuild? All Repair/Maintenance Discussions here.

 
LinkBack Thread Tools Display Modes
post #1 of 1 (permalink) Old 09-06-2009, 09:05 PM Thread Starter
Junior Member
 
cowboy6885's Avatar
 
Join Date: Aug 2009
Location: south cakalacky
Posts: 1
Exclamation clutch drive or belt problems?

hey, ive got a 05 sportsman 400. The other day I was riding some extreme trails at a local ohv park and went through a litte bit of mud,"barely got the bottom of the clutch cover muddy", and it started to feel like the belt was slipping. By the time i limped back to the truck, it would barley move in high. So i assumed it was a worn belt or full of water. i got it in my shop and took the clutch cover off to look at the belt and to me it looks fine and there is no mud or water. My question is the side of the belt supposed to be shiny and flat, or have some sort of grip on the side of it? Also the bottom of the clutch cover is hitting the clutch housing, I started it with the cover off and noticed a small amount of vibration. Do I need to rebuild my clutch and get a new belt or just adjust it? Also before it started to slip is was having problems changing gears when riding hard, I had to let off the gas and it would change but jerk.

Last edited by cowboy6885; 09-06-2009 at 09:41 PM.
cowboy6885 is offline  
Sponsored Links
Advertisement
 
Reply

  Lower Navigation
Go Back   Polaris ATV Forum > Polaris ATV Technical Discussions > ATV Repair and Maintenance

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Polaris ATV Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome