2005 500 HO carb problems=wits' end - Polaris ATV Forum
ATV Repair and Maintenance Having problems? Doing a rebuild? All Repair/Maintenance Discussions here.

 
LinkBack Thread Tools Display Modes
post #1 of 6 (permalink) Old 01-26-2011, 06:46 AM Thread Starter
Junior Member
 
Mobuck's Avatar
 
Join Date: Jan 2011
Location: missouri
Posts: 5
2005 500 HO carb problems=wits' end

New here so give me a break and don't get too technical, please.
My 05 Sportsman 500 HO stalled out last October and would only run enough to get back to the barn by holding the choke open. I'm short on funds so didn't take the machine to the shop but asked the shop foreman who I've known for years about the problem. Before I'd listed all the symptoms, he called it a bad cam and said it took at least $800 to fix. Earlier this month, I came up with all the parts to replace the cam and associated parts. It wasn't that difficult for an old farmer but that didn't fix the problem. Looked inside the carb and the long jet rod thingy was broken off and just sitting in the hole in the bottom of the carb. Another parts order and I got the rod,2 plastic pieces, and a tiny E-clip. Put those in yesterday. It runs but has a stutter up to about 3000rpm and bogs slightly when revved from idle. I'm open for any suggestions.
Mobuck is offline  
Sponsored Links
Advertisement
 
post #2 of 6 (permalink) Old 01-26-2011, 07:12 AM
Polaris ATV Legend
 
Bruce!'s Avatar
 
Join Date: Feb 2009
Location: Port Angeles WA
Posts: 20,003
What me technical??? Welcome to the board!

I tried setting my password to "penis" but it said my password wasn't long enough...
Bruce! is offline  
post #3 of 6 (permalink) Old 01-26-2011, 01:16 PM
Polaris ATV Legend
 
4getful2's Avatar
 
Join Date: Aug 2009
Location: illinois
Posts: 2,261
that e-clip should be in the center position on the needle. it still sounds like it's not getting enough fuel. you could take the carb. apart and check the pilot jet(takes a skinny straight blade screwdriver) ,that's the smaller one next to the main jet. Also check the diaphragm on top of the carb. for cracks.
The needle valve rod that they sold you, did it have the same part numbers as the old one?
Check the order of install: washer,clip,washer,spring
4getful2 is offline  
Sponsored Links
Advertisement
 
post #4 of 6 (permalink) Old 01-26-2011, 04:37 PM Thread Starter
Junior Member
 
Mobuck's Avatar
 
Join Date: Jan 2011
Location: missouri
Posts: 5
They have numbers?(just kidding) I ordered the part listed for my year and model is all I know. Guess I got lucky on the jet rod by putting the E-clip in the middle groove by chance. If it gets warm enough for me to remove the carb w/o freezing my hands, I'll dump the gas and take it to a warmer area and take it apart. The diaphram didn't look too bad but still might have a leak. This is the first time I've dealt with this type of carb so I'm doing trial and error.
Mobuck is offline  
post #5 of 6 (permalink) Old 01-26-2011, 07:06 PM
Polaris ATV Junkie!
 
cookies's Avatar
 
Join Date: Oct 2010
Location: me
Posts: 1,104
are you talking about the needle? lol jetrod? for some reason i am now thinking about elroy from the jetsons...
cookies is offline  
post #6 of 6 (permalink) Old 01-27-2011, 04:56 AM Thread Starter
Junior Member
 
Mobuck's Avatar
 
Join Date: Jan 2011
Location: missouri
Posts: 5
Making light of incorrect terminology does not answer the question. I've called the SOB everything I can think of w/o making it better. I came to this forum hoping for some assistance but evidently it's not here. Guess I'll go somewhere else.
Mobuck is offline  
Reply

  Lower Navigation
Go Back   Polaris ATV Forum > Polaris ATV Technical Discussions > ATV Repair and Maintenance

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Polaris ATV Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Thread Thread Starter Forum Replies Last Post
Problems with the Sportsman 400 2005 zeclipik ATV Performance Modifications 2 07-12-2010 07:20 PM
new member with 2005 800 efi problems BOBSS396 ATV Repair and Maintenance 2 07-12-2010 06:58 PM
2005 800 sportsman problems HAZEE ATV New Members 8 06-23-2009 05:35 AM
2005 800 problems HAZEE ATV Repair and Maintenance 3 06-12-2009 06:37 PM
2005 800 problems HAZEE Polaris Sportsman 0 06-12-2009 04:54 AM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome