2007 Polaris Sportsman 500 H.O. EFI Acceleration Problems - Polaris ATV Forum
ATV Repair and Maintenance Having problems? Doing a rebuild? All Repair/Maintenance Discussions here.

 
LinkBack Thread Tools Display Modes
post #1 of 4 (permalink) Old 01-09-2017, 04:41 AM Thread Starter
Junior Member
 
cms3992's Avatar
 
Join Date: Jan 2017
Location: Phenix City, AL
Posts: 4
2007 Polaris Sportsman 500 H.O. EFI Acceleration Problems

I have a 2007 Polaris Sportsman 500 H.O. EFI 4x4 and it will start up and idle fine but when I attempt to accelerate the throttle it will die (cut-off). The battery was put in it last summer new but is weak and I will charge it this evening. However, I got this ATV from my brother in law and he related the sponge type air filter that was on the ATV was old and came apart and he thinks some of the pieces were sucked into the intake. However, he took it apart and did not see anything but he is not sure if any pieces went into the block through the big hole leading into the block from the intake. Again it starts fine and idles perfect but when you give it the gas it will cut off. Any assistance would be appreciated. Also, I see it has a medal type of gas filter on it can this be replaced with a clear see thru gas filter or not? Thank you Mike
cms3992 is offline  
Sponsored Links
Advertisement
 
post #2 of 4 (permalink) Old 01-09-2017, 07:00 AM
Polaris ATV Junkie!
 
cariboo's Avatar
 
Join Date: Jun 2012
Location: Bridge Lake BC
Posts: 828
check your throttle free play and if this doesn't help clean your carburator.
cariboo is offline  
post #3 of 4 (permalink) Old 01-09-2017, 10:31 AM Thread Starter
Junior Member
 
cms3992's Avatar
 
Join Date: Jan 2017
Location: Phenix City, AL
Posts: 4
Polaris Sportsman 500 EFI idles good but cuts off when the throttle is pushed to accelerate

Sir,
It is fuel injection.
cms3992 is offline  
Sponsored Links
Advertisement
 
post #4 of 4 (permalink) Old 01-11-2017, 07:56 AM Thread Starter
Junior Member
 
cms3992's Avatar
 
Join Date: Jan 2017
Location: Phenix City, AL
Posts: 4
2007 Polaris Sportsman 500 HO EFI

Yes, it is fuel injection
cms3992 is offline  
Reply

  Lower Navigation
Go Back   Polaris ATV Forum > Polaris ATV Technical Discussions > ATV Repair and Maintenance

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Polaris ATV Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Thread Thread Starter Forum Replies Last Post
Service manuals cookies ATV Repair and Maintenance 981 04-23-2017 11:10 AM
ASM-CLUSTER,110MM,W/FUEL (Speedo Cluster) FOR SALE KLCFLC Polaris Sportsman 1 11-21-2016 02:09 AM
3280431 ASM-CLUSTER,110MM,W/FUEL (Speedo Cluster) KLCFLC ATV New Members 0 11-19-2016 03:12 AM
2002 sportsman 500 bearing carrier fishnfool ATV Brakes & Suspension 2 07-13-2016 09:50 AM
Softer rear shocks/springs? Unitoo1 Polaris Sportsman 10 04-25-2016 04:20 AM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome