Polaris ATV Forum
Go Back   Polaris ATV Forum > Polaris ATV Technical Discussions > ATV Repair and Maintenance

ATV Repair and Maintenance Having problems? Doing a rebuild? All Repair/Maintenance Discussions here.

Reply
 
LinkBack Thread Tools Display Modes
  #1 (permalink)  
Old 02-04-2011, 08:23 AM
Polaris27's Avatar
Junior Member
 
Member #11696
Join Date: Feb 2011
Location: Michigan
Posts: 2
weak spark? Please help!

I just bought a 2003 Polaris Predator 500. The other day it stalled out while idling and when I tried to start it would only backfire and run then stall. I changed the spark plug but no change. If you let it sit it would start up and run perfect until you rode for about 30 seconds then stall and backfire. Since then it sat for two days and not it wont act up. I think it had weak spark and thought maybe a weak coil or bad CDI unit. Any help or pointers i would greatly appreciate.

Thanks
Reply With Quote
Sponsored Links
PolarisATVForums is the premier Polaris ATV Forum on the internet. Registered Users do not see these ads, So Register, It's Free!
  #2 (permalink)  
Old 02-04-2011, 09:37 AM
Hit.The.Gas's Avatar
Extreme ATV Enthusiast
 
Member #11694
Join Date: Feb 2011
Location: OHIO
Posts: 173
Do you have a good battery? Predators need a fully charged battery to run correctly. If the battery is not fully charged it will have symptoms very similar. ~Phil
Reply With Quote
  #3 (permalink)  
Old 02-04-2011, 10:06 AM
Polaris27's Avatar
Junior Member
 
Member #11696
Join Date: Feb 2011
Location: Michigan
Posts: 2
The battery was fully charged good. It happened after riding it for ten minutes and now it runs perfect and I haven't touched the battery since.
Reply With Quote
  #4 (permalink)  
Old 02-04-2011, 03:19 PM
DavTay's Avatar
ATV Enthusiast
 
Member #10823
Join Date: Jan 2011
Location: Jacksonville, FL
Posts: 49
Send a message via Yahoo to DavTay
Check the Cap to coil wire connection.

If the wire is rusty you would get an erratic weak spark.

If it is rusty you can cut a little off and reattach the cap.
Reply With Quote
  #5 (permalink)  
Old 02-07-2011, 05:07 AM
Hit.The.Gas's Avatar
Extreme ATV Enthusiast
 
Member #11694
Join Date: Feb 2011
Location: OHIO
Posts: 173
Did you check to see if you have 12 volts when the machine is running? If your battery is good and your bike isn't charging it will slowly drain it until it won't run. Then if you let it sit, the battery goes back up to 12 volts again and repeats. Just a thought.
Reply With Quote
Reply

Lower Navigation
Go Back   Polaris ATV Forum > Polaris ATV Technical Discussions > ATV Repair and Maintenance


Search tags for this page

diagnosis weak/no spark on a polaris atv

,
polaris 90 intermittent spark
,

polaris 90 intermittent spark#gsc.tab

,
polaris 90 predator light fire to plug
,

polaris predator 500 weak spark

,
polaris predator 90 isn't getting fire
,

polaris predator 90 weak spark

,

polaris predator intermittent spark

,

polaris sportsman 90 weak spark

,
poulan predator weak spark
,

predator 500 weak spark

,
weak spark
Click on a term to search our sites for related topics.

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
2000 Polaris Sportsman 90 No spark/weak kennyy ATV Repair and Maintenance 4 02-01-2011 04:42 AM
Weak spark ford_boy ATV Repair and Maintenance 0 10-14-2010 02:04 PM
weak suspension joecl41 ATV General Discussion 5 10-06-2010 06:13 PM
2005 Sportsman 400 w/weak/no spark issue HELP!! mspeer7 Polaris Sportsman 1 07-16-2010 04:36 PM
Sportsman 90 weak Spark prinsloos ATV New Members 3 05-24-2010 01:40 PM

Motosport.com


All times are GMT -8. The time now is 12:59 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.