02 Sportsman 500 H.O. Won't Shut Off - Polaris ATV Forum
ATV Repair and Maintenance Having problems? Doing a rebuild? All Repair/Maintenance Discussions here.

 
LinkBack Thread Tools Display Modes
post #1 of 8 (permalink) Old 05-21-2011, 08:48 AM Thread Starter
Extreme ATV Enthusiast
 
gmiller0737's Avatar
 
Join Date: Oct 2009
Location: Jacksonville,Florida
Posts: 170
02 Sportsman 500 H.O. Won't Shut Off

I recently purchased a nice used Sportsman 500 H.O. most times the engine will not shut off by turning the key off sometimes it will run for a minute or longer with the key off,Turns off normally with the switch on the handle bar what could cause this or is it made that way?
gmiller0737 is offline  
Sponsored Links
Advertisement
 
post #2 of 8 (permalink) Old 05-21-2011, 10:28 AM
Extreme ATV Enthusiast
 
ebaysnyper's Avatar
 
Join Date: Apr 2011
Location: sierra vista az
Posts: 212
Send a message via Yahoo to ebaysnyper
Sounds like a bad ground. Fallo the wires from the key inside the pod and keep an eye out for a groung not connnected. If you can't find one then replace the key switch

Sent from my Droid using Tapatalk

2007 sportsman 500 x2 efi
26" sadona ripsaws on 12" itp ss312's
3 headlight mod relay type
2500 Ib polaris winch
custom made "winch saver"
custom work light mod with lighted switch and 18 Watt lamps
custom stealth black shock covers
Front trunk locks Polaris Part #2874548 $7.50 each @ dealer
front rack rails converted to "U channel" strut for easy attachments
pure polaris HD front springs
ebaysnyper is offline  
post #3 of 8 (permalink) Old 05-26-2011, 03:43 AM Thread Starter
Extreme ATV Enthusiast
 
gmiller0737's Avatar
 
Join Date: Oct 2009
Location: Jacksonville,Florida
Posts: 170
It's fixed the problem was the ignition switch.
gmiller0737 is offline  
Sponsored Links
Advertisement
 
post #4 of 8 (permalink) Old 05-26-2011, 04:15 AM
Polaris ATV Junkie!
 
pjmartin's Avatar
 
Join Date: May 2010
Location: Pierrefonds Quebec
Posts: 505
Good thread. I now realize I have a problem I didn't know I had. The ignition switch on my 2001 500HO seems to control only the speedometer and indicator lights. The quad will start and stop with the kill/starter switch with the ignition switch in either on or off position. Thought it strange but the quad is new to me. Turning off the ignition switch doesn't kill the engine. Doesn't keep me from using the quad but I'll check it out next time I get the chance. Did you have to replace the ignition switch or was it just a bad connection. Would appreciate details of your fix.
pjmartin is offline  
post #5 of 8 (permalink) Old 05-26-2011, 04:58 AM Thread Starter
Extreme ATV Enthusiast
 
gmiller0737's Avatar
 
Join Date: Oct 2009
Location: Jacksonville,Florida
Posts: 170
On mine if you turn the key off slowly just before it got to the off position it would shut off normally but if you just turned it from run to off it would stay running unless it was turned off using the switch on the left handle bar,Got the new switch off eBay for around $50 shipped be cautious when shopping as there are used switches on there too for about the same $ I got a new one.
gmiller0737 is offline  
post #6 of 8 (permalink) Old 05-26-2011, 05:08 AM
Polaris ATV Junkie!
 
pjmartin's Avatar
 
Join Date: May 2010
Location: Pierrefonds Quebec
Posts: 505
Thanks
So your problem was the switch itself being bad.
I'll start my troubleshooting with the wiring and if I end up needing a new switch so be it.
pjmartin is offline  
post #7 of 8 (permalink) Old 05-26-2011, 08:01 AM
Polaris ATV Junkie!
 
pjmartin's Avatar
 
Join Date: May 2010
Location: Pierrefonds Quebec
Posts: 505
Just tested mine
-key off quad won't start
-key on all ok
-Quad running, turn key off quickly, no effect on engine but speedo turns off.
-Quad running, turn key slowly to off and engine stops when key hits about 80% of its travel, speedo turns off at same point

Looks like exactly the same problem. Not sure if it's worth fixing unless it can lead to complete switch failure down the road. It's like the switch travels too far and makes ignition contact again before the engine has stopped when the key's turned quickly. Turn the key slowly and everything's fine.
pjmartin is offline  
post #8 of 8 (permalink) Old 08-28-2012, 06:12 PM
Junior Member
 
BadjerJim's Avatar
 
Join Date: Aug 2012
Location: Chico, CA
Posts: 4
Thanks all for the info. This is exactly the problem I'm having. Odd: when the engine keeps running (key OFF), the kill switch won't stop the engine either. Quad is a yr 2002 Sportsman 500 HO.
BadjerJim is offline  
Reply

  Lower Navigation
Go Back   Polaris ATV Forum > Polaris ATV Technical Discussions > ATV Repair and Maintenance

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Polaris ATV Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Thread Thread Starter Forum Replies Last Post
Can I shut off the On-demand AWD on a 2009 Sportsman 500? buster634 Polaris Sportsman 20 06-17-2010 03:16 PM
94 sportsman boggs mid throttle/will not shut off ratherbflyn Polaris Sportsman 2 05-05-2010 09:11 AM
1995 sportsman 300 4x4 nd gas shut off s/w rickhise ATV Repair and Maintenance 3 02-28-2010 12:19 PM
07 Sportsman 500EFI Hot Gas Shut Down?? sporthog ATV Repair and Maintenance 1 09-01-2009 01:40 PM
08 Sportsman starter stick/shut down Garrett32 ATV Repair and Maintenance 1 06-15-2009 10:15 AM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome