Polaris ATV Forum
Go Back   Polaris ATV Forum > Polaris ATV Technical Discussions > ATV Repair and Maintenance

ATV Repair and Maintenance Having problems? Doing a rebuild? All Repair/Maintenance Discussions here.

Reply
 
LinkBack Thread Tools Display Modes
  #1 (permalink)  
Old 07-25-2011, 03:08 PM
mmcb's Avatar
Junior Member
 
Member #17097
Join Date: Jul 2011
Location: Wisconsin
Posts: 2
03 TrailBoss 330 ignition problem

Here it goes. I know the coil is good (new). I have reason to believe the CDI is good. (checked). I THINK the little switch by the flywheel (Name? Sort of like a "Hall-Effect" switch.) that signals the CDI when to fire the coil is good. Coil wire from CDI is always hot. Should it always be hot and if so what and how is the coil fired? (Got to either be a hot or a ground switching on and off to fire it and there is no ground. Or to be precise it is grounded all the time through the coil's frame. No seperate ground wire.) Thanks in advance for the help. This is for my 12 year-old son and I'm stumped on it.

P.S. No spark at all.
Reply With Quote
Sponsored Links
PolarisATVForums is the premier Polaris ATV Forum on the internet. Registered Users do not see these ads, So Register, It's Free!
  #2 (permalink)  
Old 07-25-2011, 04:35 PM
Bruce!'s Avatar
Polaris ATV Legend
Premium Member
 
Member #193
Join Date: Feb 2009
Location: Port Angeles WA
Posts: 20,001
Welcome to the board!
__________________
I tried setting my password to "penis" but it said my password wasn't long enough...
Reply With Quote
  #3 (permalink)  
Old 07-25-2011, 05:16 PM
mmcb's Avatar
Junior Member
 
Member #17097
Join Date: Jul 2011
Location: Wisconsin
Posts: 2
Thanks for the welcome Bruce. Any answers on whether that coil wire should be hot all the time? I am starting to think it might be the CDI after all since the coil is somehow getting 28 volts to it. (All the time which I still think is wrong because with only the hot wire and no negitive wire going to the coil the only way it can fire is if the hot goes dead at some point.)
Reply With Quote
Reply

Lower Navigation
Go Back   Polaris ATV Forum > Polaris ATV Technical Discussions > ATV Repair and Maintenance


Search tags for this page
polaris 330 cdi problems
,
polaris 330 coil
,
polaris 330 ignition problem
,

polaris 330 no ignition

,

polaris 330 trail boss ignition coil

,

polaris 330 trail boss no spark

,
polaris 330 trailboss no spark
,
polaris cdi trail boss
,
polaris trail boss 330 ignition problems
,

polaris trail boss 330 no spark

,

polaris trail boss 330 wiring

,
trail boss ignition system
Click on a term to search our sites for related topics.

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
'11 Sportsman 500 Ignition Problem twk87 Polaris Sportsman 12 05-16-2011 04:41 PM
1999 Sportsman 335 Ignition Spark Problem collins5637 Polaris Sportsman 1 02-27-2011 09:05 PM
1998 Sportsman ignition problem? Toyoranger ATV Repair and Maintenance 0 04-24-2010 02:07 PM
Preditor 90 ignition problem? jyarosz ATV Repair and Maintenance 1 12-03-2009 06:44 PM
Ignition problem Martin ATV Repair and Maintenance 13 09-24-2009 08:25 AM

Motosport.com


All times are GMT -8. The time now is 10:57 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.