1997 Polaris Xplorer problem - Polaris ATV Forum
ATV Repair and Maintenance Having problems? Doing a rebuild? All Repair/Maintenance Discussions here.

 
LinkBack Thread Tools Display Modes
post #1 of 1 (permalink) Old 10-11-2011, 11:15 AM Thread Starter
Junior Member
 
Kevin147's Avatar
 
Join Date: Jul 2011
Location: USA
Posts: 9
1997 Polaris Xplorer problem

I'm having trouble with my 97 Polaris Xplorer 500. I will put it in high gear with the shifter, take off in high, but when I get going, the engine will rev up and it will be in low gear. I slow down, and then it jerks back into high gear and does this everytime I'm riding. I'm not sure why its doing this, but I think it may have something to do with the clutch even though the clutch isn't making any noise. Someone please help me!!!!
Kevin147 is offline  
Sponsored Links
Advertisement
 
Reply

  Lower Navigation
Go Back   Polaris ATV Forum > Polaris ATV Technical Discussions > ATV Repair and Maintenance

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Polaris ATV Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Thread Thread Starter Forum Replies Last Post
1997 Polaris xplorer focushunter ATV General Discussion 24 03-31-2017 05:15 PM
1997 Polaris Xplorer problems Kevin147 ATV Repair and Maintenance 5 04-13-2014 04:00 AM
1997 Polaris Xplorer Forward Gear problem Kevin147 ATV Repair and Maintenance 0 10-09-2011 02:28 PM
1997 Polaris Xplorer Steering problem Kevin147 ATV Repair and Maintenance 7 07-17-2011 09:51 AM
1997 Polaris Xplorer 500 cazahollis ATVs For Sale 3 07-17-2010 06:08 PM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome