Transmission grinding 2003 Magnum 330 - Polaris ATV Forum
ATV Repair and Maintenance Having problems? Doing a rebuild? All Repair/Maintenance Discussions here.

 
LinkBack Thread Tools Display Modes
post #1 of 6 (permalink) Old 10-27-2011, 03:40 PM Thread Starter
Junior Member
 
MagnumRider's Avatar
 
Join Date: Oct 2011
Location: Jasper, Ga
Posts: 1
Unhappy Transmission grinding 2003 Magnum 330

Hi All,
Recently, my 2003 Magnum 330 4x4 starting grinding when I try to put it into high gear. Low gear is fine, as are reverse and park. Sometimes it goes right in but usually there is at least some grinding before you hear it pop into place. I've never seen anything about transmission fluid, but it would seem likely with an auto tranny. Any suggestions besides take it to the shop?
Thanks
MagnumRider is offline  
Sponsored Links
Advertisement
 
post #2 of 6 (permalink) Old 10-27-2011, 06:49 PM
Polaris ATV Legend
 
Bruce!'s Avatar
 
Join Date: Feb 2009
Location: Port Angeles WA
Posts: 20,003
Welcome to the board!

I tried setting my password to "penis" but it said my password wasn't long enough...
Bruce! is offline  
post #3 of 6 (permalink) Old 11-25-2011, 12:09 PM
Junior Member
 
swampdog69's Avatar
 
Join Date: Nov 2011
Location: chesapeake va
Posts: 1
did you get a answer on your trans i have a 330 magnuw with the same thing thanks
swampdog69 is offline  
Sponsored Links
Advertisement
 
post #4 of 6 (permalink) Old 10-24-2012, 08:27 AM
Junior Member
 
callsan's Avatar
 
Join Date: Oct 2012
Location: VA Beach
Posts: 1
I seem to be having the same issue...Anyone have a solution to this crazy probem? I haven't torn it apart yet....I want to try and find a fix before I tear it apart.
callsan is offline  
post #5 of 6 (permalink) Old 10-24-2012, 10:22 AM
Polaris ATV Legend
 
InRBigness's Avatar
 
Join Date: Sep 2010
Location: Winnipeg, Manitoba
Posts: 2,411
Check the adjustment rods as well as the bell crank on the top of the tranny. They sometimes get a crack in them that allows them to flex but keeps the rod from fully shifting into gear

12 Starfire Blue Sportsman 850XPHO LE EPS:
- Fender guards, 3500lb PolarisHD winch, Polaris hand warmers, Powermadd hand guards, HID lights, Guru Front Guard, Ricochet A-Arm guards, front L&R box, Uni Air Filter. 27" Black Diamonds, Odyssey Battery, Rhino front axles, QSC clutch kit

12 Bronze Mist Sportsman 850XPHO EPS
- 3500lb PolarisHD winch, Polaris hand warmers, Powermadd Hand guards, HID lights, Guru Front Guard, Ricochet A-Arm guards, Front L&R box, Uni Air Filter. 27" Black Diamonds, Odyssey Battery, Rhino front axles

08 Sportsman 500HO
-26" STI Black Diamond, Kimpex box with seat, Rack/Fender guards, Uni Air Filter, HID lights, Ricochet A-Arm guards, Polaris 3500HD, Polaris hand/thumb warmers, EPI clutch, Rhino front axles

01 500HO Plow Machine
-Kenda Bearclaws, Kimpex Plow, hand warmers, Warn winch

Faithful friends no longer with me:
94 Sportsman 400 4x4- owned 18 years
2000 Xplorer 400 4x4- owned 10 years
InRBigness is offline  
post #6 of 6 (permalink) Old 12-09-2012, 03:57 PM
Junior Member
 
nd48463's Avatar
 
Join Date: Dec 2012
Location: Mussey, MI
Posts: 3
I am having the same problem and am wondering if maybe it is related to the rear brakes?? I just bought my 2003 Magnum 4x4 and it sometimes grinds when putting it into high gear. It also needs rear brakes, so I was thinking that maybe they are related since you have to have the rear brakes on to engage high gear.
nd48463 is offline  
Reply

  Lower Navigation
Go Back   Polaris ATV Forum > Polaris ATV Technical Discussions > ATV Repair and Maintenance

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Polaris ATV Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Thread Thread Starter Forum Replies Last Post
I need a transmission for a 97 polaris magnum 425 4x4 barber878 ATV Parts for Sale 0 03-23-2011 07:11 AM
00 magnum 2X4 transmission clicking in neutral sassah ATV Repair and Maintenance 0 01-31-2011 04:33 PM
2002 magnum rmk transmission problems mech63s ATV Repair and Maintenance 3 01-01-2011 02:13 PM
2002 magnum 325 4x4 Transmission leak dude ATV New Members 1 12-16-2009 05:36 PM
WTB 325 Magnum transmission andrewspivey ATV Parts for Sale 2 10-30-2009 09:59 PM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome