phoenix backfire - Polaris ATV Forum
ATV Repair and Maintenance Having problems? Doing a rebuild? All Repair/Maintenance Discussions here.

 
LinkBack Thread Tools Display Modes
post #1 of 5 (permalink) Old 05-02-2009, 05:53 PM Thread Starter
Junior Member
 
rooter52's Avatar
 
Join Date: May 2009
Location: michigan
Posts: 1
phoenix backfire

The Phoenix has a problem with backfiring, and I know that I have seen posts that talk about this issue with the Phoenix and how to fix it. But, I can't find anything on this problem now. Does anyone remember what the issue is with this Quad?

thanks
rooter52 is offline  
Sponsored Links
Advertisement
 
post #2 of 5 (permalink) Old 05-02-2009, 10:26 PM
Polaris ATV Legend
 
Bruce!'s Avatar
 
Join Date: Feb 2009
Location: Port Angeles WA
Posts: 20,004
Welcome to the board!

I tried setting my password to "penis" but it said my password wasn't long enough...
Bruce! is offline  
post #3 of 5 (permalink) Old 05-03-2009, 02:22 PM
Extreme ATV Enthusiast
 
pony's Avatar
 
Join Date: Apr 2009
Location: mid-ga.
Posts: 441
what year is yours ? we have an 05 that was doing that . it was the etc switch in the throttle control . we had the dealership put the new [ 06 , they upgraded ] throttle control on it . if you have an 06 or newer you can try adjusting the switch . what spark plug are you using , we upgraded to a ngk cr6hsa.

mid-ga. dirt dobbers
see ya on the trail or track

time ta scramble on

Last edited by pony; 05-03-2009 at 02:46 PM.
pony is offline  
Sponsored Links
Advertisement
 
post #4 of 5 (permalink) Old 05-04-2009, 11:25 AM
Junior Member
 
Wildhorse800's Avatar
 
Join Date: May 2009
Location: Pennsylvania
Posts: 20
Should be able to at least look inside and watch to see if the switch is making contact when it shouldn't be.
Wildhorse800 is offline  
post #5 of 5 (permalink) Old 05-06-2009, 02:08 PM
Extreme ATV Enthusiast
 
pony's Avatar
 
Join Date: Apr 2009
Location: mid-ga.
Posts: 441
yeah , heard of some just takin the switch out .

mid-ga. dirt dobbers
see ya on the trail or track

time ta scramble on
pony is offline  
Reply

  Lower Navigation
Go Back   Polaris ATV Forum > Polaris ATV Technical Discussions > ATV Repair and Maintenance

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Polaris ATV Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome