Antifreeze smell - Polaris ATV Forum
ATV Repair and Maintenance Having problems? Doing a rebuild? All Repair/Maintenance Discussions here.

 
LinkBack Thread Tools Display Modes
post #1 of 8 (permalink) Old 02-19-2012, 12:44 PM Thread Starter
Extreme ATV Enthusiast
 
NORDFORD's Avatar
 
Join Date: Feb 2012
Location: Lincoln, NE
Posts: 263
Antifreeze smell

Hi guys, when I ride my 98 magnum 425 4x4, after a couple minutes, I can smell antifreeze. The radiator is full, the overflow tank is at the proper levels. I've got no signs of a leak anywhere. I'm wondering if it is because of where the over flow tank is located. Any other ideas?

Thanks guys.
NORDFORD is offline  
Sponsored Links
Advertisement
 
post #2 of 8 (permalink) Old 02-19-2012, 07:51 PM
Polaris ATV Legend
 
RENOBADBOY's Avatar
 
Join Date: Feb 2012
Location: Reno,Nev.
Posts: 1,565
Is there a fan? Is it working? Is there a thermostat like in a car? Is it overheating?? Is the overflow can to full and allowing fluid to come out and onto the exhaust? Just some things to look for.
RENOBADBOY is offline  
post #3 of 8 (permalink) Old 02-20-2012, 03:04 AM Thread Starter
Extreme ATV Enthusiast
 
NORDFORD's Avatar
 
Join Date: Feb 2012
Location: Lincoln, NE
Posts: 263
Overflow is at the minimum line and has been since I bought it. No change in fluid level , except after it is warmed up. Then it is a little higher. Radiator is full. There is a fan, are they supposed to run all the time or just when it reaches a certain temp? I will check on the thermostat.
NORDFORD is offline  
Sponsored Links
Advertisement
 
post #4 of 8 (permalink) Old 02-20-2012, 04:08 PM
Polaris ATV Legend
 
RENOBADBOY's Avatar
 
Join Date: Feb 2012
Location: Reno,Nev.
Posts: 1,565
The fan shouldn't run all the time. Is it?? It could be the seal in the pump leaking and it's getting onto the exhaust. That's usually the only way to smell the anti-freeze. Let's go from there.
RENOBADBOY is offline  
post #5 of 8 (permalink) Old 02-20-2012, 04:28 PM Thread Starter
Extreme ATV Enthusiast
 
NORDFORD's Avatar
 
Join Date: Feb 2012
Location: Lincoln, NE
Posts: 263
Thanks for the replies RENOBADBOY. Are you talking about the waterpump seal?
NORDFORD is offline  
post #6 of 8 (permalink) Old 02-20-2012, 04:38 PM Thread Starter
Extreme ATV Enthusiast
 
NORDFORD's Avatar
 
Join Date: Feb 2012
Location: Lincoln, NE
Posts: 263
The fan does not run all of the time
NORDFORD is offline  
post #7 of 8 (permalink) Old 02-20-2012, 04:54 PM
Polaris ATV Legend
 
RENOBADBOY's Avatar
 
Join Date: Feb 2012
Location: Reno,Nev.
Posts: 1,565
I bet it's the seal. Look under the quad for fluid on the bottom. How's the weather there?? I'm from Omaha originally.
RENOBADBOY is offline  
post #8 of 8 (permalink) Old 02-20-2012, 05:16 PM Thread Starter
Extreme ATV Enthusiast
 
NORDFORD's Avatar
 
Join Date: Feb 2012
Location: Lincoln, NE
Posts: 263
I will check the seal out.

The weather has been unbelievable. We have had maybe, and I mean maybe 10 days of below freezing. We've only had about 14-16" of snow as well. It has been really great and weird at the same time.
NORDFORD is offline  
Reply

  Lower Navigation
Go Back   Polaris ATV Forum > Polaris ATV Technical Discussions > ATV Repair and Maintenance

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Polaris ATV Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Thread Thread Starter Forum Replies Last Post
Gas smell C@TCH Polaris Magnum 4 12-21-2011 11:16 PM
New 550 Strong Gas Smell yackee ATV Repair and Maintenance 1 11-26-2011 06:46 PM
gas smell in oil. mhollerich Polaris XP 9 04-01-2011 07:36 PM
Smell gas when riding matushko Polaris Sportsman 2 02-18-2011 07:17 AM
Smell gas in oil JustB727 ATV Repair and Maintenance 6 09-22-2009 05:52 PM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome