2008 sportsman 500 HO not charging ??? - Polaris ATV Forum
ATV Repair and Maintenance Having problems? Doing a rebuild? All Repair/Maintenance Discussions here.

Reply
 
LinkBack Thread Tools Display Modes
post #1 of 11 (permalink) Old 05-10-2012, 06:31 AM Thread Starter
ATV Enthusiast
 
gixxerone's Avatar
 
Join Date: Nov 2011
Location: mass
Posts: 54
2008 sportsman 500 HO not charging ???

I hooked up a voltage meter and it says about 10 volts.....Is it just in need of a battery or a voltage rectifier ( aluminum finned module)?? What do you guys think???

2008 sportsman 500 carburated
gixxerone is offline  
Sponsored Links
Advertisement
 
post #2 of 11 (permalink) Old 05-10-2012, 08:29 AM
Polaris ATV Junkie!
 
fishhooker's Avatar
 
Join Date: Feb 2012
Location: Colorado
Posts: 806
10 volts with the machine off or running? 10 volts off needs a battery, 10 volts while running needs further investigation and information.

"Big Bad Wolf" 2004 Sportsman 700 EFI, Mine
"Lil' Red" 1999 Sportsman 335, The Wife's Ride
fishhooker is offline  
post #3 of 11 (permalink) Old 05-10-2012, 10:27 AM Thread Starter
ATV Enthusiast
 
gixxerone's Avatar
 
Join Date: Nov 2011
Location: mass
Posts: 54
Quote:
Originally Posted by fishhooker View Post
10 volts with the machine off or running? 10 volts off needs a battery, 10 volts while running needs further investigation and information.
10 volts at idle....
gixxerone is offline  
Sponsored Links
Advertisement
 
post #4 of 11 (permalink) Old 05-10-2012, 11:39 AM
Polaris ATV Legend
 
jordaman17's Avatar
 
Join Date: Mar 2011
Location: Renfrew, Ontario, Canada
Posts: 2,480
do the volts go up when you rev it up?

2016 Sportsman 450, Polaris front bumper, running on 26" Kenda Bearclaw htr's.
2010 Polaris Ranger 400, Super ATV Roof, running on 26" Maxxis Zilla's.



(sold August 17th, 2015 ) 5490km 2008 Polaris Sportsman 500 Ho, Polaris Hand & Thumb warmers, RotoPax 4 Gallon Fuel Pack, Custom Made Rear Bumper, PowerMadd Hand Guards, Polaris Rear Work Lights, Ricochet Ultimate Armor, Polaris 3500lb Winch, Rear Rack Extender, Polaris Brush Guard, 3 Headlight Mod, Uni Air Filter, EPI 'patv1' primary clutch spring. All up on Interco Swamplites!

Subscribe to my youtube channel! ---> http://www.youtube.com/user/mudsling...ew=0&flow=grid
jordaman17 is offline  
post #5 of 11 (permalink) Old 05-10-2012, 01:49 PM Thread Starter
ATV Enthusiast
 
gixxerone's Avatar
 
Join Date: Nov 2011
Location: mass
Posts: 54
Quote:
Originally Posted by jordaman17 View Post
do the volts go up when you rev it up?
Yes! It goes to about 13.6 when reved up.......
gixxerone is offline  
post #6 of 11 (permalink) Old 05-10-2012, 03:33 PM
Polaris ATV Legend
 
jordaman17's Avatar
 
Join Date: Mar 2011
Location: Renfrew, Ontario, Canada
Posts: 2,480
your stator may be going bad, at idle you should be reading 14v plus, and 15 and up reving.

2016 Sportsman 450, Polaris front bumper, running on 26" Kenda Bearclaw htr's.
2010 Polaris Ranger 400, Super ATV Roof, running on 26" Maxxis Zilla's.



(sold August 17th, 2015 ) 5490km 2008 Polaris Sportsman 500 Ho, Polaris Hand & Thumb warmers, RotoPax 4 Gallon Fuel Pack, Custom Made Rear Bumper, PowerMadd Hand Guards, Polaris Rear Work Lights, Ricochet Ultimate Armor, Polaris 3500lb Winch, Rear Rack Extender, Polaris Brush Guard, 3 Headlight Mod, Uni Air Filter, EPI 'patv1' primary clutch spring. All up on Interco Swamplites!

Subscribe to my youtube channel! ---> http://www.youtube.com/user/mudsling...ew=0&flow=grid

Last edited by jordaman17; 05-10-2012 at 03:35 PM.
jordaman17 is offline  
post #7 of 11 (permalink) Old 05-10-2012, 04:56 PM Thread Starter
ATV Enthusiast
 
gixxerone's Avatar
 
Join Date: Nov 2011
Location: mass
Posts: 54
Quote:
Originally Posted by jordaman17 View Post
your stator may be going bad, at idle you should be reading 14v plus, and 15 and up reving.
The original owner told me that it spikes to 16-17v when reved up high.....
gixxerone is offline  
post #8 of 11 (permalink) Old 05-10-2012, 05:45 PM Thread Starter
ATV Enthusiast
 
gixxerone's Avatar
 
Join Date: Nov 2011
Location: mass
Posts: 54
Where is the voltage regulator located? Just under the speedometer pod or second one down aluminum with fins (says pure power on it).....?
gixxerone is offline  
post #9 of 11 (permalink) Old 05-10-2012, 06:56 PM
Polaris ATV Legend
 
jordaman17's Avatar
 
Join Date: Mar 2011
Location: Renfrew, Ontario, Canada
Posts: 2,480
Quote:
Originally Posted by gixxerone View Post
Quote:
Originally Posted by jordaman17 View Post
your stator may be going bad, at idle you should be reading 14v plus, and 15 and up reving.
The original owner told me that it spikes to 16-17v when reved up high.....
i did say 15 and up, but if it was getting up to that that sounds like a voltage regulator

2016 Sportsman 450, Polaris front bumper, running on 26" Kenda Bearclaw htr's.
2010 Polaris Ranger 400, Super ATV Roof, running on 26" Maxxis Zilla's.



(sold August 17th, 2015 ) 5490km 2008 Polaris Sportsman 500 Ho, Polaris Hand & Thumb warmers, RotoPax 4 Gallon Fuel Pack, Custom Made Rear Bumper, PowerMadd Hand Guards, Polaris Rear Work Lights, Ricochet Ultimate Armor, Polaris 3500lb Winch, Rear Rack Extender, Polaris Brush Guard, 3 Headlight Mod, Uni Air Filter, EPI 'patv1' primary clutch spring. All up on Interco Swamplites!

Subscribe to my youtube channel! ---> http://www.youtube.com/user/mudsling...ew=0&flow=grid
jordaman17 is offline  
post #10 of 11 (permalink) Old 05-10-2012, 07:09 PM
Polaris ATV Legend
 
jordaman17's Avatar
 
Join Date: Mar 2011
Location: Renfrew, Ontario, Canada
Posts: 2,480
Quote:
Originally Posted by gixxerone View Post
Where is the voltage regulator located? Just under the speedometer pod or second one down aluminum with fins (says pure power on it).....?
fins on it.

2016 Sportsman 450, Polaris front bumper, running on 26" Kenda Bearclaw htr's.
2010 Polaris Ranger 400, Super ATV Roof, running on 26" Maxxis Zilla's.



(sold August 17th, 2015 ) 5490km 2008 Polaris Sportsman 500 Ho, Polaris Hand & Thumb warmers, RotoPax 4 Gallon Fuel Pack, Custom Made Rear Bumper, PowerMadd Hand Guards, Polaris Rear Work Lights, Ricochet Ultimate Armor, Polaris 3500lb Winch, Rear Rack Extender, Polaris Brush Guard, 3 Headlight Mod, Uni Air Filter, EPI 'patv1' primary clutch spring. All up on Interco Swamplites!

Subscribe to my youtube channel! ---> http://www.youtube.com/user/mudsling...ew=0&flow=grid

Last edited by jordaman17; 05-10-2012 at 07:16 PM.
jordaman17 is offline  
Reply

  Lower Navigation
Go Back   Polaris ATV Forum > Polaris ATV Technical Discussions > ATV Repair and Maintenance

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Polaris ATV Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Thread Thread Starter Forum Replies Last Post
Sportsman over charging Dawdyservices ATV Repair and Maintenance 4 01-21-2012 05:55 PM
02 Sportsman charging help headusher ATV Repair and Maintenance 2 05-10-2011 09:48 AM
07 sportsman 90 Not Charging dirttracker ATV Repair and Maintenance 0 09-07-2010 06:15 AM
sportsman 400 not charging hondafan Polaris Sportsman 0 04-26-2010 04:49 PM
94 sportsman 400 not charging hairy32 ATV Repair and Maintenance 3 04-08-2010 02:49 PM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome