Polaris ATV Forum
Go Back   Polaris ATV Forum > Polaris ATV Technical Discussions > ATV Repair and Maintenance

ATV Repair and Maintenance Having problems? Doing a rebuild? All Repair/Maintenance Discussions here.

Reply
 
LinkBack Thread Tools Display Modes
  #1 (permalink)  
Old 07-14-2012, 12:11 AM
bigtime's Avatar
Extreme ATV Enthusiast
 
Member #14353
Join Date: Apr 2011
Location: Michigan
Posts: 246
800 wont idle but no engine codes

I had my 2011 sportsman 800 rebuilt for the second time 2 weeks ago and finally got it back. I went on Wednesday for a trail ride of about 90 miles. I went to St. Helen MI and rode from there to Roscommon and back, then to Rose City and back. I had enough time I thought what the heck I will ride to Houghton Lake and back and call it a day.

Well on the way back from Rose City the machine seemed to hickup a little at a couple stop signs but I thought well maybe I am just being paranoid because of all the problems I have had with this machine. Anyway I filled back up with gas in St. Helen at the trailer and took off towards Houghton Lake. At the first stop sign when I stopped it came back to idle and really started chugging and eventually stalled itself out. I restarted it and again it idled for a second then stalled itself out. No check engine light or anything. The next time I tried to restart it, it almost didnt want to go so I headed back to the trailer. Well as long as you are on the gas it is fine it just wont stay running unless you keep it over 2500 rpms.

I loaded it back up and headed home to Birch Run. By the time I got back the motor was cold so I tried to start it again on the trailer. It would roll over but literally would not start until I kept tapping the throttle then it would start. As soon as you let off the throttle it would stall immediately. Still no engine codes or check engine light. I took it back to the dealer immediately since it is still under the extended warranty.

Now I know a lot of guys would probably say its a sensor and I would agree but how come no codes or check engine lights? Back before the first top end rebuild it tried dying twice randomly in a row that day but came back on. No engine codes and no check engine light. The first time for the rebuild was a dead right cylinder that was believed to be due to cylinder wash out from too much fuel. Never did find a cause of it. The mechanic at that dealer said he found that the ECU was never grounded to the chasis.

The second rebuild was due to a bad rebuild the first time and that dealer didnt want to do anything about it just for me to keep adding oil to it. When I told the new dealer mechanic about all that had happened. He is feared that the ECU may not be functioning right. When I first got the machine it would barely idle and would stall unless it was warmed up, the cutting out randomly 2 times, the ground not being connected on the ECU, the cylinder washing out, now it wont idle again after 75 miles on new rebuild and just the general lack of any check engine lights or engine codes.

Do you think he may be on the right track? The only other thing I have done is after the 2nd rebuild I got it home and put my new QSC muffler on it. I was told by Adam and the paperwork that came with it that I didnt need a fuel controller. Like I said it never popped ever and when I got it home and it wouldnt start I pulled the plug on the right cylinder and it was tan so I really dont think that the muffler had anything to do with it. I was a little concerned that if it was too lean I may have burned to exhaust valves but I really dont think any of that happened.

I know he will check it out good and figure out what is wrong but what do you guys think?

Bigtime
__________________
2011 Sportsman 800 EFI:

Front and Rear Polaris brush guards
STI HD 1 wheels
26x9 STI Mudtrax XL
26x11 STI Mudtrax XL
K&N Air Filter
Venom #3000 Winch with synthetic rope
DDM Tuning 6000k HID kit
3 Headlight Mod
Polaris Rear Rack Extender
QSC cluth kit
Reply With Quote
Sponsored Links
PolarisATVForums is the premier Polaris ATV Forum on the internet. Registered Users do not see these ads, So Register, It's Free!
  #2 (permalink)  
Old 07-14-2012, 12:39 AM
bigtime's Avatar
Extreme ATV Enthusiast
 
Member #14353
Join Date: Apr 2011
Location: Michigan
Posts: 246
Well upon more reading in the forums I found that the symptoms I have are probably caused by a misadjusted ETC. Never even thought of that. I am also betting that will not throw an engine code if it is tripped. Any thoughts

Bigtime
__________________
2011 Sportsman 800 EFI:

Front and Rear Polaris brush guards
STI HD 1 wheels
26x9 STI Mudtrax XL
26x11 STI Mudtrax XL
K&N Air Filter
Venom #3000 Winch with synthetic rope
DDM Tuning 6000k HID kit
3 Headlight Mod
Polaris Rear Rack Extender
QSC cluth kit
Reply With Quote
  #3 (permalink)  
Old 07-14-2012, 05:26 AM
SMP63's Avatar
Polaris ATV Junkie!
 
Member #13545
Join Date: Mar 2011
Location: Zephyrhills,Fl.
Posts: 1,387
I'd say your right on the money with the ETC needing adjustment!!!!! Also correct about it not throwing codes for that problem.
__________________
2011 Sportsman 500 H.O. Green
14" STI Wheels-26" Mud Trax X/L's
2500# polaris winch
Ricochet a-arm guards
Rev. override kit
Hid 3 light kit
3 light mod. w/relay

Uni air filter on both

Wifes
2011 Sportsman 500 H.O. Red
Ricochet a-arm guards
Hid 3 light kit
3 light mod. w/relay
Winch,wheels & tires still to go!
Reply With Quote
  #4 (permalink)  
Old 07-14-2012, 08:30 PM
Picpic's Avatar
Extreme ATV Enthusiast
 
Member #22123
Join Date: Jan 2012
Location: Stockholm
Posts: 160
Sounds like ETC, had the same problem once, was ETC
Reply With Quote
  #5 (permalink)  
Old 07-16-2012, 06:21 AM
bigtime's Avatar
Extreme ATV Enthusiast
 
Member #14353
Join Date: Apr 2011
Location: Michigan
Posts: 246
Talked to the mechanic this morning and he did find a code stored in the computer for the TPS. He said while running the machine you could wiggle the wires in the harness for the TPS and the machine would cut in and out and would pop up an engine code for it. Maybe I just didnt see it while riding.

Anyway he repaired the harness and he said he has been running it on and off all morning with no problems. At least it sounds like an easy fix.

Bigtime
__________________
2011 Sportsman 800 EFI:

Front and Rear Polaris brush guards
STI HD 1 wheels
26x9 STI Mudtrax XL
26x11 STI Mudtrax XL
K&N Air Filter
Venom #3000 Winch with synthetic rope
DDM Tuning 6000k HID kit
3 Headlight Mod
Polaris Rear Rack Extender
QSC cluth kit
Reply With Quote
  #6 (permalink)  
Old 07-16-2012, 08:23 AM
vortecz71wv's Avatar
Polaris ATV Junkie!
 
Member #14032
Join Date: Apr 2011
Location: Morgantown, WV
Posts: 1,182
Lets hope man! I just fixed the wifes 550 TPS and adjusted it as well as tuned it in on my 800. Way better throttle response now and idles way smoother!!!

Matt
__________________
Mine:

2011 Sportsman 800
Polaris Front Brush Guard, Polaris Rear Brush Guard, Polaris Rear Rack Extender, Polaris L&R Rear Cargo Box, Warn 2500lb winch, Winch Saver, Ricochet A-Arm Guards (www.TheATVSuperStore.com), 3-High Headlight Mod, 6000k HID kit, Rigid Ind. 2xDually w/ strobe box, UNI Air Filter, 26" GBC Dirt Commanders, 1" Billet Wheel Spacers (Front and Rear) HighLifter HD springs, Dalton Primary Spring O\BL, Realtree Seat custom cover, Polaris Handguards

Wife's

2011 Sportsman 550XP
Polaris Front Brush Guard, Polaris Rear Brush Guards, Polaris Rear Rack Extender, 26" GBC Grim Reapers, Viper Elite 3000lbs Winch w/ wireless, Polaris Handguards, 6000k HID Kit

Fuel It, Flog It, Feel It!
Reply With Quote
Reply

Lower Navigation
Go Back   Polaris ATV Forum > Polaris ATV Technical Discussions > ATV Repair and Maintenance


Search tags for this page
2010 polaris rzr 800 wont stay idle
,
2011 polaris ranger 800 rough idle
,
2011 polaris sportsman 800 efi rebuild engine
,
polaris ranger 800 will not idle
,
polaris razor 800 wont idle
,
polaris rzr 800 won't idle
,

polaris rzr 800 wont idle

,

polaris rzr wont idle

,

polaris sportsman 800 wont idle

,
rough idling and dieing will not start polaris ranger 800
,
rzr runs rough after rebuild
,

rzr wont idle

Click on a term to search our sites for related topics.

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
engine codes Nobike Polaris XP 4 10-20-2014 02:19 PM
1995 Sportsman 400 4x4 wont idle but will get scary off idle. darrin5 ATV Repair and Maintenance 5 02-27-2012 07:01 AM
Check Engine Codes? thole15 Polaris Sportsman 0 02-20-2012 03:02 PM
reading engine codes? nvhunter Polaris XP 1 07-05-2011 07:42 AM
2005 sportsman efi 700 engine codes 21 and 42 and 4wd inop hammerhead Polaris Sportsman 0 05-03-2010 04:33 PM

Motosport.com


All times are GMT -8. The time now is 02:44 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.