Polaris ATV Forum
Go Back   Polaris ATV Forum > Polaris ATV Technical Discussions > ATV Repair and Maintenance

ATV Repair and Maintenance Having problems? Doing a rebuild? All Repair/Maintenance Discussions here.

Reply
 
LinkBack Thread Tools Display Modes
  #1 (permalink)  
Old 08-17-2012, 05:21 AM
Polaris_Sweden's Avatar
Junior Member
 
Member #29122
Join Date: Aug 2012
Location: Northern Sweden
Posts: 1
Polaris Sportsman 800 EFI X2, Only runs at idle

As the topic, I've got a SP 800 EFI x2 - 2008 That dies as soon as i hit the throttle, it idle just fine. It's something whit the ignition... I've tried a diffrent TPC and all the sensors on the trottle body.

Any ideas?

Greetings from Sweden

/Robert
Reply With Quote
Sponsored Links
PolarisATVForums is the premier Polaris ATV Forum on the internet. Registered Users do not see these ads, So Register, It's Free!
  #2 (permalink)  
Old 08-28-2012, 06:07 PM
curtwpk's Avatar
Extreme ATV Enthusiast
 
Member #17079
Join Date: Jul 2011
Location: Woodland Park, Colorado
Posts: 307
Fuel Filter?
Fuel Pump?
Check Fuel Pressure at injector rail?
Reply With Quote
  #3 (permalink)  
Old 08-29-2012, 12:02 PM
Picpic's Avatar
Extreme ATV Enthusiast
 
Member #22123
Join Date: Jan 2012
Location: Stockholm
Posts: 159
Have you downloaded the error codes. Might give a lead on where to start
Reply With Quote
  #4 (permalink)  
Old 08-29-2012, 05:24 PM
Bruce!'s Avatar
Super Moderator
Premium Member
 
Member #193
Join Date: Feb 2009
Location: Port Angeles WA
Posts: 19,203
Welcome to the board!
Reply With Quote
  #5 (permalink)  
Old 08-31-2012, 01:25 AM
MaineJim's Avatar
Junior Member
 
Member #27949
Join Date: Jul 2012
Location: Central Maine Highlands
Posts: 13
I would be looking at the fuel filter first,a clogged one will cause a vehicle to do exactly
what yours is doing.
It might not be the cause but that would be first thing i would check ,then the rest as suggested.
Reply With Quote
Reply

Lower Navigation
Go Back   Polaris ATV Forum > Polaris ATV Technical Discussions > ATV Repair and Maintenance


Search tags for this page
2008 polaris ranger 700cc, running rough at idle
,
2008 polaris sportsman 800 efi idles rough
,

2009 polaris 800 efi sportsman runs rough back fires

,
800 efi sportsman wont run if u give throttle
,

polaris 400 will not run wide open

,
polaris 800 efi running rough
,

polaris 800 efi will only idle press throttle it dies

,

polaris sportsman 800 running rough

,

polaris stortsman 800 efi idles dont rev at all

,
sportsman 800 idle rough injectors
,
what should 2009 polaris sportsman 800 idle at
,
what would cause a polaris rzr 800 efi to backfire
Click on a term to search our sites for related topics.

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
2011 550XP won't idle runs rough after a couple minutes muddinger Polaris XP 0 05-13-2012 04:28 PM
2002 700 sportsman runs rough at idle and backfires Floyd32 ATV New Members 6 09-30-2011 04:41 AM
2009 Polaris Sportsman starts, idle and runs excellent...for 1/2 hour then shuts off. NugZilla81 ATV Repair and Maintenance 10 09-20-2011 04:01 AM
96' Polaris Sportsman 4x4 400 Only runs with Choke Pulled Tspang80 Polaris Sportsman 3 12-05-2010 05:42 AM
96' Polaris Sportsman 4x4 400 Runs WIDE OPEN!!! Tspang80 Polaris Sportsman 9 12-03-2010 09:28 AM

Motosport.com


All times are GMT -8. The time now is 06:20 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.