How to change oil on a 2000 Magnum 325??? - Polaris ATV Forum
ATV Repair and Maintenance Having problems? Doing a rebuild? All Repair/Maintenance Discussions here.

Reply
 
LinkBack Thread Tools Display Modes
post #1 of 14 (permalink) Old 06-13-2010, 08:42 PM Thread Starter
Junior Member
 
drew's Avatar
 
Join Date: Jun 2010
Location: ny
Posts: 7
How to change oil on a 2000 Magnum 325???

Hi Everyone,
I've purchased a 2000 Polaris Magnum 325 and I do not have a owners manual...I want to change the oil myself ASAP and would appreciate any guidance!
I am new here and look forward to future communications...
Thanks!!!
drew is offline  
Sponsored Links
Advertisement
 
post #2 of 14 (permalink) Old 06-13-2010, 09:15 PM
Polaris ATV Legend
 
Bruce!'s Avatar
 
Join Date: Feb 2009
Location: Port Angeles WA
Posts: 20,004
Welcome to the board!

I tried setting my password to "penis" but it said my password wasn't long enough...
Bruce! is offline  
post #3 of 14 (permalink) Old 06-14-2010, 02:00 PM Thread Starter
Junior Member
 
drew's Avatar
 
Join Date: Jun 2010
Location: ny
Posts: 7
Thanks!!!
drew is offline  
Sponsored Links
Advertisement
 
post #4 of 14 (permalink) Old 06-14-2010, 02:05 PM Thread Starter
Junior Member
 
drew's Avatar
 
Join Date: Jun 2010
Location: ny
Posts: 7
I plan on getting the new Filter and oil Wednesday...
So if anyone has some tips/hints it would be much appreciated. Looked it over today...I see the filter and the fill hole...mainly what I need to know is;
Where is the drain plug?
drew is offline  
post #5 of 14 (permalink) Old 06-14-2010, 04:10 PM
Extreme ATV Enthusiast
 
scott09's Avatar
 
Join Date: Dec 2009
Location: Newfoundland Canada
Posts: 120
the drain plug is on the bottom of the engine. there is a hole in the plastic guard, not sure what size the bolt is, i used a socket and ratchet and it came out no problem. there was some mess from the filter but nothing some cleaner could not take off when the new filter was installed. 0w30 synteic oil should be used.

2000 magnum 325 4x4 Hunter Green
2009 sportsman 500 efi x2 Red
2009 hyundai elantra touring Red
2000 Ford f150 Flare side 5.4l 4X4
scott09 is offline  
post #6 of 14 (permalink) Old 06-14-2010, 05:29 PM Thread Starter
Junior Member
 
drew's Avatar
 
Join Date: Jun 2010
Location: ny
Posts: 7
Quote:
Originally Posted by scott09 View Post
the drain plug is on the bottom of the engine. there is a hole in the plastic guard, not sure what size the bolt is, i used a socket and ratchet and it came out no problem. there was some mess from the filter but nothing some cleaner could not take off when the new filter was installed. 0w30 synteic oil should be used.
Thanks for the Help; Much appreciated!!!
Just to clarify on the drain plug...I do not have access right now, but;
if I am looking at the ATV from the front, my oil fill is on the right side and my oil filter on the left side...is the drain plug directly in between them on the bottom of the engine?
Just want to make sure I don't take the wrong bolt out...
Thanks again!
drew is offline  
post #7 of 14 (permalink) Old 06-14-2010, 06:22 PM
Extreme ATV Enthusiast
 
scott09's Avatar
 
Join Date: Dec 2009
Location: Newfoundland Canada
Posts: 120
about 6-8 inchs back from the filter in the middle

2000 magnum 325 4x4 Hunter Green
2009 sportsman 500 efi x2 Red
2009 hyundai elantra touring Red
2000 Ford f150 Flare side 5.4l 4X4

Last edited by scott09; 06-14-2010 at 06:27 PM.
scott09 is offline  
post #8 of 14 (permalink) Old 06-14-2010, 07:48 PM Thread Starter
Junior Member
 
drew's Avatar
 
Join Date: Jun 2010
Location: ny
Posts: 7
Quote:
Originally Posted by scott09 View Post
about 6-8 inchs back from the filter in the middle
Cool! I am sure you've saved me a lot of time and troubles...Thanks again!
drew is offline  
post #9 of 14 (permalink) Old 06-15-2010, 06:48 PM Thread Starter
Junior Member
 
drew's Avatar
 
Join Date: Jun 2010
Location: ny
Posts: 7
Quote:
Originally Posted by scott09 View Post
the drain plug is on the bottom of the engine. there is a hole in the plastic guard, not sure what size the bolt is, i used a socket and ratchet and it came out no problem. there was some mess from the filter but nothing some cleaner could not take off when the new filter was installed. 0w30 synteic oil should be used.
Hi,
I am happy to say I got to the oil change today and had no problems getting it done...THANKS again!
BTW, (for anyone reading this thread in the future) I found a 9/16 socket did the trick...

Take care for now, Drew
drew is offline  
post #10 of 14 (permalink) Old 08-11-2011, 11:31 AM
Junior Member
 
Plus1's Avatar
 
Join Date: Aug 2011
Location: USA
Posts: 4
Lightbulb Fyi

User Manuals available @ Official Global Website For Polaris ATVs, RANGER Vehicles, Snowmobiles, & Victory Motorcycles
They are free to download for registered users.
1. Login
2. Place mouse over "Rider's Guide" Located in 2 places. Top bar and bottom bar on home page.
3. Click "Manuals & Parts"
4. enter fill in fields: "Vehicle Type, Manual Type, Model Year"
( it lists service manuals, but only user manuals worked for me)

You can also find online parts catalog on the same page.
Plus1 is offline  
Reply

  Lower Navigation
Go Back   Polaris ATV Forum > Polaris ATV Technical Discussions > ATV Repair and Maintenance

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Polaris ATV Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Thread Thread Starter Forum Replies Last Post
2000 Magnum 325 Temp Light z27651 ATV Repair and Maintenance 7 04-04-2010 09:42 PM
Steering On a 2000 325 Magnum bert ATV Repair and Maintenance 2 11-22-2009 05:29 AM
2000 polaris magnum 325 clutch problem cpr210 ATV Repair and Maintenance 0 11-08-2009 04:51 PM
2000 Magnum 325 4-wheel drive system Putt400 ATV Repair and Maintenance 3 10-14-2009 07:08 PM
2000 magnum 335 online schematics jmjoppich ATV New Members 1 03-29-2009 01:17 AM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome