AWD problem 2008 Sportman 300 - Polaris ATV Forum
ATV Repair and Maintenance Having problems? Doing a rebuild? All Repair/Maintenance Discussions here.

 
LinkBack Thread Tools Display Modes
post #1 of 4 (permalink) Old 07-27-2009, 07:04 AM Thread Starter
Junior Member
 
Jamieg's Avatar
 
Join Date: Jul 2009
Location: MA
Posts: 27
AWD problem 2008 Sportman 300

I was out riding my 2008 sportsman 300 when i flicked it into AWD (from a stop) and pow! the bike stalled and there was no electrical power at all. had it towed back home and put it back into 2x4 and replaced the fuse. i turned the key on and it started right up, but when i hit the AWD switch it blew the fuse and died again. anyone have that problem? could it be the wiring harness or the coil? I was ridding in some wet terain. any help would be appreciated. thanks
Jamieg is offline  
Sponsored Links
Advertisement
 
post #2 of 4 (permalink) Old 07-27-2009, 09:31 AM Thread Starter
Junior Member
 
Jamieg's Avatar
 
Join Date: Jul 2009
Location: MA
Posts: 27
Brought it back to the dealer and they said the wire going into the coil was pinched from who ever assembled it at the factory. So when i rode it a while the insulation on the wire wore off and shorted out. So it was only a minor problem thank god.
Jamieg is offline  
post #3 of 4 (permalink) Old 07-27-2009, 10:50 AM
Polaris ATV Legend
 
Bruce!'s Avatar
 
Join Date: Feb 2009
Location: Port Angeles WA
Posts: 20,003
And welcome to the board!

I tried setting my password to "penis" but it said my password wasn't long enough...
Bruce! is offline  
Sponsored Links
Advertisement
 
post #4 of 4 (permalink) Old 05-28-2013, 08:56 PM
Junior Member
 
woxof's Avatar
 
Join Date: Apr 2013
Posts: 4
Thanks for the update on the problem. Nice to have someone adding to the knowledge base.
woxof is offline  
Reply

  Lower Navigation
Go Back   Polaris ATV Forum > Polaris ATV Technical Discussions > ATV Repair and Maintenance

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Polaris ATV Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome