Stalling, sputtering, and back firing - Polaris ATV Forum
Polaris ATV Forum
Go Back   Polaris ATV Forum > Polaris ATV Technical Discussions > ATV Repair and Maintenance

ATV Repair and Maintenance Having problems? Doing a rebuild? All Repair/Maintenance Discussions here.

Reply
 
LinkBack Thread Tools Display Modes
  #1 (permalink)  
Old 05-20-2016, 03:42 PM
Mblake08's Avatar
Junior Member
 
Member #65178
Join Date: Feb 2016
Location: Pickerington, ohio
Posts: 2
Stalling, sputtering, and back firing

Ok guys. I've been reading these forums for 2 hours. I'm down at hatfield McCoy in West Virginia. Riding my 2012 sportsman 800. Been fine all day. Blew the belt which I knew I needed to change. Put my replacement one on. And ride for another hour then the quad started to back fire and sputter when I would let off the gas and the check engine light came on. I did the turn the key thing it's a code 21. Which is loss of sync. Ok wtf does that mean. So I shut it off and waited for my buddies to come pick my quad up with the trailer. And when they got there I started it and the check engine light was off and it ran perfectly fine so sputter or back firing. The. We get back to the house and I decided to take it for a ride and a little into the ride the check engine light came on and started sputtering and back firing again. I called my hometown shop and they said they have no idea they would need to put the digital wrench to find out. Does anyone have any ideas to try and help salvage my expensive ass weekend down here. Thanks in advance for all the help.
Reply With Quote
Sponsored Links
PolarisATVForums is the premier Polaris ATV Forum on the internet. Registered Users do not see these ads, So Register, It's Free!
  #2 (permalink)  
Old 05-21-2016, 08:17 PM
Neal_Fox's Avatar
ATV Enthusiast
 
Member #54914
Join Date: Oct 2015
Location: Whittemore Iowa
Posts: 36
Disconnect the battery for a little bit and see if that helps? Maybe loose battery cable?

Sent from my SM-G935R4 using Tapatalk
Reply With Quote
Reply

Lower Navigation
Go Back   Polaris ATV Forum > Polaris ATV Technical Discussions > ATV Repair and Maintenance


Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
2005 Sportsman 500 HO sputtering CrimsonTideJosh Polaris Sportsman 6 09-14-2016 02:48 PM
Random Stalling Cammertime88 ATV Repair and Maintenance 1 02-29-2016 06:42 AM


All times are GMT -8. The time now is 09:12 PM.



Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
vBulletin Security provided by vBSecurity v2.2.2 (Pro) - vBulletin Mods & Addons Copyright © 2017 DragonByte Technologies Ltd.