Polaris ATV Forum
Go Back   Polaris ATV Forum > Polaris Model Specific Discussions > Polaris Outlaw

Polaris Outlaw Discussions for the Polaris Outlaw 50,90,450, 525

LinkBack Thread Tools Display Modes
  #1 (permalink)  
Old 03-08-2011, 04:01 PM
tingley_8's Avatar
Junior Member
Member #6198
Join Date: Jul 2010
Location: Canada
Posts: 3
2009 525 S Outlaw Electrical Problems Please Help!!!

Hey I have a 2009 525 S Outlaw and lately it has been giving me problems. The bike works amazing but as soon as I turn the lights on it blows the fuse and it'll kill the motor. Has anyone had similar problems. Please help me!
Reply With Quote
Sponsored Links
PolarisATVForums is the premier Polaris ATV Forum on the internet. Registered Users do not see these ads, So Register, It's Free!
  #2 (permalink)  
Old 03-08-2011, 07:02 PM
Junior Member
Member #12375
Join Date: Feb 2011
Location: Ohio
Posts: 12
Sounds to me like something is shorting out.
2008 Outlaw 525s
FMF 4.1 Slip On
Wiseco 12.5:1
Rath racing intake
Reply With Quote
  #3 (permalink)  
Old 03-09-2011, 09:54 PM
croghan23's Avatar
ATV Enthusiast
Member #12402
Join Date: Feb 2011
Location: Kentucky
Posts: 45
sounds like you have a bare wire. good luck finding it
2008 Outlaw 525s
-renthal fat fars
-pure polaris nerf bars
-baffle removed
-shaved fenders
-red neon lights
Reply With Quote

Lower Navigation
Go Back   Polaris ATV Forum > Polaris Model Specific Discussions > Polaris Outlaw

Remove Ads

Search tags for this page
2008 outlaw 525 fuse location
2008 polaris outlaw 525 irs electrical troubleshooting
fuse box location on 2008 polaris outlaw 525
fuse on 08 polaris outlaw 525s
outlaw 525 fuse box

polaris outlaw 525 electrical problems


polaris outlaw 525 problems

polaris outlaw 525 s fuse

polaris outlaw 525 stator output

polaris outlaw 525s problems
polaris outlaw fuse

polaris outlaw fuse location

Click on a term to search our sites for related topics.

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

Similar Threads
Thread Thread Starter Forum Replies Last Post
electrical problems buckshot276 ATV Repair and Maintenance 0 10-10-2010 04:34 PM
Electrical problems carmelo ATV Repair and Maintenance 3 07-30-2010 08:00 PM
2009 Outlaw 525 irs Lord Rahl ATV Performance Modifications 1 03-18-2010 09:10 PM
500 efi electrical problems bubbagump ATV General Discussion 2 10-25-2009 06:51 PM
Electrical Problems Think38 Polaris Sportsman 10 05-24-2009 07:44 PM

All times are GMT -8. The time now is 06:37 PM.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2015, vBulletin Solutions, Inc.