Polaris ATV Forum
Go Back   Polaris ATV Forum > Polaris Model Specific Discussions > Polaris Predator

Polaris Predator All discussions for the Polaris Predator

Reply
 
LinkBack Thread Tools Display Modes
  #1 (permalink)  
Old 11-29-2011, 02:13 PM
Hillbillydrummer's Avatar
Junior Member
 
Member #20918
Join Date: Nov 2011
Location: Hamptonville, NC
Posts: 25
Predator Will Not Start

Hey guys! I have an 05 Predator 500 that will not start. It turns over, but will not fire. I had it running yesterday (11/28/2011) and rode it a while. I know for sure my battery is shot because I have been using a Jump Box to crank it. The carb is clean because I had to buy one, and it was installed yesterday which is why I was riding to make sure the carb was good. It also backfires sometimes while trying to crank it. I also know the valves are OK, because it was running fine yesterday and I just adjusted them a few weeks ago. I think I definitely need a battery and maybe need a new plug. It doesn't have a lot of gas in it at all, but enough for it to crank. I also know the gas that is in it, well I cant tell you the last time I put fresh gas in it so that could be an issue. Any ideas or suggestions would be appreciated.
Reply With Quote
Sponsored Links
PolarisATVForums is the premier Polaris ATV Forum on the internet. Registered Users do not see these ads, So Register, It's Free!
  #2 (permalink)  
Old 11-29-2011, 04:29 PM
Hillbillydrummer's Avatar
Junior Member
 
Member #20918
Join Date: Nov 2011
Location: Hamptonville, NC
Posts: 25
Anyone???
Reply With Quote
  #3 (permalink)  
Old 11-29-2011, 04:35 PM
Bruce!'s Avatar
Polaris ATV Legend
Premium Member
 
Member #193
Join Date: Feb 2009
Location: Port Angeles WA
Posts: 20,002
Welcome to the board!
__________________
I tried setting my password to "penis" but it said my password wasn't long enough...
Reply With Quote
  #4 (permalink)  
Old 11-29-2011, 04:56 PM
JFoley001's Avatar
Junior Member
 
Member #18462
Join Date: Sep 2011
Posts: 28
Predators need a surprisingly high level of fuel in the tank to be above the suction tube in the petcock. Fill it with fresh gas, connect your jumper cables, open the petcock, pull the choke, and it will fire.
__________________
2005 Predator 500 TLD K&N Dyno Jet Pro Armor

2007 Predator 500 CUSTOM CREATION by REDNECK2725
Reply With Quote
  #5 (permalink)  
Old 11-29-2011, 09:10 PM
Hillbillydrummer's Avatar
Junior Member
 
Member #20918
Join Date: Nov 2011
Location: Hamptonville, NC
Posts: 25
I will give that a try...thanks!
Reply With Quote
  #6 (permalink)  
Old 12-03-2011, 10:18 PM
JFoley001's Avatar
Junior Member
 
Member #18462
Join Date: Sep 2011
Posts: 28
Any luck?
__________________
2005 Predator 500 TLD K&N Dyno Jet Pro Armor

2007 Predator 500 CUSTOM CREATION by REDNECK2725
Reply With Quote
  #7 (permalink)  
Old 12-04-2011, 12:18 AM
Hillbillydrummer's Avatar
Junior Member
 
Member #20918
Join Date: Nov 2011
Location: Hamptonville, NC
Posts: 25
I ended up tearing it back down, just to make sure the valves were still within specs. When I took the valve cover off, I immediately noticed my cams were all out of wack, no were near where they need to be when it is turned to TDC. I think my timing chain had jumped. I pulled the clutch cover, removed my clutch basket and all and removed the chain to replace it. It has never been replace since new in 2005. So I'm waiting on a chain and tensioner and that is pretty much where I am. I still have to get a battery and plug. I tried to see if I had spark but the battery is completely shot and does nothing but tick when I hit the start button, not even enough power to produce a spark at all.
Reply With Quote
  #8 (permalink)  
Old 12-06-2011, 07:02 PM
JFoley001's Avatar
Junior Member
 
Member #18462
Join Date: Sep 2011
Posts: 28
So I guess it wasn't low on fuel? Lol Sounds like you've got it under control!
__________________
2005 Predator 500 TLD K&N Dyno Jet Pro Armor

2007 Predator 500 CUSTOM CREATION by REDNECK2725
Reply With Quote
  #9 (permalink)  
Old 12-09-2011, 10:04 AM
Hillbillydrummer's Avatar
Junior Member
 
Member #20918
Join Date: Nov 2011
Location: Hamptonville, NC
Posts: 25
Oh no...you were right...it was way low on fuel. I removed the tank to dump the old gas out and held it up right as if it were sitting on the frame turned the fuel on and i may have got a few drips out of it. Is it or is it not recommended to reinstall the timing chain tensioner with it already extended? Are you supposed to release the tension, install then let it tighten back up slowly? I'm a little confused about that as well?
Reply With Quote
  #10 (permalink)  
Old 12-09-2011, 03:01 PM
Hillbillydrummer's Avatar
Junior Member
 
Member #20918
Join Date: Nov 2011
Location: Hamptonville, NC
Posts: 25
Well...i got my chain in today and installed it. What a difference! I can hardly move the cams with it loose with the new chain. The old tensioner wont even go in now so im guessing the old chain was stretched bad. Still waiting on the new tensioner...so i know i will have to retract the new one to get it in. I may be on to something finally!
Reply With Quote
Reply

Lower Navigation
Go Back   Polaris ATV Forum > Polaris Model Specific Discussions > Polaris Predator


Search tags for this page
02 predator 90 has spark and fuel but wont run
,
04 predator has spark but wont start
,
2004 polaris predator 500 wont start
,
2005 polaris predator 500 will not start
,

2005 polaris predator 500 wont start

,
polaris predator 500 cranks but wont start
,
polaris predator 500 have power will not start
,

polaris predator 500 not starting

,
polaris predator 500 wont start
,

polaris predator wont start

,
polaris predator wont turn over
,
predator wont start
Click on a term to search our sites for related topics.

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
predator no start pink63impala Polaris Predator 81 12-02-2011 03:23 AM
predator will not start help please. snager Polaris Predator 5 11-29-2011 05:02 PM
03 predator 500 no start mxracerx37 ATV Repair and Maintenance 2 03-21-2011 07:40 AM
Predator 90 will not start sauerkraut89 ATV Repair and Maintenance 2 03-20-2011 05:08 PM
05 predator wont start!!!!! yzryder125 Polaris Predator 3 12-26-2010 03:55 PM

Motosport.com


All times are GMT -8. The time now is 01:20 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.