Starts but won't stay running. - Page 2 - Polaris ATV Forum
Polaris Predator All discussions for the Polaris Predator

Reply
 
LinkBack Thread Tools Display Modes
post #11 of 15 (permalink) Old 08-30-2012, 03:05 PM Thread Starter
Junior Member
 
springloaded's Avatar
 
Join Date: Aug 2012
Location: Odenton MD
Posts: 9
Sorry kind of new to this stuff.
springloaded is offline  
Sponsored Links
Advertisement
 
post #12 of 15 (permalink) Old 08-30-2012, 03:10 PM
Polaris ATV Junkie!
 
neandrathal's Avatar
 
Join Date: Sep 2011
Location: colorado
Posts: 521
U are fine it takes questions yoo get answers too figurr things out when u start out

07 outlaw 525 irs (too much too list lol)
06 predato le

polarisproriders.com
neandrathal is offline  
post #13 of 15 (permalink) Old 08-30-2012, 03:32 PM Thread Starter
Junior Member
 
springloaded's Avatar
 
Join Date: Aug 2012
Location: Odenton MD
Posts: 9
Thanks. I don't think it is the throttle cable. I tried adjusting it. All the way in to all the way out. I can smell it flooding trying to start. Will have to try to clean the carb this weekend.
springloaded is offline  
Sponsored Links
Advertisement
 
post #14 of 15 (permalink) Old 09-03-2012, 07:47 AM
Junior Member
 
gpillow's Avatar
 
Join Date: Sep 2012
Posts: 4
I have a 2005 330 Magnum 4x4 it will run if i keep the throttle going, then if i let off the rpm drops to about 800-900 and it shuts off. When I try to crank it again it will not fire. The key symbol shows up in the display if I turn the key on/off a couple of times it will clear the key symbol and will start if I give it some throttle. Any ideas to what could be the problem?
gpillow is offline  
post #15 of 15 (permalink) Old 10-13-2016, 07:52 AM
Junior Member
 
Amirault's Avatar
 
Join Date: Oct 2016
Location: Sc
Posts: 1
Have 2015 sportsman 570 will start run a few secs then quit
Amirault is offline  
Reply

  Lower Navigation
Go Back   Polaris ATV Forum > Polaris Model Specific Discussions > Polaris Predator

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Polaris ATV Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Thread Thread Starter Forum Replies Last Post
09 500 HO won't stay running Prowler59 Polaris Sportsman 5 04-15-2012 08:02 AM
Sportsman 500 Won't Stay Running ghggroundforce ATV Repair and Maintenance 3 02-16-2011 03:14 PM
will not stay running tym2ski ATV Repair and Maintenance 1 02-02-2011 01:26 PM
TB now it wont stay running paraord Polaris Trail Blazer 3 01-19-2011 05:40 PM
Wont stay running lefty Polaris Trail Blazer 5 09-11-2010 05:41 PM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome