570 SP Battery location - Polaris ATV Forum
Polaris Sportsman 570 Discussions for the all new 2014+ Polaris Sportsman 570

 
LinkBack Thread Tools Display Modes
post #1 of 6 (permalink) Old 03-18-2017, 11:41 AM Thread Starter
Junior Member
 
troy570sp's Avatar
 
Join Date: Mar 2017
Location: Northern CA
Posts: 5
570 SP Battery location

Any one notice their front driveshaft occasionally will spin up against the corner of the battery? Mine looks like it only has 1/8 inches between the front drive shaft and the battery. Its a very inconvenient area for the battery anyway but for it to rub the driveshaft is definitely not a good sign. I looked at the battery and its not loose or moving around at all. The strap is on tight and the box it fits in seems like there is no room for it to move.
troy570sp is offline  
Sponsored Links
Advertisement
 
post #2 of 6 (permalink) Old 03-18-2017, 11:46 AM
Extreme ATV Enthusiast
 
irishboy02's Avatar
 
Join Date: Oct 2016
Location: North Jersey
Posts: 126
Pics? Sounds like something isn't right here. How many miles/hours do you have?

Sent from my LG-D800 using Tapatalk
irishboy02 is offline  
post #3 of 6 (permalink) Old 03-19-2017, 05:46 PM Thread Starter
Junior Member
 
troy570sp's Avatar
 
Join Date: Mar 2017
Location: Northern CA
Posts: 5
As of today its got 100 miles and 22 hours. I marked the driveshaft and today it didnt rub. I am thinking i had the motor mounts replaced under warranty last month. Possible it might have rubbed when those broke. The dealer said they were defective. I think when the engine shifted thats when it happened. I will keep an eye on it. I forgot about that until today. Thanks for your reply.
troy570sp is offline  
Sponsored Links
Advertisement
 
post #4 of 6 (permalink) Old 03-19-2017, 05:55 PM
Polaris ATV Legend
 
FUSE's Avatar
 
Join Date: May 2013
Location: Middle of Nowhere North Dakota
Posts: 2,973
No rubbing on ours.....
FUSE is offline  
post #5 of 6 (permalink) Old 03-20-2017, 01:29 AM
ATV Enthusiast
 
sportsmatt's Avatar
 
Join Date: Jun 2015
Location: Home
Posts: 92
It's just dirt and other trash getting between the shaft and battery on mine. I look at stuff fairly often so it doesn't worry me much.
sportsmatt is offline  
post #6 of 6 (permalink) Old 03-20-2017, 09:37 AM
Polaris ATV Legend
 
ThorsHammer's Avatar
 
Join Date: Jan 2013
Location: Western WA
Posts: 6,697
Garage
The only other post that I've seen on this, the dealer had installed the wrong battery. I think you're right, that it happened when the motor mounts broke. (you're also the first to post anything about that happening that I've seen.)

"There are no problems. There are only Solutions. It's your job to find the right one.

2007 Hawkeye 300 17HP of gutless glory
25" STI Black Diamond ATRs
Pure Polaris Deluxe front Brush guard
Pure Polaris hand guards
4" LED on the pod
8" LED light bar on the front bumper.
Tamarack Titan Luxury Lounger
Cabela's Chainsaw mount
Badlands 2500 lbs. winch w/remote and Kong winch saver.
Full Aluminum Skid plate and A-arm guards(custom built)
Pure Polaris Front rack extension
Quadworks Stage 1 power kit
  • K&N Highflow reusable filter
  • Quadworks highflow prefilter
  • Dynojet kit
2" rear spring spacers

Towable/equipment
Custom built road drag grader

Future mods
Rear bumper/brush guard
ThorsHammer is offline  
Reply

  Lower Navigation
Go Back   Polaris ATV Forum > Polaris Model Specific Discussions > Polaris Sportsman 570

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Polaris ATV Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Thread Thread Starter Forum Replies Last Post
Wheel bearing brands DAKOTAKIDD Polaris Sportsman 19 03-17-2017 09:51 AM
2012 550 X2 battery upgrade Stormrider1961 ATV Repair and Maintenance 1 01-16-2017 11:31 AM
Handy battery terminal access bullseyeguy ATV Performance Modifications 15 12-19-2016 04:49 AM
570 Riders - May be time for a new Battery, have you replaced yours? CyberianHusky Polaris Sportsman 570 44 07-26-2016 06:07 AM
Is my plow/winch killing my 570 battery? petertirrell Polaris Sportsman 570 9 03-09-2016 05:01 AM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome