rain water leaked into belt box - Polaris ATV Forum
Polaris ATV Forum
Go Back   Polaris ATV Forum > Polaris Model Specific Discussions > Polaris Sportsman 570

Polaris Sportsman 570 Discussions for the all new 2014+ Polaris Sportsman 570

Reply
 
LinkBack Thread Tools Display Modes
  #1 (permalink)  
Old 01-15-2014, 07:19 AM
Geraldbailey's Avatar
Extreme ATV Enthusiast
 
Member #40274
Join Date: Nov 2013
Location: Atlanta, Tx
Posts: 183
rain water leaked into belt box

I left my 570 uncovered when it rained a couple days ago. I got on it yesterday to ride it around the yard. Backed up fine down the hill but when I put in in low it wouldnt go. Drained the box and dried the belt. All was good. I went looking for where the leak could be coming from and found that the boot where the snorkle is seperated under the boot was leaking bad. The water will sit down in the snorkle until you move and then it dumps into the belt box. Has anyone else had a problem with this? Im going to seal it up. It wouldnt hurt to check your snorkle boots under the seat to see if yours will leak as well. I dont know anyone close to see if my boot was put on wrong or if it something that may be an issue
__________________
2014 Sportsman 850 XP HO 28X14 Mega Mayham MSA Kore Polaris 13" Led Light Bar
2015 Sportsman 570 28x14 Mega Mayham Skinny on MSA Diesel
2013 Polaris Ranger 400 HO Mods coming soon
Reply With Quote
Sponsored Links
PolarisATVForums is the premier Polaris ATV Forum on the internet. Registered Users do not see these ads, So Register, It's Free!
  #2 (permalink)  
Old 01-15-2014, 07:24 AM
bgirard420's Avatar
Polaris ATV Legend
 
Member #11494
Join Date: Jan 2011
Location: Rhode Island
Posts: 4,626
That's crazy. Might want to check other connections and bolts ect on the machine in case you got a Friday model.


Rather be riding, instead I'm using Tapatalk
__________________
2013 Polaris XP 850 HO LE EPS
  • Full Ricochet Armor (Black Anodized), ATV GURU Cobra F & R Brush Guards, Polaris L&R rear box w/Backrest & Bags, Scrambler LE Hand Guards, Symtec Heat Demon Grips, Rotopax 2+2
2010 Polaris 500 HO
  • 25" GBC Spartacus, EPI Clutch Kit, Full Ricochet Armor, Polaris 2500 lb Winch Rear Box & Hand Guards, SuperATV Bumpers
Reply With Quote
  #3 (permalink)  
Old 01-15-2014, 08:04 AM
Geraldbailey's Avatar
Extreme ATV Enthusiast
 
Member #40274
Join Date: Nov 2013
Location: Atlanta, Tx
Posts: 183
ive looked it over pretty well and everything seems to be good other than this.
__________________
2014 Sportsman 850 XP HO 28X14 Mega Mayham MSA Kore Polaris 13" Led Light Bar
2015 Sportsman 570 28x14 Mega Mayham Skinny on MSA Diesel
2013 Polaris Ranger 400 HO Mods coming soon
Reply With Quote
Sponsored Links
Advertisement
 
  #4 (permalink)  
Old 01-15-2014, 02:27 PM
Tcounty's Avatar
Polaris ATV Junkie!
 
Member #40976
Join Date: Jan 2014
Location: West Tennessee
Posts: 745
Mine did the same thing when I washed it. Didn't notice the boot was off. Needs a clamp on it. I'm going to put a couple zip ties on it.
__________________
2014 Sportsman 570 Green EPS
Reply With Quote
  #5 (permalink)  
Old 01-15-2014, 02:46 PM
Geraldbailey's Avatar
Extreme ATV Enthusiast
 
Member #40274
Join Date: Nov 2013
Location: Atlanta, Tx
Posts: 183
zip ties will help. I thought of that as well. i think ill try that with a little sealant just for some extra protection.
__________________
2014 Sportsman 850 XP HO 28X14 Mega Mayham MSA Kore Polaris 13" Led Light Bar
2015 Sportsman 570 28x14 Mega Mayham Skinny on MSA Diesel
2013 Polaris Ranger 400 HO Mods coming soon
Reply With Quote
  #6 (permalink)  
Old 04-06-2014, 03:47 PM
Acker952's Avatar
Junior Member
 
Member #43090
Join Date: Apr 2014
Location: Fredericton, NB, Canada
Posts: 10
I just got a new 570EFI about 2 weeks ago. Had it out twice on an dirt road that has some water on it in spots. No wheres did the water go over the floor boards... Brought the bike home and washed it and went to drive it into my shed and it started slipping even when revving at 3000RPM. Did you end up solving the problem? I think it may have been the wash that did it.
Reply With Quote
  #7 (permalink)  
Old 04-06-2014, 05:00 PM
Straightedge's Avatar
Junior Member
 
Member #42343
Join Date: Mar 2014
Location: Central Ohio
Posts: 26
I washed mine good with the hose once and soaked it thoroughly. Then last Thursday and Friday I camped and it was in the rain - almost continuously. I didn't have a bit of trouble.

It is home and dry in the garage now, but I'm going to check it over good to make sure nothing like this could happen.
Reply With Quote
  #8 (permalink)  
Old 04-07-2014, 08:02 AM
Acker952's Avatar
Junior Member
 
Member #43090
Join Date: Apr 2014
Location: Fredericton, NB, Canada
Posts: 10
I litterally just took mine back to the dealership. I think my clutch cover is warped or something. I'll keep you posted on the situation. Thanks for the input
Reply With Quote
  #9 (permalink)  
Old 04-07-2014, 08:27 AM
whtrapta's Avatar
Polaris ATV Junkie!
 
Member #21865
Join Date: Jan 2012
Location: Bolivar, MO
Posts: 815
mine always slips with water after a wash. IDK why it leaks so bad. I tried everything with that boot but its simply not big enough. It hardly holds both of those tubes. Serious design flaw polaris.
__________________
2013 RZR 900 XP | Black Sixr Wheels | 26" Sedona Ripsaws

10 Ford SVT Raptor | WSI Front Bumper | WSI Rear Bumper | WSI Faux Hawk Rack | Method Standard Race Wheels
3" Single Chamber Exhaust | Perch Mod | HID Lights | Rear Hella Dust Lights | Mickey Thompson Baja ATZ P3 Tires
Volant Cold Air Intake | Custom Carbon Fiber Dash | Custom Spare Tire Mount | National Rear Leaf Springs
30" Led Bar Bumper Mount | 40" Led Bar Bed Rack Mount

SOLD 14 Polaris 570 Touring
SOLD 99 Honda 440ex Big Bore
Reply With Quote
  #10 (permalink)  
Old 04-07-2014, 02:23 PM
Acker952's Avatar
Junior Member
 
Member #43090
Join Date: Apr 2014
Location: Fredericton, NB, Canada
Posts: 10
I hear ya. I think I'm going to silicone the whole system down the road... If worse comes to worse you can just peal off the silicone.
Reply With Quote
Reply

Lower Navigation
Go Back   Polaris ATV Forum > Polaris Model Specific Discussions > Polaris Sportsman 570



Search tags for this page

2014 polaris sportsman 570 efi belt slipping

,

belt housing snorkel polaris 570

,
how to fix rain water in polaris ranger belt housing
,

polaris 570 ranger fullsize cleaning clutch

,

polaris sportsman 570 belt box filling with water

,

polaris sportsman 570 belt slipping

,
polaris water housing belt slipping
,

rain water in belt cover

,
sportsman 570 belt problems
,

sportsman 570 belt slipping

,
sportsman 570 belt snorkel
,
sportsman 570 water in belt housing
Click on a term to search our sites for related topics.

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
water in belt srbigbrown Polaris Sportsman 11 12-31-2013 06:56 AM
Water on belt - should I replace belt Rangerbob316 Polaris Scrambler XP 12 06-15-2013 10:00 AM
Water getting into CVT belt housing...any help POLARIS13 Polaris Sportsman 5 12-25-2012 01:06 PM
Water in belt 800polaris ATV Repair and Maintenance 6 01-31-2012 02:25 PM
Water in belt housing Stu14 Polaris Sportsman 10 01-03-2012 08:24 AM


All times are GMT -8. The time now is 03:20 PM.



Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
vBulletin Security provided by vBSecurity v2.2.2 (Pro) - vBulletin Mods & Addons Copyright © 2017 DragonByte Technologies Ltd.