Problem with my sportsman speedo! - Polaris ATV Forum
Polaris Sportsman Discussions for the Polaris Sportsman 90, 300, 355, 400, 450, 500, 550, 600, 700, 800, 850

 
LinkBack Thread Tools Display Modes
post #1 of 10 (permalink) Old 06-30-2011, 06:31 AM Thread Starter
Junior Member
 
Clay7790's Avatar
 
Join Date: Jun 2011
Posts: 4
Problem with my sportsman speedo!

Thanks I'm having problems with the speedo on my 05 sportsman 500 ho. Everything works but the speedometer?
Clay7790 is offline  
Sponsored Links
Advertisement
 
post #2 of 10 (permalink) Old 06-30-2011, 08:05 AM
Polaris ATV Legend
 
Bruce!'s Avatar
 
Join Date: Feb 2009
Location: Port Angeles WA
Posts: 20,003
welcome to the board!

I tried setting my password to "penis" but it said my password wasn't long enough...
Bruce! is offline  
post #3 of 10 (permalink) Old 06-30-2011, 08:09 AM
Polaris ATV Legend
 
Bruce!'s Avatar
 
Join Date: Feb 2009
Location: Port Angeles WA
Posts: 20,003
I always go to ATV forums and click the button at the bottom of page (mark all forums read)button!

I tried setting my password to "penis" but it said my password wasn't long enough...
Bruce! is offline  
Sponsored Links
Advertisement
 
post #4 of 10 (permalink) Old 06-30-2011, 08:43 AM
Junior Member
 
cmitchell79's Avatar
 
Join Date: May 2011
Location: Kentucky
Posts: 12
The magnetic sensor mounted behind the right front tire (if you are sitting on the quad) is probably bad. Not hard to replace but they are around $50.

06 Oultaw 500
-L8ton racing rear swaybar
-Rekluse
02 Sportsman 700
05 Predator 90

Special thanks to L8ton Racing
www.l8tonracing.com
cmitchell79 is offline  
post #5 of 10 (permalink) Old 06-30-2011, 11:08 AM Thread Starter
Junior Member
 
Clay7790's Avatar
 
Join Date: Jun 2011
Posts: 4
Thanks but already replaced that, but put a used one. Anything else ya ll no of?
Clay7790 is offline  
post #6 of 10 (permalink) Old 06-30-2011, 01:35 PM
Extreme ATV Enthusiast
 
jshields's Avatar
 
Join Date: Aug 2010
Location: Dallas, TX
Posts: 159
Have you checked to make sure you are getting power all the way to the speedo? What about fuses? Headlights? Does AWD work?
jshields is offline  
post #7 of 10 (permalink) Old 06-30-2011, 01:57 PM
Extreme ATV Enthusiast
 
jayhkr's Avatar
 
Join Date: Oct 2010
Location: Kansas City, KS
Posts: 367
I have the same issue. All my lights, AWD, gear lights work, just no speed. I havn't looked at the sensor on the wheel though. Going to do that tonight or tomorrow. Is it cleanable or just needs replaced?

2001 Sportsman 500 HO 4x4:
K&N Filter
Warn 2500# Winch
Heated Hand Grips
60" Polaris Razor Plow
26" Mud Lite XL Tires
Aftermarket Wheels

2008 Sportsman 300 4x4:
Upgrades soon to come!
jayhkr is offline  
post #8 of 10 (permalink) Old 06-30-2011, 02:59 PM Thread Starter
Junior Member
 
Clay7790's Avatar
 
Join Date: Jun 2011
Posts: 4
Lights work and there or 3 wires black no power red and white both have power going to sensor but my awd slams in while still having switch in 2wd. Has new used sensor on it. Can't find any fuses????
Thanks if anyone could help on this!!!
Clay7790 is offline  
post #9 of 10 (permalink) Old 07-06-2011, 04:50 PM Thread Starter
Junior Member
 
Clay7790's Avatar
 
Join Date: Jun 2011
Posts: 4
Is there any fuses on 05 sportsman 500 ho. I can't find any and speedometer not working and awd engaging when in 2wd ??????
Clay7790 is offline  
post #10 of 10 (permalink) Old 06-11-2016, 06:05 AM
Junior Member
 
freerangechicken's Avatar
 
Join Date: Mar 2016
Location: Pt charlotte, fl
Posts: 1
i have a 2008 sportsman 500 HO Tourung model.
All guages, AWD works but needle on speedometer wont register above 20 mph. Any clues?
freerangechicken is offline  
Reply

  Lower Navigation
Go Back   Polaris ATV Forum > Polaris Model Specific Discussions > Polaris Sportsman

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Polaris ATV Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Thread Thread Starter Forum Replies Last Post
04 and up Sportsman speedo jroptop ATV Parts for Sale 2 04-27-2011 05:09 AM
'05 800 Speedo/AWD problem SwooshmanDM Polaris Sportsman 6 04-06-2011 05:13 AM
2002 500 Speedo problem cookies Polaris Sportsman 8 03-29-2011 06:40 PM
2002 Sportsman speedo problem TimberGhost ATV Repair and Maintenance 4 12-31-2010 01:39 PM
99 Sportsman 500 speedo? reel_story Polaris Sportsman 2 08-10-2009 07:04 AM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome