2010 Sportsman 400 Dead Battery - Polaris ATV Forum
Polaris Sportsman Discussions for the Polaris Sportsman 90, 300, 355, 400, 450, 500, 550, 600, 700, 800, 850

 
LinkBack Thread Tools Display Modes
post #1 of 5 (permalink) Old 09-09-2011, 05:02 PM Thread Starter
Junior Member
 
weaver9710's Avatar
 
Join Date: Oct 2010
Location: TN
Posts: 2
2010 Sportsman 400 Dead Battery

Purchased a Sportsman last fall and it has sat from November until now. The key was out but the switch was left to run. The battery is completely dead. When I turn the key on nothin happens. When I hook up the battery tender (I know I should have used it all winter) it blinks telling me that the battery is too low to charge. I'm hooking it up to the wires that are in the front compartment. Is there any way to bring it back to life?

Also when I tried to jump it with another ATV, it turns over but won't start.

Actually, I think its a 2011 if that makes a difference.

Last edited by weaver9710; 09-09-2011 at 05:12 PM.
weaver9710 is offline  
Sponsored Links
Advertisement
 
post #2 of 5 (permalink) Old 09-09-2011, 05:40 PM
Polaris ATV Legend
 
Bruce!'s Avatar
 
Join Date: Feb 2009
Location: Port Angeles WA
Posts: 20,004
Welcome to the board!

I tried setting my password to "penis" but it said my password wasn't long enough...
Bruce! is offline  
post #3 of 5 (permalink) Old 09-10-2011, 05:22 AM
Polaris ATV Legend
 
Russ C's Avatar
 
Join Date: Feb 2011
Location: Douglas Wyo
Posts: 4,243
new battery time
Russ C is offline  
Sponsored Links
Advertisement
 
post #4 of 5 (permalink) Old 09-10-2011, 06:08 AM
ATV Enthusiast
 
09Stealth's Avatar
 
Join Date: Sep 2011
Location: South Central Pa
Posts: 49
Does it have any acid or water in it, if not try filling it but Id say its junk. I ride mine atleast 3 times per week and within 10 months my was junk as well. Polaris sends them out with a cheapo battery. Go get a good one for it and be done. 50 bucks or so and your good to go
09Stealth is offline  
post #5 of 5 (permalink) Old 09-10-2011, 07:00 AM
Polaris ATV Junkie!
 
1of7627's Avatar
 
Join Date: Apr 2010
Location: Post Falls, ID
Posts: 503
Quote:
Originally Posted by weaver9710 View Post
Actually, I think its a 2011 if that makes a difference.
Actually, it makes a big difference. If you have a 2010, it's on the mid-size Hawkeye chassis and the battery replacement is your worst nightmare. If you have a 2011, it's on the full size chassis with the Sportsman 500's and such. The 2010 came with an AGM battery that's sealed and has no liquid to deal with. And, if you have a 2010, be sure and get another AGM battery and take care of it as dealing with the battery is something you'll want to do as infrequently as possible. - MarkC

MarkC - Spokane, WA USA
"Long live the orphaned Hawkeyes and mid-size Sportsmans"

Last edited by 1of7627; 09-10-2011 at 06:45 PM.
1of7627 is offline  
Reply

  Lower Navigation
Go Back   Polaris ATV Forum > Polaris Model Specific Discussions > Polaris Sportsman

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Polaris ATV Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Thread Thread Starter Forum Replies Last Post
Battery Dead, runs but headlights dim Paulcalif Polaris Phoenix 5 07-24-2011 08:07 AM
Dead battery Cobb71 ATV Repair and Maintenance 2 05-07-2011 05:04 AM
2009 sportsman battery dead bigmike5904 ATV Repair and Maintenance 2 10-09-2010 12:00 PM
replaced starter- battery cable still melting conections and dead battery mcmarkrazz Polaris Sportsman 4 09-19-2010 07:20 PM
90 sportsman dead battery erice Polaris Sportsman 0 04-26-2010 09:50 AM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome