Polaris ATV Forum
Go Back   Polaris ATV Forum > Polaris Model Specific Discussions > Polaris Sportsman

Polaris Sportsman Discussions for the Polaris Sportsman 90, 300, 355, 400, 450, 500, 550, 600, 700, 800, 850

Reply
 
LinkBack Thread Tools Display Modes
  #1 (permalink)  
Old 10-15-2011, 06:24 PM
focushunter's Avatar
Extreme ATV Enthusiast
 
Member #9482
Join Date: Nov 2010
Location: Houston,Tx
Posts: 215
2003 Sportsman 700 problems

I finally picked up the 700 i asked questions about with the 4wd not to long ago. Now here is what i have. The 4wd doesnt engage and does not show up on the speedo. The speed doesnt work on the speedo and the lights flick off and on. Also for every gear it shows E on the display except for when its in nuetral. Lets hear yall ideas of were to start. Right now from reading all the other topics i am leading to that its the just the speedo. Sorry about posting this up but every search just show one or the other instead of all of them.
Reply With Quote
Sponsored Links
PolarisATVForums is the premier Polaris ATV Forum on the internet. Registered Users do not see these ads, So Register, It's Free!
  #2 (permalink)  
Old 10-16-2011, 04:46 AM
Reid44's Avatar
Junior Member
 
Member #6206
Join Date: Jul 2010
Location: Milton,on
Posts: 4
My buddy had the same kindda problem with his 500. It was the 4X4 switch the electronic one, he changed that out and he was good to go. I don't know if your gonna be the same but it's worth a shot I guess.
Reply With Quote
  #3 (permalink)  
Old 10-16-2011, 09:50 PM
focushunter's Avatar
Extreme ATV Enthusiast
 
Member #9482
Join Date: Nov 2010
Location: Houston,Tx
Posts: 215
Well i got the bike jacked up today and found out that the 4wd is working fine even though the light is not coming on. Still have the problems with the lights and the speedo showing e.
Reply With Quote
  #4 (permalink)  
Old 10-17-2011, 04:10 AM
Russ C's Avatar
Polaris ATV Legend
 
Member #11982
Join Date: Feb 2011
Location: Douglas Wyo
Posts: 4,166
speedo showing e is probably gear indicator switch on tranny
Reply With Quote
  #5 (permalink)  
Old 10-17-2011, 09:13 PM
freestylest22's Avatar
Junior Member
 
Member #19227
Join Date: Oct 2011
Location: Fort Worth, Texas
Posts: 12
Does your exhaust y-pipe get cherry red hot when riding? I have the same bike and it does. Also takes awhile to get it warmed up.
Reply With Quote
  #6 (permalink)  
Old 10-18-2011, 10:06 AM
focushunter's Avatar
Extreme ATV Enthusiast
 
Member #9482
Join Date: Nov 2010
Location: Houston,Tx
Posts: 215
My pipe gets hot but not cherry red.
Reply With Quote
Reply

Lower Navigation
Go Back   Polaris ATV Forum > Polaris Model Specific Discussions > Polaris Sportsman


Search tags for this page
03 polaris 700 sportman stuck in 4x4
,
2003 polaris 700 sportsman
,
2003 polaris 700 sportsman issues
,
2003 polaris 700 sportsman problems
,
2003 polaris sportsman 700
,
2003 polaris sportsman 700 4x4 problems
,
2003 polaris sportsman 700 issue
,

2003 polaris sportsman 700 problems

,
2003 polaris sportsman 700 recalls
,
2003 polaris sportsman 700 troubleshoot
,
2003 sportsman 700
,
2003 sportsman 700 problems
Click on a term to search our sites for related topics.

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
2003 sportsman 400 AWD problems. Rodamatic80 ATV Repair and Maintenance 0 06-24-2011 05:33 PM
2003 Polaris Sportsman 700 Twin Problems Cslaxer26 Polaris Sportsman 6 03-04-2011 05:16 PM
2003 Sportsman 600 wheel problems smyers33 ATV Repair and Maintenance 2 04-30-2010 05:53 AM
2003 Sportsman 600 twin problems NEED HELP JayJay Polaris Sportsman 4 10-26-2009 08:09 PM
2003 sportsman 700 engine problems 4603j ATV Repair and Maintenance 12 08-01-2009 10:26 AM

Motosport.com


All times are GMT -8. The time now is 09:19 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.