2005 Polaris 400 sportsman electrical issues? - Polaris ATV Forum
Polaris Sportsman Discussions for the Polaris Sportsman 90, 300, 355, 400, 450, 500, 550, 600, 700, 800, 850

 
LinkBack Thread Tools Display Modes
post #1 of 1 (permalink) Old 01-09-2012, 11:38 AM Thread Starter
Junior Member
 
Jmaldonado's Avatar
 
Join Date: Dec 2011
Location: Anna,Texas
Posts: 4
2005 Polaris 400 sportsman electrical issues?

Can anybody tell me why my odometer light will blink, like is loosing power but the battery is fully charged? Some times the battery sing will also blink on and off on the odometer screen? My battery and alternator are both working fine, they were both tested? Any help will be much appreciated! I just installed a brand new starter on the ATV and it runs good, but every so often when the odometer goes to blinking the ATV will die?
Jmaldonado is offline  
Sponsored Links
Advertisement
 
Reply

  Lower Navigation
Go Back   Polaris ATV Forum > Polaris Model Specific Discussions > Polaris Sportsman

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Polaris ATV Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Thread Thread Starter Forum Replies Last Post
Polaris xplorer 250 Electrical issues ajmicek ATV Repair and Maintenance 5 11-23-2014 04:46 PM
2005 Sportsman 600 Electrical jslimjeff ATV Repair and Maintenance 7 01-26-2011 03:51 PM
1999 polaris xplorer 400 electrical issues?? wisemind2 ATV Repair and Maintenance 3 01-04-2011 10:58 AM
2005 500 sportsman electrical problem srt2 ATV Repair and Maintenance 3 12-01-2010 04:27 PM
electrical problem 2005 sportsman help.... srt2 ATV New Members 2 11-28-2010 06:52 PM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome