winch problem.... - Polaris ATV Forum
Polaris Sportsman Discussions for the Polaris Sportsman 90, 300, 355, 400, 450, 500, 550, 600, 700, 800, 850

Reply
 
LinkBack Thread Tools Display Modes
post #1 of 14 (permalink) Old 01-20-2012, 02:00 PM Thread Starter
Junior Member
 
cupero's Avatar
 
Join Date: Oct 2011
Location: exeter,maine
Posts: 25
winch problem....

ok so i was out plowing today and the plow wouldant lift but it would still drop the plow just not life so i checked all my connections and i found one that was loose ,so i tightin it and thought it fixed it but now it wont drop checked all the connections again and they are all tight any help..oh and my dealer said it was the switch he told me to unplugg it and bring it inside but i cant figure out how to unplugg it it looks sealed..
cupero is offline  
Sponsored Links
Advertisement
 
post #2 of 14 (permalink) Old 01-20-2012, 02:16 PM
Polaris ATV Junkie!
 
antoniodef's Avatar
 
Join Date: Jan 2011
Location: Michigan
Posts: 1,484
So it won't lift or drop now? Do you hear the contactor click?

Sent from my SCH-I510 using Tapatalk

2015 Sportsman 570 Touring EPS - 26" Big Horn 2s, ITP Delta rims, Polaris 3500lb winch.
Sold - 11 TB 330, 11 SP 500, 13 SP 500
antoniodef is offline  
post #3 of 14 (permalink) Old 01-20-2012, 02:19 PM Thread Starter
Junior Member
 
cupero's Avatar
 
Join Date: Oct 2011
Location: exeter,maine
Posts: 25
well it will do one or the other eather it will lift and wont drop or it will drop it wont lift and when i hite the switch nothing no clicking nothing..
cupero is offline  
Sponsored Links
Advertisement
 
post #4 of 14 (permalink) Old 01-20-2012, 04:36 PM
Junior Member
 
NaturalElement's Avatar
 
Join Date: Oct 2011
Location: Cleveland, OH
Posts: 19
Battery failure? Mine started doing that last night. After the winch stopped, it kept me from revving above 18-2000 RPM. Couldn't move. Shut it off, let it sit. Turn back on and get check engine light code= voltage too low.

Let it idle with no lights for half hour and was able to get it in my truck. I thank Polaris for the warning before it was totally dead, but the lights were still nice and bright.

I think what ultimately killed it was the cold. The battery was 4 years old. Got new one today at Batteries Plus today for $114. Not cheap, but it has a 2 year warranty.

If you think about it, all those lights (I have two auxiliary reverse), constantly using the winch (for hours in my case), and the cold will kill a battery.

Sorry for my rant, I was fired up last night when this went down, still am. Winter income was the justification for buying the tool, toy. Happy it was only the battery. Seemed like much worse.


---
I am here: http://maps.google.com/maps?ll=41.510175,-81.581320
Ryan
Natural Element
www.earthh2ofire.com

'09 Sportsman XP 550
NaturalElement is offline  
post #5 of 14 (permalink) Old 01-20-2012, 04:55 PM Thread Starter
Junior Member
 
cupero's Avatar
 
Join Date: Oct 2011
Location: exeter,maine
Posts: 25
well if its the battery then i am gunna be upset caue i just put one in the machine when i bought it this past summer .....................oh if any one was woundering its a 05 sportsman 800
cupero is offline  
post #6 of 14 (permalink) Old 01-20-2012, 07:12 PM
Junior Member
 
NaturalElement's Avatar
 
Join Date: Oct 2011
Location: Cleveland, OH
Posts: 19
Put it on a maintainer every time you bring it home and you may not have a problem.


---
I am here: http://maps.google.com/maps?ll=41.510149,-81.581288
Ryan
Natural Element
www.earthh2ofire.com

'09 Sportsman XP 550
NaturalElement is offline  
post #7 of 14 (permalink) Old 01-20-2012, 08:02 PM
Extreme ATV Enthusiast
 
pathfinder's Avatar
 
Join Date: Dec 2010
Location: California
Posts: 294
If you are not hearing the "click" from the contactor then it is most likely the handlebar switch or the contactor. Could even be the wiring between the switch and contactor. Even if the battery was low on voltage it would still pull in the contactor, doesn't take much to pull it in.

2010 Sportsman 500 HO
3 headlight mod (with relay)
rear rack extender
handguards
Warn XT25 winch
Ricochet arm guards(anodized black)
Polaris front & rear brushguards
LED tail lights www.autolumination.com
HID light kit http://www.theatvsuperstore.com/ATV-HID-Lights-s/54.htm
pathfinder is offline  
post #8 of 14 (permalink) Old 01-20-2012, 08:20 PM
Polaris ATV Junkie!
 
antoniodef's Avatar
 
Join Date: Jan 2011
Location: Michigan
Posts: 1,484
It is hard to trouble shoot which part is broke if there is no consistency in the problem. It is usually the contractor or switch though. The switch on your handle bar usually has two screws to take the housing apart, then you can make sure it is clean. The contractors going bad are very common as well. I keep am extra, $30 on ebay.

If you can get the problem consistent, do a search on the forum. There is a thread I posted in that will tell you how to switch wires and test it.

Sent from my SCH-I510 using Tapatalk

2015 Sportsman 570 Touring EPS - 26" Big Horn 2s, ITP Delta rims, Polaris 3500lb winch.
Sold - 11 TB 330, 11 SP 500, 13 SP 500
antoniodef is offline  
post #9 of 14 (permalink) Old 01-21-2012, 05:53 AM Thread Starter
Junior Member
 
cupero's Avatar
 
Join Date: Oct 2011
Location: exeter,maine
Posts: 25
ya i see that post and was gunna try it today when i found the time but also to throw another wrench in this there were time that it didnt drop the plow untill i had it in gear and started to move forword not quite sure what that means..eather
cupero is offline  
post #10 of 14 (permalink) Old 01-21-2012, 08:01 AM Thread Starter
Junior Member
 
cupero's Avatar
 
Join Date: Oct 2011
Location: exeter,maine
Posts: 25
but if it is the battery does it mean i just have to plow in the daylight and not run my lights...cause its gunna take me awile to plow if i have to stop every hour and let it charge..
cupero is offline  
Reply

  Lower Navigation
Go Back   Polaris ATV Forum > Polaris Model Specific Discussions > Polaris Sportsman

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Polaris ATV Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Thread Thread Starter Forum Replies Last Post
winch problem jordaman17 Around The Garage 13 12-04-2011 08:12 AM
Winch problem remote_medic ATV Repair and Maintenance 2 11-27-2011 01:45 AM
Winch Problem Bucky Polaris Sportsman 11 01-26-2011 08:31 PM
Winch problem larryhd ATV General Discussion 6 10-19-2010 01:41 PM
winch problem please help stickem ATV General Discussion 6 10-09-2010 02:53 PM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome