Wrench light on start up - Polaris ATV Forum
Polaris Sportsman Discussions for the Polaris Sportsman 90, 300, 355, 400, 450, 500, 550, 600, 700, 800, 850

 
LinkBack Thread Tools Display Modes
post #1 of 7 (permalink) Old 02-15-2012, 07:41 PM Thread Starter
Extreme ATV Enthusiast
 
Scrambler2Sportsman's Avatar
 
Join Date: Sep 2011
Location: Nebraksa
Posts: 242
Wrench light on start up

My polaris service interval diagnostic mode indicator light comes on at start up. Then flashes a couple times then goes off. Is this normal?

2005 800 efi

His ~ 2013-Scrambler XP - Painted Polaris Grille Guard ~ Polaris Lock and Ride Box ~ ODI Rouge Grips ~ MSA M12 Diesel Gloss Black Wheels ~ 28x9x14 Swamplites(Front) ~ 28x11x14 Swamplites(Rear)

Hers ~ 2005 sportsman 800 EFI - Polaris Winch - 27" Outlaw MST's ~ Raceline Monster Wheels ~ FOR SALE
Scrambler2Sportsman is offline  
Sponsored Links
Advertisement
 
post #2 of 7 (permalink) Old 02-15-2012, 08:07 PM
Polaris ATV Legend
 
blueline15's Avatar
 
Join Date: Feb 2009
Location: Washington State
Posts: 6,903
Reverse countdown hour meter. It does this when that Meyer counts down to zero to remind you it's time to service.

You can reset it in one hour increments from 1-99 or turn the feature off by going into the diagnostic mode.

Key off
In neutral
Parking break set
Wait 10 secs
Press and hold yellow override button
Turn key to on (engine off)

Should load diagnostic mode. Scroll thru using yellow override button, press and hold when at hour meter screen to reset or turn off.

Getting into diagnostic mode is from memory. Apologies if I screwed it up.
blueline15 is offline  
post #3 of 7 (permalink) Old 02-15-2012, 08:08 PM Thread Starter
Extreme ATV Enthusiast
 
Scrambler2Sportsman's Avatar
 
Join Date: Sep 2011
Location: Nebraksa
Posts: 242
So is that telling me I need to service my rig?

His ~ 2013-Scrambler XP - Painted Polaris Grille Guard ~ Polaris Lock and Ride Box ~ ODI Rouge Grips ~ MSA M12 Diesel Gloss Black Wheels ~ 28x9x14 Swamplites(Front) ~ 28x11x14 Swamplites(Rear)

Hers ~ 2005 sportsman 800 EFI - Polaris Winch - 27" Outlaw MST's ~ Raceline Monster Wheels ~ FOR SALE
Scrambler2Sportsman is offline  
Sponsored Links
Advertisement
 
post #4 of 7 (permalink) Old 02-16-2012, 11:19 AM
Super Moderator
 
bobx2's Avatar
 
Join Date: Apr 2011
Location: Colorado
Posts: 5,825
Garage
It is telling you that the hour count down meter has reached zero. I believe the factory setting when new is for 50 hours. That is what I re-set mine to after each service so I stay on my service schedule. I would guess you need to service your machine and then re-set the meter to your desired service interval. An hour service schedule is better than a milage schedule IMO.

2015 Sportsman 570 Touring EPS, 26" Kenda Bearclaw HTR's on ITP Delta Steel wheels, Warn XT25, Iron Baltic HDPE Skid Plates (Mine)
2015 Sportsman 570 Touring EPS, 26" Kenda Bearclaw HTR's on ITP Delta Steel wheels, Warn Vantage 3000, Warn Mid-Mount Plow (Wife's)

2011 XP 850 EPS (SOLD 3,600 miles), 28" Kenda Bearclaw HTR's on STI HD2 Wheels, Warn XT25, Ricochet Ultimate protection, Elka Stage 1 shocks, QSC clutch kit
2009 Sportsman 500 EFI HO (SOLD 2,600 miles), 26" Maxxis Bighorns, ITP Delta Steel wheels, Polaris 2,500 lb. winch, Cycle Country plow (Wife's)
2007 Sportsman 800 X2 (SOLD 2,500 miles), 26" Maxxis Bighorns, ITP Delta Steel wheels, Polaris 2,500 lb. winch
bobx2 is offline  
post #5 of 7 (permalink) Old 02-16-2012, 11:39 AM
Polaris ATV Legend
 
blueline15's Avatar
 
Join Date: Feb 2009
Location: Washington State
Posts: 6,903
Quote:
Originally Posted by Scrambler2Sportsman View Post
So is that telling me I need to service my rig?
Depends if whoever serviced it last didn't reset the meter. If this machine is fairly new to you, it may be best to do its service now, and than reset the meter to 50 hours so you know its good to go.
blueline15 is offline  
post #6 of 7 (permalink) Old 02-16-2012, 11:41 AM
Polaris ATV Legend
 
Diesel man 03's Avatar
 
Join Date: Sep 2010
Location: Wisconsin
Posts: 1,806
It means that the last person that changed the oil did not reset it, or maybe it was not changed at all.
Diesel man 03 is offline  
post #7 of 7 (permalink) Old 02-16-2012, 04:20 PM
Polaris ATV Legend
 
KICKER431's Avatar
 
Join Date: Aug 2011
Location: Chaumont NY
Posts: 2,069
Here is a link to another thread where Blueline told us exactly how to get into dignostic mode and reset the meter.

Wrench flashing on dash

hope that helps

Oops, I didn't read Blueline's comment above before posting this. I will leave it here anyway incase he did mess it up earlier but it does look right. The link is slightly more detailed.

MINE:2015 Sportsman SP 800 Sunset Red
completely stock FOR NOW

HERS:2007 Sportsman 700 EFI Black Metallic
Tamarack Cargo Seat, Fender Guards with footpegs from Thor, UNI air filter, Symtec heated grips
Warn 2500 with synthetic rope, ThermoTec exhaust wrap, Reverse Override, 3 Headlight Mod
26" Maxxis Bighorn 2.0



RIP Sarge (2004 Sportsman 700 EFI killed on trail 32, Rock House, Hatfield-McCoy)

Last edited by KICKER431; 02-16-2012 at 04:22 PM. Reason: didn't read above
KICKER431 is offline  
Reply

  Lower Navigation
Go Back   Polaris ATV Forum > Polaris Model Specific Discussions > Polaris Sportsman

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Polaris ATV Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Thread Thread Starter Forum Replies Last Post
Wrench light on after 2 hrs?? CNEDEER ATV Repair and Maintenance 3 02-15-2011 03:04 PM
Nuetral "Green" Light ~ To Start!!! kjpacer ATV Repair and Maintenance 4 01-12-2011 05:18 PM
Maint Wrench light no showing... jshields ATV Repair and Maintenance 7 09-23-2010 11:38 AM
Sportsman 500 temp light comes on/fan won't auto start? Michigan Sportsman 500 Polaris Sportsman 3 03-16-2010 08:19 AM
battery light and wrench flashing rrrssm ATV Repair and Maintenance 3 08-23-2009 12:06 AM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome