Polaris ATV Forum
Go Back   Polaris ATV Forum > Polaris Model Specific Discussions > Polaris Sportsman

Polaris Sportsman Discussions for the Polaris Sportsman 90, 300, 355, 400, 450, 500, 550, 600, 700, 800, 850

Reply
 
LinkBack Thread Tools Display Modes
  #1 (permalink)  
Old 05-12-2012, 05:18 AM
gixxerone's Avatar
ATV Enthusiast
 
Member #20355
Join Date: Nov 2011
Location: mass
Posts: 54
help...my 500 ho has a charging problem

Its a 2008 sportsman 500 ho carb model and its not charging properly. At idle its at 12.5 and reved to 3k rpm it spikes to 16-17 volts! I think the controller module under the headlight pod is the problem (alum. with fins, one big connector) part # 4011568 . Can some one please give some insight, i don't want to order the wrong part. thank you for your help.
Reply With Quote
Sponsored Links
PolarisATVForums is the premier Polaris ATV Forum on the internet. Registered Users do not see these ads, So Register, It's Free!
  #2 (permalink)  
Old 05-13-2012, 10:25 AM
gixxerone's Avatar
ATV Enthusiast
 
Member #20355
Join Date: Nov 2011
Location: mass
Posts: 54
Please, any help at all ...
Reply With Quote
  #3 (permalink)  
Old 05-13-2012, 12:02 PM
BOBANDTOBY's Avatar
ATV Enthusiast
 
Member #16646
Join Date: Jul 2011
Location: SW MANITOBA
Posts: 43
regulator

thats the regulator you are talking about which might be the problem. Have heard lots of others say its the stator gone bad. My 2010 500HO is doing the same thing so I will be watching this thread.
__________________
2013 400 HO
2011 850 XP EPS
2010 500 HO sold now
2002 425 Xpedition
Reply With Quote
  #4 (permalink)  
Old 05-13-2012, 12:29 PM
gixxerone's Avatar
ATV Enthusiast
 
Member #20355
Join Date: Nov 2011
Location: mass
Posts: 54
If it was not charging at all is is most likely a bad stator. Mine is over charging making me believe the controller module (voltage regulator on 08 500 hO) is bad.
Reply With Quote
  #5 (permalink)  
Old 05-13-2012, 12:51 PM
jordaman17's Avatar
Polaris ATV Legend
 
Member #13240
Join Date: Mar 2011
Location: Renfrew, Ontario, Canada
Posts: 2,372
Quote:
Originally Posted by gixxerone View Post
If it was not charging at all is is most likely a bad stator. Mine is over charging making me believe the controller module (voltage regulator on 08 500 hO) is bad.
Ditto
__________________
5400km 2008 Polaris Sportsman 500 Ho, Polaris Hand & Thumb warmers, RotoPax 4 Gallon Fuel Pack, Custom Made Rear Bumper, PowerMadd Hand Guards, Polaris Rear Work Lights, Ricochet Ultimate Armor, Polaris 3500lb Winch, Rear Rack Extender, Polaris Brush Guard, 3 Headlight Mod, Uni Air Filter, EPI 'patv1' primary clutch spring. All up on Interco Swamplites! Maintenance is the key to a never ending happiness

Check out and subscribe to my youtube channel! ---> http://www.youtube.com/user/mudsling...ew=0&flow=grid
Reply With Quote
  #6 (permalink)  
Old 05-13-2012, 02:54 PM
gixxerone's Avatar
ATV Enthusiast
 
Member #20355
Join Date: Nov 2011
Location: mass
Posts: 54
Quote:
Originally Posted by jordaman17 View Post
Quote:
Originally Posted by gixxerone View Post
If it was not charging at all is is most likely a bad stator. Mine is over charging making me believe the controller module (voltage regulator on 08 500 hO) is bad.
Ditto
Thank you........
Reply With Quote
  #7 (permalink)  
Old 05-16-2012, 08:21 AM
blueline15's Avatar
Super Moderator
Premium Member
 
Member #230
Join Date: Feb 2009
Location: Washington State
Posts: 6,899
I agree, I think you're on the right track yet. Any update?
Reply With Quote
  #8 (permalink)  
Old 05-16-2012, 05:34 PM
gixxerone's Avatar
ATV Enthusiast
 
Member #20355
Join Date: Nov 2011
Location: mass
Posts: 54
Quote:
Originally Posted by blueline15 View Post
I agree, I think you're on the right track yet. Any update?
I ordered the module on Sat. ......hopwfully it shows up Friday.....i will update when installed.
Reply With Quote
  #9 (permalink)  
Old 05-22-2012, 12:30 PM
gixxerone's Avatar
ATV Enthusiast
 
Member #20355
Join Date: Nov 2011
Location: mass
Posts: 54
Ok the controller module showed up and i installed it today , $185 dollars later and its still not fixed !!!! WTF? Can some one please help me with this???? Could it possibly be the black box right under the Headlight/gauge pod???? Maybe called the cdi box??? This is very frustraiting.
Reply With Quote
  #10 (permalink)  
Old 05-22-2012, 05:00 PM
BOBANDTOBY's Avatar
ATV Enthusiast
 
Member #16646
Join Date: Jul 2011
Location: SW MANITOBA
Posts: 43
price

$185 bucks for a regulator sounds like a lot. I just ordered one for my 2010 that cost me $60 with shipping, haven't received it yet. I still think you might be having stator issues. Searching on here found that was the problem more then once. I agree that if it was charging everyone thinks that they are fine but they start shorting out making them spike up to 18 volts. Stator is a little expensive though to order one and find out its not the problem. Good luck
__________________
2013 400 HO
2011 850 XP EPS
2010 500 HO sold now
2002 425 Xpedition
Reply With Quote
Reply

Lower Navigation
Go Back   Polaris ATV Forum > Polaris Model Specific Discussions > Polaris Sportsman


Search tags for this page
2002 polaris 500 ho charging problem
,

2008 polaris sportsman 500 ho stator

,
2008 polaris sportsman 500 ho voltage regulator
,
2008 polaris sportsman 500 voltage regulator
,
2012 polaris sportsman stator issues
,
location of stator on 2008 polaris sportsman 500 ho
,
polaris 500 ho voltage regulator
,
polaris sportsman 400 ho charging issues
,

polaris sportsman 500 charging problem

,

polaris sportsman 500 charging problems

,
polaris sportsman 500 not charging
,
sportsman 500 charging problem
Click on a term to search our sites for related topics.

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
06 500 X2 charging problem please help fireman659 ATV Repair and Maintenance 4 11-21-2012 11:02 AM
charging problem. kkchevy ATV Repair and Maintenance 9 03-08-2012 12:05 PM
Charging problem Ratboy Polaris Sportsman 6 01-15-2012 01:57 PM
Charging problem shore Polaris XP 10 12-30-2011 10:20 AM
charging problem gator Polaris Sportsman 3 06-22-2010 12:26 PM

Motosport.com


All times are GMT -8. The time now is 08:33 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.