Polaris ATV Forum
Go Back   Polaris ATV Forum > Polaris Model Specific Discussions > Polaris Sportsman

Polaris Sportsman Discussions for the Polaris Sportsman 90, 300, 355, 400, 450, 500, 550, 600, 700, 800, 850

Reply
 
LinkBack Thread Tools Display Modes
  #1 (permalink)  
Old 10-16-2012, 09:06 AM
tvolsr1's Avatar
Junior Member
 
Member #31093
Join Date: Oct 2012
Posts: 7
electrical problems

2008 sportsman 500 carburated. My son decided to use it as a submarine a few weeks ago. I drained fluids and started it, no problems. After setting for a few days it will no longer start, won't even turn over. I have replaced battery (it was weak anyways), checked the starter solenoid (good), and checked ground and wiring and it's all good. I've got a clymer service manual and it says that 08 models have a circuit breaker and fuse panel. Can anyone tell me where they are located??? I've looked under the headlight and there are only two boxes. One is the ECU and the other is a solid black box. Also, the speedo assembly has water in it and the digital readout is not working. Could the speedo assembly be my problem? ANY help is greatly appreciated.
Reply With Quote
Sponsored Links
PolarisATVForums is the premier Polaris ATV Forum on the internet. Registered Users do not see these ads, So Register, It's Free!
  #2 (permalink)  
Old 10-16-2012, 11:38 AM
InRBigness's Avatar
Polaris ATV Legend
 
Member #7218
Join Date: Sep 2010
Location: Winnipeg, Manitoba
Posts: 2,113
I would try and hook the starter up directly to a known good battery. I will bet that some water got in the starter and the brushes are rusted and not making contact. If it does move on to the next suggestion.

If that turns over then you have other issues. One thing the speedo does is tells the quad what gear it is in. If you are not in neutral or park you have to pull the hand brake to start. If that is not working right you may have found a problem.
__________________
12 Starfire Blue Sportsman 850XPHO LE EPS:
- Fender guards, 3500lb PolarisHD winch, Polaris hand warmers, Powermadd hand guards, HID lights, Guru Front Guard, Ricochet A-Arm guards, front L&R box, Uni Air Filter. 27" Black Diamonds, Odyssey Battery, Rhino front axles, QSC clutch kit

12 Bronze Mist Sportsman 850XPHO EPS
- 3500lb PolarisHD winch, Polaris hand warmers, Powermadd Hand guards, HID lights, Guru Front Guard, Ricochet A-Arm guards, Front L&R box, Uni Air Filter. 27" Black Diamonds, Odyssey Battery, Rhino front axles

08 Sportsman 500HO
-26" STI Black Diamond, Kimpex box with seat, Rack/Fender guards, Uni Air Filter, HID lights, Ricochet A-Arm guards, Polaris 3500HD, Polaris hand/thumb warmers, EPI clutch, Rhino front axles

01 500HO Plow Machine
-Kenda Bearclaws, Kimpex Plow, hand warmers, Warn winch

Faithful friends no longer with me:
94 Sportsman 400 4x4- owned 18 years
2000 Xplorer 400 4x4- owned 10 years
Reply With Quote
  #3 (permalink)  
Old 10-16-2012, 04:19 PM
Bruce!'s Avatar
Polaris ATV Legend
Premium Member
 
Member #193
Join Date: Feb 2009
Location: Port Angeles WA
Posts: 20,000
Welcome to the board!
Reply With Quote
  #4 (permalink)  
Old 10-20-2012, 10:56 AM
tvolsr1's Avatar
Junior Member
 
Member #31093
Join Date: Oct 2012
Posts: 7
PROBLEM SOLVED!!!!! I bought a new speedometer for it and it fired right up.
Reply With Quote
  #5 (permalink)  
Old 10-20-2012, 11:01 AM
vortecz71wv's Avatar
Polaris ATV Junkie!
 
Member #14032
Join Date: Apr 2011
Location: Morgantown, WV
Posts: 1,182
Sorry man , wish i would have seen this sooner so you could have been up and running. Had this happen to a 2001 sportsman and a new speedo fixed it.

Matt
__________________
Mine:

2011 Sportsman 800
Polaris Front Brush Guard, Polaris Rear Brush Guard, Polaris Rear Rack Extender, Polaris L&R Rear Cargo Box, Warn 2500lb winch, Winch Saver, Ricochet A-Arm Guards (www.TheATVSuperStore.com), 3-High Headlight Mod, 6000k HID kit, Rigid Ind. 2xDually w/ strobe box, UNI Air Filter, 26" GBC Dirt Commanders, 1" Billet Wheel Spacers (Front and Rear) HighLifter HD springs, Dalton Primary Spring O\BL, Realtree Seat custom cover, Polaris Handguards

Wife's

2011 Sportsman 550XP
Polaris Front Brush Guard, Polaris Rear Brush Guards, Polaris Rear Rack Extender, 26" GBC Grim Reapers, Viper Elite 3000lbs Winch w/ wireless, Polaris Handguards, 6000k HID Kit

Fuel It, Flog It, Feel It!
Reply With Quote
  #6 (permalink)  
Old 10-22-2012, 07:27 AM
tvolsr1's Avatar
Junior Member
 
Member #31093
Join Date: Oct 2012
Posts: 7
We rode it all weekend and it did fine. So speedo was difinitely the problem. Even though $250 for the speedo wasn't cheap, I'm glad I took a guess instead of taking to the polaris dealer for $75 an hour!
Reply With Quote
Reply

Lower Navigation
Go Back   Polaris ATV Forum > Polaris Model Specific Discussions > Polaris Sportsman


Search tags for this page

2012 sportsman 800 electric issues

,

2012 sportsman altenator

,

what is the electrical box on the front rack of my polaris

Click on a term to search our sites for related topics.

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
electrical problems Toomanycars Polaris Scrambler 1 06-01-2012 09:03 PM
Electrical Problems 600RacerX Polaris Sportsman 4 05-30-2012 11:14 AM
electrical problems kristi00 ATV General Discussion 1 04-01-2012 04:17 PM
Electrical problems...help please 2001polarissportsman90 ATV Repair and Maintenance 3 07-04-2011 04:25 PM
electrical problems robster248 ATV Repair and Maintenance 17 05-17-2011 05:31 PM

Motosport.com


All times are GMT -8. The time now is 11:52 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.