Question about "Y" throttle cable - Polaris ATV Forum
Polaris Trail Blazer Discussions pertaining to the Polaris Trail Blazer

 
LinkBack Thread Tools Display Modes
post #1 of 9 (permalink) Old 01-02-2011, 08:16 AM Thread Starter
Junior Member
 
Timbo's Avatar
 
Join Date: Jan 2011
Location: Upper Michigan
Posts: 11
Question about "Y" throttle cable

On my 93 350 4X4 it has a "Y" throttle cable, on the Y, one end goes to the carb. The other end goes down to the front of the crankcase, what does this end connect to and what is its purpose?
Timbo is offline  
Sponsored Links
Advertisement
 
post #2 of 9 (permalink) Old 01-02-2011, 08:44 AM
Extreme ATV Enthusiast
 
waynev's Avatar
 
Join Date: Aug 2010
Location: Timmins, Ontario
Posts: 295
if it is 2 stroke it goes down to the oil injection pump

2010 Sportsman 850 XP EPS Stealth Black
Glacier II Plow System with plow strap
3500HD Polaris Winch w/ synthetic rope
2010 Sportsman 550 XP EPS Crimson Red, Rear Seat
waynev is offline  
post #3 of 9 (permalink) Old 01-02-2011, 08:53 AM Thread Starter
Junior Member
 
Timbo's Avatar
 
Join Date: Jan 2011
Location: Upper Michigan
Posts: 11
Thanks waynev!
Timbo is offline  
Sponsored Links
Advertisement
 
post #4 of 9 (permalink) Old 01-02-2011, 09:56 AM
Extreme ATV Enthusiast
 
waynev's Avatar
 
Join Date: Aug 2010
Location: Timmins, Ontario
Posts: 295
no problem

2010 Sportsman 850 XP EPS Stealth Black
Glacier II Plow System with plow strap
3500HD Polaris Winch w/ synthetic rope
2010 Sportsman 550 XP EPS Crimson Red, Rear Seat
waynev is offline  
post #5 of 9 (permalink) Old 01-02-2011, 01:19 PM
Polaris ATV Legend
 
blueline15's Avatar
 
Join Date: Feb 2009
Location: Washington State
Posts: 6,903
waynev is correct. the 350L is a 2 stroke, so one end does go to the carb, the other end goes to the oil injection.
blueline15 is offline  
post #6 of 9 (permalink) Old 01-02-2011, 01:25 PM
Extreme ATV Enthusiast
 
waynev's Avatar
 
Join Date: Aug 2010
Location: Timmins, Ontario
Posts: 295
yup we have a trail boss 350L at home it's a 1991 runs perfect. did alot of work to it but it likes to eat clutch covers lol the motor mounts were broke before.

2010 Sportsman 850 XP EPS Stealth Black
Glacier II Plow System with plow strap
3500HD Polaris Winch w/ synthetic rope
2010 Sportsman 550 XP EPS Crimson Red, Rear Seat
waynev is offline  
post #7 of 9 (permalink) Old 01-02-2011, 01:34 PM Thread Starter
Junior Member
 
Timbo's Avatar
 
Join Date: Jan 2011
Location: Upper Michigan
Posts: 11
Mine is pretty beat, need struts/shock, starter solenoid, a rebuild, but it starts on the first pull and plows the snow good.
I was going to replace the cable but its $104! Guess I'll just lube it and hopes it hold out.
Timbo is offline  
post #8 of 9 (permalink) Old 01-19-2011, 10:59 AM
ATV Enthusiast
 
shane_zuk's Avatar
 
Join Date: Oct 2010
Location: Crestview Fl
Posts: 33
Get an oil injection block off kit, pre-mix, and get a cheaper single throttle cable. The injection block off kits with cable are around $60. Ritter Cycyle Racing has them, that is the kit I have on mine.
shane_zuk is offline  
post #9 of 9 (permalink) Old 01-19-2011, 12:15 PM Thread Starter
Junior Member
 
Timbo's Avatar
 
Join Date: Jan 2011
Location: Upper Michigan
Posts: 11
Thanks Shane, I'll look into it.
Timbo is offline  
Reply

  Lower Navigation
Go Back   Polaris ATV Forum > Polaris Model Specific Discussions > Polaris Trail Blazer

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Polaris ATV Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Thread Thread Starter Forum Replies Last Post
2006 Sportsman 700 EFI "dies above idle" NEED HELP ASAP FOR WEEKEND RIDE xlwater Polaris Sportsman 6 12-29-2012 10:59 PM
I'm thinking "Western States" with Alaska and Hawaii and the rest... Bruce! Western States 8 02-02-2011 05:50 AM
"Clicking" sound coming from front end when turning (05 Sportsman 400 4x4) NickS ATV Repair and Maintenance 8 01-03-2011 06:48 PM
Polaris 700 Twin EFI... "Wait" and "End" Error? TechieSooner Polaris Sportsman 3 11-26-2010 07:20 PM
A "Mark Forums Read" button (link) working. scottdeet Site Issues & Suggestions 4 09-17-2010 07:51 PM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome