Polaris ATV Forum
Go Back   Polaris ATV Forum > Polaris Model Specific Discussions > Polaris Trail Blazer

Polaris Trail Blazer Discussions pertaining to the Polaris Trail Blazer

Reply
 
LinkBack Thread Tools Display Modes
  #1 (permalink)  
Old 03-08-2013, 08:56 AM
cadamo's Avatar
Junior Member
 
Member #34634
Join Date: Mar 2013
Posts: 4
2008 Trailblazer Electrical Problems

Just picked up a 330 from my brother to help him get it fixed and sold. He used it once for about 3 hours. Here's the problem:

Battery was dead and he has had battery issues since day 1. I replaced the battery and charged it up. No lights, no electrical start, no nothing. I've used known good batteries and same problem.

The fan on the radiator will continue to run. Haven't tried starting via pull start since I don't think that would help me in any way.

A dealer a while back said the control module and thermister needed to be changed. I think I'm going to as I don't know what else to do.

Any ideas on where to start troubleshooting something like this?

Also appears to be a ground female wire under the headlight that is not connected to anything.

I have no wiring diagram or shop manual so any help would be greatly appreciated. Thanks!

Last edited by cadamo; 03-08-2013 at 09:29 AM.
Reply With Quote
Sponsored Links
PolarisATVForums is the premier Polaris ATV Forum on the internet. Registered Users do not see these ads, So Register, It's Free!
  #2 (permalink)  
Old 03-08-2013, 03:39 PM
Bruce!'s Avatar
Super Moderator
Premium Member
 
Member #193
Join Date: Feb 2009
Location: Port Angeles WA
Posts: 19,443
Welcome to the board!
Reply With Quote
  #3 (permalink)  
Old 03-10-2013, 06:56 PM
cadamo's Avatar
Junior Member
 
Member #34634
Join Date: Mar 2013
Posts: 4
Thanks. Now all I need is some help! I've tested the kill switch and that seems to work fine. Nothing else on the bike is working. No lights, no display, no electric start. The only hing that runs is the radiator fan.
Is it the controller module? Is that what you would replace? Do these go bad?
Thanks again.
Reply With Quote
  #4 (permalink)  
Old 03-15-2013, 11:33 AM
cadamo's Avatar
Junior Member
 
Member #34634
Join Date: Mar 2013
Posts: 4
Update

So I ordered a new Controller Module since I can't figure out what is wrong with the electrical. Polarisparts.com or something like that. Hasn't shipped yet but when I get the new part I'll post an update.

Still looking for suggestions if anyone has them.

Thanks.
Reply With Quote
  #5 (permalink)  
Old 03-21-2013, 04:38 AM
cadamo's Avatar
Junior Member
 
Member #34634
Join Date: Mar 2013
Posts: 4
Problem solved

Controller module did the trick. Replaced it and $225 later everything works like a charm. Selling the bike now, out of Central NJ. has about 3 hours on it. Who wants it????
Reply With Quote
Reply

Lower Navigation
Go Back   Polaris ATV Forum > Polaris Model Specific Discussions > Polaris Trail Blazer


Search tags for this page
08 polaris 330 trail blazer kill switch
,

08 polaris trailblazer 330 cooling fan runs all the time

,
08 polaris trailblazer 330 cooling fan runs all the time#gsc.tab
,
2008 polaris 330 trailblazer
,
2008 polaris trail blazer electrical problems
,
2008 polaris trailblazer 330
,
2008 polaris trailblazer electrical problems
,

2008 polaris trailn blazer electrical parts

,
electrical diagrams for a 330 polaris 2008 trailblazer
,
polais trailblzer no eletrical power
,
polaris trailblazer 250 wiring diagram
,
polaris trailblazer starter 330 2008 start problem
Click on a term to search our sites for related topics.

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
2008 trailblazer 330 body parts BIGDAWG75 ATV General Discussion 4 11-14-2012 08:50 PM
electrical problems tvolsr1 Polaris Sportsman 5 10-22-2012 07:27 AM
electrical problems blazin500 ATV Repair and Maintenance 6 09-10-2012 07:37 AM
Just picked up a 2008 Trailblazer 330, have some ?'s Vegasrph Polaris Trail Blazer 6 06-25-2012 01:07 PM
Electrical Problems Think38 Polaris Sportsman 10 05-24-2009 06:44 PM

Motosport.com


All times are GMT -8. The time now is 08:01 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.