Polaris ATV Forum
Go Back   Polaris ATV Forum > Polaris Model Specific Discussions > Polaris Trail Boss

Polaris Trail Boss Discussions for the Polaris Trail Boss

Reply
 
LinkBack Thread Tools Display Modes
  #1 (permalink)  
Old 08-08-2011, 09:50 AM
Trapp's Avatar
Junior Member
 
Member #17500
Join Date: Aug 2011
Posts: 2
Idle Problem

I just cleaned the carb on my 2003 Trail Boss 330 and it starts but it idles really high. When I turn the idle screw to lower the idle it doesnt do anything it just stays the same. The weird thing is that when I pull the choke the rpms drop
Reply With Quote
Sponsored Links
PolarisATVForums is the premier Polaris ATV Forum on the internet. Registered Users do not see these ads, So Register, It's Free!
  #2 (permalink)  
Old 08-08-2011, 12:53 PM
4getful2's Avatar
Polaris ATV Legend
 
Member #1234
Join Date: Aug 2009
Location: illinois
Posts: 1,940
Check the throttle cable ,to make sure it is not binding up somewhere.
Reply With Quote
  #3 (permalink)  
Old 08-08-2011, 03:52 PM
Trapp's Avatar
Junior Member
 
Member #17500
Join Date: Aug 2011
Posts: 2
Thanks! I just had to adjust the throttle cable a bit and now it runs like a champ.

Thanks again for the quick reply!
Reply With Quote
  #4 (permalink)  
Old 11-20-2011, 09:10 AM
felony's Avatar
Junior Member
 
Member #20584
Join Date: Nov 2011
Location: northern california
Posts: 8
Send a message via AIM to felony Send a message via Yahoo to felony
OMG! i have an 03 325. mine revs super high with choke just barely out, and pulled out all the way the idle drops to almost wanting to die. i thaught it was suppose to do that? also it wont stay running even when warmed up if in put the choke all the in. so in order to ride it i have to have choke pulled all the way out.

i baught this quad a week ago. it had been sitting for 3 years.
Reply With Quote
  #5 (permalink)  
Old 11-24-2011, 06:00 AM
Diesel man 03's Avatar
Polaris ATV Junkie!
 
Member #7294
Join Date: Sep 2010
Location: Wisconsin
Posts: 1,463
felony, sounds like you need a carb cleaning, jets are probably plugged.
Reply With Quote
  #6 (permalink)  
Old 11-24-2011, 08:55 AM
felony's Avatar
Junior Member
 
Member #20584
Join Date: Nov 2011
Location: northern california
Posts: 8
Send a message via AIM to felony Send a message via Yahoo to felony
Thanks. i just changed all the fluids and filters and spark plug. i never thaught about the carberator.
Reply With Quote
Reply

Lower Navigation
Go Back   Polaris ATV Forum > Polaris Model Specific Discussions > Polaris Trail Boss


Search tags for this page
2005 polaris 330 magnum cold idle issues
,

2005 polaris 330 magnum idle speed

,

250 trailboss idle to high unless choke on

,
a 2005 polaris 330 magnum want run but run with chock out
,
high idle problems on polaris 325 trail boss
,
polaris 330 will not idle unless choke is on
,
polaris 330 wont idle high unless unless choke is on
,

polaris magnum 330 wont idle

,

polaris magnum idles high

,
polaris trail boss fast idle
,

polaris trailboss runaway idle

,
problem with polaris trail boss 330 idleing
Click on a term to search our sites for related topics.

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
Problem with idle mix screw Natureboy Polaris Sportsman 10 08-15-2011 03:27 AM
Idle problem QuadCorey Polaris Scrambler 3 07-03-2011 08:12 AM
CVT Problem... Belt slap at Idle... 97 Xplorer iif3lixii Polaris Magnum 2 07-23-2010 04:58 PM
1994 explorer 400L 4X4 idle problem GREYWOLF1957 ATV Repair and Maintenance 3 11-27-2009 09:32 PM
Cold Start Idle Problem - Suggestions Atv Dad Polaris Scrambler 4 11-08-2009 01:50 PM

Motosport.com


All times are GMT -8. The time now is 05:37 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.