2004 Trail Boss 330 - Polaris ATV Forum
Polaris Trail Boss Discussions for the Polaris Trail Boss

Reply
 
LinkBack Thread Tools Display Modes
post #1 of 13 (permalink) Old 01-17-2012, 07:42 PM Thread Starter
Junior Member
 
troy5050's Avatar
 
Join Date: Oct 2011
Location: Lake Havasu City AZ
Posts: 6
2004 Trail Boss 330

OK Guys I need some help I just bought this 04 Trail Boss it runs very good after it get's warm up only problem is getting it to warm up I choke it & it starts right away & I keep pulling choke in out just to keep it running after 3to4 min it will finally run with out the choke. Why is it taking so long to warm up.
THANKS

Last edited by troy5050; 01-17-2012 at 07:45 PM.
troy5050 is offline  
Sponsored Links
Advertisement
 
post #2 of 13 (permalink) Old 01-17-2012, 08:31 PM
Polaris ATV Junkie!
 
factionfx's Avatar
 
Join Date: Nov 2011
Location: Dallas, TX
Posts: 662
My 2000 325 does this, as well as my 2012 sportsman 500.

2012 Sportsman 500, Red.
Highlifter HD Springs all around, Moose pregressors on front (not activated). EPI 'patv1' primary clutch spring, UNI air filter w/ PJ-1 oil. K&N Model KN-303 oil filters. Bikemaster foam grips.
factionfx is offline  
post #3 of 13 (permalink) Old 01-19-2012, 07:33 AM
Junior Member
 
winstoncup's Avatar
 
Join Date: Nov 2011
Location: New Hampshire
Posts: 22
I thought I was the only one... for me, I pull choke out and it starts right up... within a minute or so it is already choking out, as you'd expect, and I need to play with choke/gas for a few minutes and sometimes stall/restart before it runs smoothly...

I just had the carb cleaned, tuned and needle/seat replace... my experience with this is that on a cold day when choke is applied it stays on high/choked idle for a couple minutes before bogging and then stepping down choke smooths out until finally warm... my Trailboss just doesn't behave this way and it is a pain to get it to the point it smooths out... ;(

--
Winstoncup
winstoncup is offline  
Sponsored Links
Advertisement
 
post #4 of 13 (permalink) Old 01-19-2012, 10:59 AM Thread Starter
Junior Member
 
troy5050's Avatar
 
Join Date: Oct 2011
Location: Lake Havasu City AZ
Posts: 6
Thank You for your reply. Happy to here someone is having the same problem as I'm having. So I guess now I'll just live with it. Thanks agin
troy5050 is offline  
post #5 of 13 (permalink) Old 01-19-2012, 05:26 PM
Junior Member
 
cwmiers's Avatar
 
Join Date: Jan 2012
Location: houghton lake
Posts: 2
trailboss 330

i all so have a 2005 330 trailboss with carb problems it starts up and takes sometime to get running but 1/2 to full throttle bogs and the exaust turns red so i incresed thr pilot jet and the main jet to a 165 and pilot to a 50 witch made it better but if i hook up a rubber tube to a uni filter it bogs again and back fiers i dont know why so if any one knows let me know
cwmiers is offline  
post #6 of 13 (permalink) Old 01-19-2012, 06:22 PM Thread Starter
Junior Member
 
troy5050's Avatar
 
Join Date: Oct 2011
Location: Lake Havasu City AZ
Posts: 6
Boy from what reading & hearing about this model we'll just have to live with it. That's really a shame I thought Polaris always put out a good product but this is a very bad problem for them & they should have a recall on this model. Thanks for your reply
troy5050 is offline  
post #7 of 13 (permalink) Old 02-18-2012, 07:15 PM
Extreme ATV Enthusiast
 
03 trail boss's Avatar
 
Join Date: Dec 2009
Location: Portland MI
Posts: 157
Our 03 trail boss 330 does the same thing, and even our 2012 sportsman 500 takes forever to warm up!

03 trail boss is offline  
post #8 of 13 (permalink) Old 02-19-2012, 05:09 AM
Junior Member
 
winstoncup's Avatar
 
Join Date: Nov 2011
Location: New Hampshire
Posts: 22
This seems to be a flaw in the choke/carb design to me... not an expert here, but every other 4-stroke engine I have is very predictable on cold starts working thru the choke process to run smoothly...

Definitely a shame to see that even newer models have this issue, this is fundamental operation of an engine and you'd think that Polaris would figure this out... ;(
winstoncup is offline  
post #9 of 13 (permalink) Old 02-19-2012, 07:01 PM
Polaris ATV Junkie!
 
factionfx's Avatar
 
Join Date: Nov 2011
Location: Dallas, TX
Posts: 662
My 500 sportsman is not doing this so much anymor since it more broken in now with 20hrs.

Iwould bet they all need to be adjusted a little bit

Sent from my NookColor using Tapatalk

2012 Sportsman 500, Red.
Highlifter HD Springs all around, Moose pregressors on front (not activated). EPI 'patv1' primary clutch spring, UNI air filter w/ PJ-1 oil. K&N Model KN-303 oil filters. Bikemaster foam grips.
factionfx is offline  
post #10 of 13 (permalink) Old 02-20-2012, 08:03 AM
Junior Member
 
winstoncup's Avatar
 
Join Date: Nov 2011
Location: New Hampshire
Posts: 22
I just had mine in the shop for tune-up, carb clean and they put new needle and seat in... perhaps it still needs to be tuned, but would expect it... dunno, seems to be across the board, no pun intended...
winstoncup is offline  
Reply

  Lower Navigation
Go Back   Polaris ATV Forum > Polaris Model Specific Discussions > Polaris Trail Boss

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Polaris ATV Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Thread Thread Starter Forum Replies Last Post
2004 Polaris Trail boss 330 no start Bensmotorworks ATV Repair and Maintenance 5 04-18-2012 01:28 PM
2004 Polaris Trail Boss 330 troy5050 Polaris Trail Boss 6 11-15-2011 04:38 PM
2004 Trail Boss 330 -- Replacement trailmonkey ATV Wheels & Tires 2 04-14-2011 08:38 PM
2004 polaris trail boss crankshaft TimBud22 ATV Repair and Maintenance 1 03-27-2011 02:55 PM
2004 trail boss wire harness carkrazd ATV Repair and Maintenance 1 08-31-2009 07:07 PM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome