Confirm a bad TPS 2010 850 XP EFI - Polaris ATV Forum
Polaris ATV Forum
Go Back   Polaris ATV Forum > Polaris Model Specific Discussions > Polaris XP

Polaris XP The Polaris XP Forum. Discussions covering the new Polaris Sportsman XP 850/550

Reply
 
LinkBack Thread Tools Display Modes
  #1 (permalink)  
Old 11-30-2016, 01:40 PM
TBark's Avatar
Junior Member
 
Member #93305
Join Date: Nov 2016
Location: AB Canada
Posts: 15
Confirm a bad TPS 2010 850 XP EFI

Pulling my hair out with these 520194 codes, I get 520194 -2, volts over range, 520194-3 volts high, some -4 and some throttle cable adjustment -7.
Did a few adjustment on the TPS with my 5 volt tool but seems the error code and actual reading just done jive. Not with throttle body off and jumpers on at least.
Had only 2 good rides in my recent Nov hunting trip, and limped back to camp a few other times.
So I did do the ohm check on the 3 pins as the test procedure suggests, but it does not specify how far out, if any on the ohm check that would confirm a bad TPS, anyone know how far off on the specs to confirm a bad TPS ?
These were my readings,
Pins 1&2, throttle pins closed, spec 4-5 k ohm, I got 5.3 k.
Pins 1&2, throttle pins open, spec 1150-1250 ohm, I got 1900 ohm.
Pins 1&3, any position, spec 4-6 k ohm, I got 5.67.
2 seem ok but the 1900 ohm seems too far off.
Any thoughts ?

TBark

Last edited by TBark; 11-30-2016 at 01:44 PM.
Reply With Quote
Sponsored Links
PolarisATVForums is the premier Polaris ATV Forum on the internet. Registered Users do not see these ads, So Register, It's Free!
  #2 (permalink)  
Old 12-18-2016, 11:28 AM
TBark's Avatar
Junior Member
 
Member #93305
Join Date: Nov 2016
Location: AB Canada
Posts: 15
Ok, won't know this for sure til spring, but I was pulling my battery for the season before the cold snap hit here in AB, and my battery post screws were not very tight at all. So this may have been the cause of the TPS voltage fluctuating so I'll know for sure in March or April.

TBark
Reply With Quote
  #3 (permalink)  
Old 12-18-2016, 12:03 PM
Corbett1973's Avatar
Polaris ATV Legend
 
Member #19435
Join Date: Oct 2011
Location: Florence WI
Posts: 2,723
That could've been the cause, these things (xp or sp) are finicky.
__________________
07 500 EFI HO X2 Deluxe
25" Original Bighorns
Polaris HD Front springs front & rear bumpers

money is the root of all evil & man needs roots:
Reply With Quote
Reply

Lower Navigation
Go Back   Polaris ATV Forum > Polaris Model Specific Discussions > Polaris XP


Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
850 EFI some kind of electrical issue??? Wat50 ATV Repair and Maintenance 5 10-24-2016 10:04 AM
F/S: 2010 Sportsman 850 XP Browning Camo Hunter Pkg - PA bonsey ATVs For Sale 4 09-27-2016 03:44 AM
2010 850 touring whining noise Jtmoney ATV Repair and Maintenance 2 08-20-2016 06:11 PM
Shock interchange TDMax Polaris XP 7 07-13-2016 06:21 PM
sportsman 850 efi sp codtraps Polaris XP 1 06-15-2016 03:29 PM


All times are GMT -8. The time now is 07:57 PM.



Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
vBulletin Security provided by vBSecurity v2.2.2 (Pro) - vBulletin Mods & Addons Copyright © 2017 DragonByte Technologies Ltd.