2003 Sporrsman 700 ignition - Polaris ATV Forum
ATV General Discussion General Discussions about Polaris ATVs.

 
LinkBack Thread Tools Display Modes
post #1 of 1 (permalink) Old 07-11-2019, 05:50 PM Thread Starter
Junior Member
 
Ch33ch's Avatar
 
Join Date: Aug 2016
Location: Michigan
Posts: 2
2003 Sporrsman 700 ignition

Have 2003 sportsman 700. Replaced Ducati ignition with Kokusan system a few years ago. Was fine for quite a while. Now exhibiting similar problems. Backfires, low power at high rev. Cuts out. But always starts and idles. Any ideas? Do I need to replace the ignition system again??
Ch33ch is offline  
Sponsored Links
Advertisement
 
Reply

  Lower Navigation
Go Back   Polaris ATV Forum > Polaris ATV Discussions > ATV General Discussion

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Polaris ATV Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome