ignition button - Polaris ATV Forum
ATV General Discussion General Discussions about Polaris ATVs.

 
LinkBack Thread Tools Display Modes
post #1 of 7 (permalink) Old 08-13-2019, 06:11 AM Thread Starter
EJM
Junior Member
 
EJM's Avatar
 
Join Date: May 2015
Posts: 24
ignition button

Hello All,

I own a 2010 phoenix Polaris 200 and my push button has to be pressed very hard to get it to work. I tried spraying a contact cleaner to see if that would help, but it did not help. Does anyone know what part number I would have to order to replace the push button start?

Any help would be greatly appreciated.

Thanks,

EJM
EJM is offline  
Sponsored Links
Advertisement
 
post #2 of 7 (permalink) Old 08-13-2019, 08:37 AM
Polaris ATV Legend
 
latebird's Avatar
 
Join Date: May 2014
Location: Illinois
Posts: 4,148
part number 0453103 @ $125 from your friendly Polaris dealer

Shop Owner and Mechanic with over 50 years experience
latebird is online now  
post #3 of 7 (permalink) Old 08-13-2019, 08:48 AM Thread Starter
EJM
Junior Member
 
EJM's Avatar
 
Join Date: May 2015
Posts: 24
Thank you!
EJM is offline  
Sponsored Links
Advertisement
 
post #4 of 7 (permalink) Old 08-13-2019, 09:49 AM
Moderator
 
polman500's Avatar
 
Join Date: Nov 2009
Location: SE Kentucky
Posts: 8,116
Here's one on ebay for $115 with free shipping.

https://www.ebay.com/itm/New-Left-Sw...QAAOSwg9hdK4nS
polman500 is online now  
post #5 of 7 (permalink) Old 08-13-2019, 10:06 AM Thread Starter
EJM
Junior Member
 
EJM's Avatar
 
Join Date: May 2015
Posts: 24
Good deal! Thanks
EJM is offline  
post #6 of 7 (permalink) Old 08-13-2019, 10:08 AM
Polaris ATV Legend
 
latebird's Avatar
 
Join Date: May 2014
Location: Illinois
Posts: 4,148
I can get one for $108 and $7 shipping NEW

If you replace it, I would like to have the old one (I'll pay shipping to have you send it to me) or if you can wait, send me the old part and I'll see if there is a match before ordering the Polaris part - I think there might be a Chinese part that could potentially interchange (might need a different wire termination), but the one on Ebay looks striking similar to one I installed on a Roketa 150 quad and since the Phoenix is made in China, it may use the same part.

Shop Owner and Mechanic with over 50 years experience
latebird is online now  
post #7 of 7 (permalink) Old 08-13-2019, 10:24 AM Thread Starter
EJM
Junior Member
 
EJM's Avatar
 
Join Date: May 2015
Posts: 24
I spoke to my local dealer and he told me to try taking it apart first and then spray it and clean it, so I will try that first. If that doesn't work I will order it from you. I just tried to spray in the cracks when I tried to fix it. Going to tackle it this weekend
EJM is offline  
Reply

  Lower Navigation
Go Back   Polaris ATV Forum > Polaris ATV Discussions > ATV General Discussion

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Polaris ATV Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome