Now Power Headlight Cluster - Polaris ATV Forum
ATV General Discussion General Discussions about Polaris ATVs.

 
LinkBack Thread Tools Display Modes
post #1 of 2 (permalink) Old 10-03-2011, 09:37 AM Thread Starter
Junior Member
 
rancher1524's Avatar
 
Join Date: Oct 2011
Location: Evans, Washington
Posts: 3
Now Power Headlight Cluster

My 2000 Polaris Sportsman 500 rolled over. The only damage was the handle bar was pushed down out of adjustment and not bent. Now there is now power to the headlight, REVERSE-NEUTRAL lights, 12 volt power outlet, Speedometer does not work or the 4W Drive. I opened the Cluster and could not find any broken or pinched wires. I readjusted the handlebar. The Sportsman starts and runs fine. I know there are no fuses, but is there a fuse link or circuit breaker some where that controls the power to the Head Light Cluster.

Last edited by rancher1524; 10-03-2011 at 09:38 AM. Reason: spelling
rancher1524 is offline  
Sponsored Links
Advertisement
 
post #2 of 2 (permalink) Old 10-04-2011, 04:16 AM
Polaris ATV Legend
 
Bruce!'s Avatar
 
Join Date: Feb 2009
Location: Port Angeles WA
Posts: 20,001
Welcome to the board!




I tried setting my password to "penis" but it said my password wasn't long enough...
Bruce! is offline  
Reply

  Lower Navigation
Go Back   Polaris ATV Forum > Polaris ATV Discussions > ATV General Discussion

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Polaris ATV Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Thread Thread Starter Forum Replies Last Post
Cluster, highbeam and AWD not working? [email protected] ATV Repair and Maintenance 1 11-13-2011 10:21 PM
Guage cluster not coming on?? jeremey14 ATV Repair and Maintenance 0 03-29-2011 01:51 PM
06 Sportsman 500 HO Cluster Problems tbeck1963 ATV Repair and Maintenance 0 03-13-2011 12:50 PM
2004 700 can't read RPM on cluster clinder700 ATV Repair and Maintenance 0 11-02-2010 09:09 PM
WTB 2006 Sportsman 800 headlight assemblies or gauge pod/headlight Angel of Death ATV Parts for Sale 1 09-06-2009 08:15 AM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome