$440 to fix high beam HL???? - Page 3 - Polaris ATV Forum
ATV General Discussion General Discussions about Polaris ATVs.

Reply
 
LinkBack Thread Tools Display Modes
post #21 of 22 (permalink) Old 12-28-2012, 09:51 AM
Polaris ATV Junkie!
 
fishhooker's Avatar
 
Join Date: Feb 2012
Location: Colorado
Posts: 806
NAPA connector part# EC17. This should plug into the light.

"Big Bad Wolf" 2004 Sportsman 700 EFI, Mine
"Lil' Red" 1999 Sportsman 335, The Wife's Ride
fishhooker is offline  
Sponsored Links
Advertisement
 
post #22 of 22 (permalink) Old 12-28-2012, 02:09 PM Thread Starter
Extreme ATV Enthusiast
 
Kalani938's Avatar
 
Join Date: Nov 2011
Location: Lufkin, Tx
Posts: 250
I looked these up. They list for $31. Didn't someone say there was one for $8? Lol. Either way its a lot better than $440!!

Red 2010 Polaris Sportsman 500 H.O.
ITP SS212 14" wheels with 27" Swamp Lites
K&N High Flow Air Filter

Kalani938 is offline  
Reply

  Lower Navigation
Go Back   Polaris ATV Forum > Polaris ATV Discussions > ATV General Discussion

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Polaris ATV Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Thread Thread Starter Forum Replies Last Post
High Beam Adjuster? Kalani938 ATV General Discussion 5 08-25-2012 10:59 PM
Light Low/High Switch not working for High Beam Bluemustang77 ATV Repair and Maintenance 3 03-22-2012 01:44 PM
High Beam Wire..... Monkey Man Polaris XP 3 02-19-2012 07:58 PM
Three Light High Beam Mod. polaris Dude Polaris Sportsman 3 12-15-2010 06:37 AM
High-Beam won't work. KenW. ATV Repair and Maintenance 2 10-05-2010 04:55 PM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome