05 Predator Backfiring and sputtering? - Polaris ATV Forum
ATV General Discussion General Discussions about Polaris ATVs.

 
LinkBack Thread Tools Display Modes
post #1 of 3 (permalink) Old 03-16-2014, 05:45 PM Thread Starter
Junior Member
 
cjl33's Avatar
 
Join Date: Mar 2014
Location: Michigan
Posts: 2
05 Predator Backfiring and sputtering?

Rode yesterday and had a backfire and sputter in the higher rpm's. Would start up and idle fine an everything else seems fine good power and all but had these issues. Rode it last weekend on a local lake and not one single problem, this time it was a little colder and pretty muddy. I just changed the plug today and it looked good, nice cardboard tan. I have a no toil filter that I just washed and is drying now. Could it be the colder weather leaning it out or is my carb dirty? When i drained the carb the drain screw had some gel on it. It was around 20 or so degrees out.
cjl33 is offline  
Sponsored Links
Advertisement
 
post #2 of 3 (permalink) Old 03-16-2014, 06:20 PM
Polaris ATV Legend
 
Bruce!'s Avatar
 
Join Date: Feb 2009
Location: Port Angeles WA
Posts: 20,001
Welcome to the board!




I tried setting my password to "penis" but it said my password wasn't long enough...
Bruce! is offline  
post #3 of 3 (permalink) Old 03-17-2014, 05:03 AM Thread Starter
Junior Member
 
cjl33's Avatar
 
Join Date: Mar 2014
Location: Michigan
Posts: 2
Anyone? Could a low battery do this??
cjl33 is offline  
Reply

  Lower Navigation
Go Back   Polaris ATV Forum > Polaris ATV Discussions > ATV General Discussion

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Polaris ATV Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Thread Thread Starter Forum Replies Last Post
500HO Sputtering and backfiring at WOT? PolarisRich ATV Repair and Maintenance 18 02-20-2014 08:33 AM
00 Sportsman 500 spitting/sputtering and backfiring 4krawln ATV Repair and Maintenance 2 10-04-2013 12:17 PM
2003 sputtering and backfiring Takelababy Polaris Sportsman 3 04-19-2012 05:09 PM
02 sportsman sputtering and backfiring grizzlybear Polaris Sportsman 1 10-11-2010 05:10 AM
02 sportsman sputtering and backfiring grizzlybear ATV Repair and Maintenance 0 10-09-2010 11:37 AM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome