no power at key - Page 2 - Polaris ATV Forum
ATV New Members If you are new here please post in this section so everyone can get to know you. This will be a kind of icebreaker section for new members.

Reply
 
LinkBack Thread Tools Display Modes
post #11 of 11 (permalink) Old 01-27-2019, 11:16 AM
Junior Member
 
Retired.Chris's Avatar
 
Join Date: Jan 2019
Posts: 2
Hey guys so similar issue, I have a 2018 sportsman 570 eps. It sat for a while and went to start it and it was dead. Put on battery tender and after half a day nothing lit up on the dash. It would start with the tender but no dash lights at all. Got a new battery and still nothing. Checked power on battery and fuses good. Power on one leg to some round brass looking piece on left side. I also replaced the 10amp circuit breaker. Any ideas?

Thank you for any assistance.
Retired.Chris is offline  
Sponsored Links
Advertisement
 
Reply

  Lower Navigation
Go Back   Polaris ATV Forum > Polaris ATV Discussions > ATV New Members

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Polaris ATV Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Thread Thread Starter Forum Replies Last Post
2004 330 no power to key Gmoon Polaris Magnum 1 07-26-2017 12:11 PM
No power to key switch/ lights Luttqui1 Polaris Predator 1 07-23-2017 06:48 AM
2009 sportsman touring 500 efi no power when you turn the key carpediem4570 ATV Repair and Maintenance 9 12-01-2016 02:47 PM
2008 efi 500 no power when key on skeeterbilt Polaris Sportsman 11 04-01-2016 05:30 PM
2010 Sportsman 500- No Electrical Power Dude89 Polaris Sportsman 2 12-13-2015 04:58 PM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome