2010 Polaris sportsman 850 co eps - Polaris ATV Forum
ATV New Members If you are new here please post in this section so everyone can get to know you. This will be a kind of icebreaker section for new members.

 1Likes
Reply
 
LinkBack Thread Tools Display Modes
post #1 of 13 (permalink) Old 02-27-2018, 05:30 PM Thread Starter
Junior Member
 
hunter_dad_jose's Avatar
 
Join Date: Oct 2017
Posts: 13
2010 Polaris sportsman 850 co eps

Having a problem with eps light flashing after bout 10min of riding. I got new battery an relay an greased connections an it still flashes. What else could it be an also would it cause more problems riding with it flashing?

Sent from my SM-G950U using Tapatalk
hunter_dad_jose is offline  
Sponsored Links
Advertisement
 
post #2 of 13 (permalink) Old 02-28-2018, 01:07 AM
Polaris ATV Legend
 
bp405's Avatar
 
Join Date: Sep 2011
Location: New York
Posts: 6,498
What do you have for DC voltage across the battery terminals @3,000 rpm?

2011 Sportsman® 800 EFI
GURU front brush guard
GURU rear brush guard
Polaris front lock n ride cargo box
Polaris rear rack extender
Warn RT 3.0 winch w/amsteel synthetic line
Viper aluminum haus fairlead
Polaris front spring adjusters
Ricochet a-arm guards
Ricochet full frame skid plate
ITP T-7 beadlock 14" w/OMF inner rim guards
Maxxis big horn 2.0 26x9 front
Maxxis big horn 2.0 26x11 rear
QSC clutch kit
EPI HD springs front n rear
ODI rogue 130mm grips
Ultraseal commercial grade tire sealant (front)
Highlifter tire sealant (rear)
CTEK 3300 battery maintainer
added 7 zerks
beefed up wiring harness
OGIO rear bag
ROTOPAX 1gal. + 2gal. gasoline can
Jccapri bushing kit
Kolpin Over Fenders
Rigid Industries E-Series 10" flood
Walker Evans struts
NGK Iridium's (2,500 miles on Champion's and they looked great!)
Odyssey Extreme battery PC545

2018 Sportsman® 570-T
2019 Aluma® A8818
bp405 is offline  
post #3 of 13 (permalink) Old 02-28-2018, 09:39 AM Thread Starter
Junior Member
 
hunter_dad_jose's Avatar
 
Join Date: Oct 2017
Posts: 13
Quote:
Originally Posted by bp405 View Post
What do you have for DC voltage across the battery terminals @3,000 rpm?
Not sure but I have noticed when I do rev it up the eps light does go off.

Sent from my SM-G950U using Tapatalk
hunter_dad_jose is offline  
Sponsored Links
Advertisement
 
post #4 of 13 (permalink) Old 02-28-2018, 01:53 PM
Extreme ATV Enthusiast
 
Gulf550's Avatar
 
Join Date: May 2010
Location: Georgia
Posts: 269
Garage
I agree with bp405. Check the battery voltage while the bike is running. My voltage regulator went bad on my 2010 and had similar problems. At idle it was putting out 18 volts and as the rpms were varied, the voltage would drop. I believe it should stay constant at 14 VDC.
Gulf550 is offline  
post #5 of 13 (permalink) Old 02-28-2018, 03:02 PM Thread Starter
Junior Member
 
hunter_dad_jose's Avatar
 
Join Date: Oct 2017
Posts: 13
Quote:
Originally Posted by Gulf550 View Post
I agree with bp405. Check the battery voltage while the bike is running. My voltage regulator went bad on my 2010 and had similar problems. At idle it was putting out 18 volts and as the rpms were varied, the voltage would drop. I believe it should stay constant at 14 VDC.
So revving it up an eps light go off a sign of possibly a bad voltage regulator?

Sent from my SM-G950U using Tapatalk
hunter_dad_jose is offline  
post #6 of 13 (permalink) Old 02-28-2018, 04:40 PM
Extreme ATV Enthusiast
 
Gulf550's Avatar
 
Join Date: May 2010
Location: Georgia
Posts: 269
Garage
I would say yes on the voltage regulator but there is also a possibility it could be a sator going. That's why you should measure the voltage across the battery when its running. You should have a Code.
Gulf550 is offline  
post #7 of 13 (permalink) Old 02-28-2018, 07:23 PM Thread Starter
Junior Member
 
hunter_dad_jose's Avatar
 
Join Date: Oct 2017
Posts: 13
Quote:
Originally Posted by Gulf550 View Post
I would say yes on the voltage regulator but there is also a possibility it could be a sator going. That's why you should measure the voltage across the battery when its running. You should have a Code.
Yeah that's what's crazy is there is no code coming up. Stoping to get a voltage meter and go from there. I appreciate your time and info.

Sent from my SM-G950U using Tapatalk
hunter_dad_jose is offline  
post #8 of 13 (permalink) Old 03-01-2018, 11:17 AM Thread Starter
Junior Member
 
hunter_dad_jose's Avatar
 
Join Date: Oct 2017
Posts: 13
Quote:
Originally Posted by hunter_dad_jose View Post
Quote:
Originally Posted by Gulf550 View Post
I would say yes on the voltage regulator but there is also a possibility it could be a sator going. That's why you should measure the voltage across the battery when its running. You should have a Code.
Yeah that's what's crazy is there is no code coming up. Stoping to get a voltage meter and go from there. I appreciate your time and info.

Sent from my SM-G950U using Tapatalk
I was able to check the voltage across battery when running at 3000rpm an it's 43 an now there's a code 168 3 an that's high voltage. So is that voltage regulator or starter

Sent from my SM-G950U using Tapatalk
hunter_dad_jose is offline  
post #9 of 13 (permalink) Old 03-01-2018, 04:38 PM
Extreme ATV Enthusiast
 
Gulf550's Avatar
 
Join Date: May 2010
Location: Georgia
Posts: 269
Garage
Voltage regulator
hunter_dad_jose likes this.
Gulf550 is offline  
post #10 of 13 (permalink) Old 03-09-2018, 10:45 AM Thread Starter
Junior Member
 
hunter_dad_jose's Avatar
 
Join Date: Oct 2017
Posts: 13
Quote:
Originally Posted by Gulf550 View Post
Voltage regulator
That's what it was the voltage regulator. Thank u for the info an now I got another problem after taking it out riding. It started to smoke white but not as I was out riding just when I started it up to load on trailer. It never overheated an all fluids was good an it idles good an sounds as it should could it be water pump?

Sent from my SM-G950U using Tapatalk
hunter_dad_jose is offline  
Reply

  Lower Navigation
Go Back   Polaris ATV Forum > Polaris ATV Discussions > ATV New Members

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Polaris ATV Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Thread Thread Starter Forum Replies Last Post
ASM-CLUSTER,110MM,W/FUEL (Speedo Cluster) FOR SALE KLCFLC Polaris Sportsman 2 02-18-2019 05:57 PM
2016 Polaris Sportsman 850 SP - Catvos Lift and Tires Weist318 Polaris Sportsman 6 11-23-2016 05:07 PM
F/S: 2010 Sportsman 850 XP Browning Camo Hunter Pkg - PA bonsey ATVs For Sale 4 09-27-2016 02:44 AM
Sportsman 850 SP EPS indicator question Viper1357 ATV General Discussion 5 09-11-2016 07:46 AM
Shock interchange TDMax Polaris XP 7 07-13-2016 05:21 PM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome