sportsman 90 cuts out - Polaris ATV Forum
ATV New Members If you are new here please post in this section so everyone can get to know you. This will be a kind of icebreaker section for new members.

 
LinkBack Thread Tools Display Modes
post #1 of 3 (permalink) Old 06-16-2011, 05:13 PM Thread Starter
Junior Member
 
quadworx's Avatar
 
Join Date: Jun 2011
Posts: 3
sportsman 90 cuts out

New to this forum but have been working on small engines and atvs for 15 years on the side. got another baffling problem. i got this 2 stroke 2006 polaris sportsman 90. had been sitting a while and would not start. took carb apart, bowl was full of green stale fuel. Let set in a bucket of dip. and cleaned thoroughly. put back on and it started up ok and ran for a little while, then started falling flat around 3/4 throttle. so took back off and bowl was full of cloudy gas, dumped bowl and looked like grey soot in bowl. so cleaned again and installed fuel filter and made sure i was getting good fuel flow, same result cutting out. took apart again and fuel was clean. i had another aftermarket carb to try so i put it on and same problem. not sure if i could be an air leak or something else
any help i can use
thanks
quadworx is offline  
Sponsored Links
Advertisement
 
post #2 of 3 (permalink) Old 06-16-2011, 05:38 PM
Polaris ATV Legend
 
Bruce!'s Avatar
 
Join Date: Feb 2009
Location: Port Angeles WA
Posts: 20,001
Welcome to the board!




I tried setting my password to "penis" but it said my password wasn't long enough...
Bruce! is offline  
post #3 of 3 (permalink) Old 06-21-2011, 05:56 PM
Junior Member
 
yote killer's Avatar
 
Join Date: Apr 2011
Location: Shelly MN
Posts: 27
Check your compression. mine did the same thing and I checked my compression and it was just a tad low. Put new rings in it and runs like a champ
yote killer is offline  
Reply

  Lower Navigation
Go Back   Polaris ATV Forum > Polaris ATV Discussions > ATV New Members

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Polaris ATV Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Thread Thread Starter Forum Replies Last Post
Cuts out in reverse kel51 ATV Repair and Maintenance 4 03-24-2011 06:07 PM
04 Sportsman 400 - Engine Cuts Out alaskatman ATV Repair and Maintenance 1 08-05-2010 08:10 PM
2004 predator 500 cuts out fordman213 ATV Repair and Maintenance 2 07-28-2010 08:12 AM
96 Polaris Scrambler cuts out when put in gear foxcub129 Polaris Scrambler 1 07-13-2010 06:02 PM
Sportsman 700 Twin EFI cuts off with hard right turn FlaDude Polaris Sportsman 6 01-19-2010 11:28 AM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome