Backfires all the time - Polaris ATV Forum
ATV New Members If you are new here please post in this section so everyone can get to know you. This will be a kind of icebreaker section for new members.

 
LinkBack Thread Tools Display Modes
post #1 of 6 (permalink) Old 04-09-2010, 08:03 PM Thread Starter
Junior Member
 
cpowers592's Avatar
 
Join Date: Apr 2010
Location: Shiloh Illinois
Posts: 8
Unhappy Backfires all the time

Starts up great and idles the same. Jump on the gas and when you let off yhe gas she backfires. 1998 Sportsman 500 not efi.
cpowers592 is offline  
Sponsored Links
Advertisement
 
post #2 of 6 (permalink) Old 04-10-2010, 06:02 AM
Polaris ATV Junkie!
 
Parsons Synthetics's Avatar
 
Join Date: Mar 2010
Location: Bonaire GA
Posts: 580
Send a message via Skype™ to Parsons Synthetics
Welcome aboard. You might get more responses to your questions in the section setup for your ATV or in the repair and maintenance section.

If I can ever be of assistance with fluids for your ATV, just let me know.

Take care,
Parsons Synthetics is offline  
post #3 of 6 (permalink) Old 04-10-2010, 10:50 AM
Polaris ATV Legend
 
4getful2's Avatar
 
Join Date: Aug 2009
Location: illinois
Posts: 2,352
backfires thru the exhaust?? or intake??
could try adjusting the valves
4getful2 is offline  
Sponsored Links
Advertisement
 
post #4 of 6 (permalink) Old 04-10-2010, 12:28 PM Thread Starter
Junior Member
 
cpowers592's Avatar
 
Join Date: Apr 2010
Location: Shiloh Illinois
Posts: 8
Smile 1998 Sportsman 500

Thanks for your quick response. It only backfires out the exhaust. I've had this baby since new in 98. Not many miles and the maintenance always performed when needed. After hunting season i drained the gas tank and put her to bed. This spring she fired right up, and idles just about perfect. But when i open her up, then let off the throttle she backfires out the exhaust. Sounds like a muzzleloader going off. Now i can stay on the throttle as long as possible, but when i let off thats when she pops. I thankyou for your responce again. Clay
cpowers592 is offline  
post #5 of 6 (permalink) Old 04-10-2010, 06:54 PM
Polaris ATV Junkie!
 
cam101311's Avatar
 
Join Date: Dec 2009
Location: Bismarck IL
Posts: 517
Send a message via Yahoo to cam101311
welcome to the site!

1998 polaris 425 magnum 4x4
super swamper vampire tsl
3 inch lift
500 h.o. carb and airbox
plastic fenders and rack swap
relocated radiator
winch
custom 300 watt pioneer audio pipe!

1995 polaris 400 xplorer 4x4 R.I.P
1998 kawasaki 220 bayou
1998 e-ton 90
cam101311 is offline  
post #6 of 6 (permalink) Old 04-10-2010, 07:58 PM
Polaris ATV Junkie!
 
redneck2725's Avatar
 
Join Date: Feb 2010
Location: West Virginia
Posts: 814
Welcome to the site!!

07 Polaris Predator 500
Yoshimura RS3 slip-on
UM Racing aluminum airbox w/K&N filter
ITP Holeshot HDs
Pro Aluminum skids, nerfs, and bumper
Powermadd handguards
Shockwears shock covers
PRM radiator scoops
PD 13T front sprocket & X-ring chain
Amsoil oil w/ K&N filter
Engine Ice coolant
ODI Rogue Grips
redneck2725 is offline  
Reply

  Lower Navigation
Go Back   Polaris ATV Forum > Polaris ATV Discussions > ATV New Members

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Polaris ATV Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Thread Thread Starter Forum Replies Last Post
2001 Sportsman 500 HO bogs and backfires RLeeSmith ATV Repair and Maintenance 9 03-20-2019 03:13 PM
Hi new member. Long time reader first time poster. Need help 😞 Michael Leverette ATV General Discussion 0 07-02-2018 04:34 PM
2nd time around on water pump rebuild Rbourman ATV Repair and Maintenance 0 07-01-2018 06:38 PM
Backfires 1 time (in the intake) runs about 1 second and then stalls. Toyvo ATV Repair and Maintenance 4 08-27-2016 05:41 PM
It's finally time to upgrade the trailer ThorsHammer Around The Garage 25 04-27-2016 07:25 AM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome