belt install - Page 5 - Polaris ATV Forum
ATV Repair and Maintenance Having problems? Doing a rebuild? All Repair/Maintenance Discussions here.

Reply
 
LinkBack Thread Tools Display Modes
post #41 of 44 (permalink) Old 04-18-2012, 08:21 PM
Polaris ATV Legend
 
KICKER431's Avatar
 
Join Date: Aug 2011
Location: Chaumont NY
Posts: 2,075
Thanks for posting all this Mikedirenzo. I have a feeling a lot of people can use this thread. I will keep it bookmarked for when I need to do any clutch / belt work.

MINE:2015 Sportsman SP 850 Sunset Red
Back seat / cargo box and footpegs from Thor, Polaris 2500 Winch with synthetic rope, Polaris front and back bumpers, Polaris Lock-n-Ride Mid windsheild, Heated handgrips, Fender Flares, Rotax 2+2 Fuel Cans on front rack.

HERS:2015 Sportsman SP 850 Touring Sunset Red
Polaris 2500 Winch with synthetic rope, Polaris front and back bumpers, Polaris Lock-n-Ride Mid windsheild, Heated handgrips, Fender Flares


RIP Sarge (2004 Sportsman 700 EFI killed on trail 32, Rock House, Hatfield-McCoy)
KICKER431 is offline  
Sponsored Links
Advertisement
 
post #42 of 44 (permalink) Old 04-19-2012, 09:13 AM
ATV Enthusiast
 
mikedirenzo's Avatar
 
Join Date: Sep 2010
Location: Charlotte, NC
Posts: 52
Glad to do it. I am going to be posting an article on my new KFI 2500 winch install.

2010 Sportsman 500 HO
KFI 2500 Winch
Richochet Under Armor (Full Packagage)
Rotopax 4 gallon with Universal mounting plate
Trails
  • Hatfiled Mcoy 2011
  • Brown Mountain Beach ORV 2012
  • Carolina Adventure World 2010, 2011, 2012
  • Brimestone ATV 2012

Last edited by mikedirenzo; 04-24-2012 at 04:53 PM.
mikedirenzo is offline  
post #43 of 44 (permalink) Old 05-16-2012, 09:26 PM
Junior Member
 
apaka's Avatar
 
Join Date: Mar 2012
Location: BC Canada
Posts: 3
I had a similar problem on my 2006 magnum 330. I blew out my belt...


But when I went to put the new belt on, it seemed overly loose and it hit the cover as well. So I found this thread and after rigging myself up a nice spring compressor to get the c-clip off the back of the secondary I found a huge amount of belt dust and abnormal wear on these so called "buttons" and a bit of wear on the helix riders as well. I ordered new buttons and a new spring, just because I'm here, after its all back together ill fine tune the belt tension via the washers behind the secondary, I have 4 back there currently so I have some room for adjustment. Here's a pic of one of the buttons

Ill let you know how it all goes when I get it all back together!

Thanks for all the tips and insight, always appreciated.
apaka is offline  
Sponsored Links
Advertisement
 
post #44 of 44 (permalink) Old 04-17-2015, 10:39 AM
ATV Enthusiast
 
ProPolaris's Avatar
 
Join Date: Apr 2015
Location: Montana
Posts: 36
Good read as I have this issue with my 500
ProPolaris is offline  
Reply

  Lower Navigation
Go Back   Polaris ATV Forum > Polaris ATV Technical Discussions > ATV Repair and Maintenance

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Polaris ATV Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Thread Thread Starter Forum Replies Last Post
good belt bad belt or all the same? notdaddys ATV Repair and Maintenance 30 06-30-2011 11:00 AM
My HID install '11 SP antoniodef Polaris Sportsman 20 05-05-2011 12:39 PM
jet kit writeup/install help. 425whpsti ATV Performance Modifications 1 04-15-2011 02:12 PM
any buy and install this HID kit???? hotairgypsy ATV General Discussion 20 03-04-2011 10:53 PM
A Arm install....Help? Bobby002 ATV Performance Modifications 3 02-03-2011 02:21 PM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome