03 Sportsman 400 no power to pod - Polaris ATV Forum
ATV Repair and Maintenance Having problems? Doing a rebuild? All Repair/Maintenance Discussions here.

 
LinkBack Thread Tools Display Modes
post #1 of 2 (permalink) Old 04-18-2019, 03:51 PM Thread Starter
Junior Member
 
KeithNL's Avatar
 
Join Date: Apr 2019
Posts: 1
03 Sportsman 400 no power to pod

I have a 2003 Sportsman 400 that's giving me trouble. When i turn the key the speedo lights up for about 10-20 seconds then fades away. Yet it will start with the key and the lights work. Wiring seems fine and battery is charged. Any ideas? Thanks for your help.

Keith
KeithNL is offline  
Sponsored Links
Advertisement
 
post #2 of 2 (permalink) Old 04-19-2019, 09:48 AM
Polaris ATV Legend
 
latebird's Avatar
 
Join Date: May 2014
Location: Illinois
Posts: 3,396
You have to access the back side of the speedo and test for 12 volts between pins 1,2 & 8 - 1 is red wire, 2 is red/white wire and 8 is brown wire (brown is ground) - If you have 12 vdc on pins 1 & 2, replace the speedo - hopefully it's just a loose connection on the plug on the back of the speedo.

2006 Trailboss 330
2002 Sportsman 90
2005 TRX400EX (FOR SALE)
2003 LT-Z400 (needs engine work & is for sale)
2004 CRF250X
1971 Triumph 650 Bonneville (has 5 original miles)
1972 Triumph 650 Bonneville (undergoing restoration)
1979 Honda CBX (6 cylinder)
1970 Kawasaki G3SS 90cc Bushmaster
1976 Suzuki RE5 Rotary (not running & FOR SALE)
1981 Kawasaki KZ305-A
1981 Suzuki GS450T (undergoing repair & will be for sale when done)
1982 Kawasaki KZ750-H (FOR SALE)
1989 Honda VT1100C
2007 Vectrix VCTX Electric Scooter
1965 Montgomery Ward 3 1/2 HP Tecumseh Mini Bike
1970 Triumph T25 250cc Trailblazer
1968 Triumph 250cc Flat Tracker

Shop Owner and Mechanic with over 50 years experience
latebird is online now  
Reply

  Lower Navigation
Go Back   Polaris ATV Forum > Polaris ATV Technical Discussions > ATV Repair and Maintenance

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Polaris ATV Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Thread Thread Starter Forum Replies Last Post
NGK plugs Happyman Polaris Sportsman XP 1000 36 04-17-2019 05:00 AM
Will this oil filter work (#2540086) - '14 Sportsman 850 Skippy850 Polaris XP 7 01-17-2019 07:56 AM
Sportsman 500 No power to gauge pod only PolarisFun07 ATV Repair and Maintenance 1 01-28-2018 03:07 PM
Polaris Rear Subframe Back Sub Frame Rack Mount Support Bracket 1040490-067 razorsharp Polaris Sportsman 3 12-10-2017 08:21 AM
2001 sportsman 400 no power Mzxjc Polaris Sportsman 3 09-27-2016 04:55 AM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome