Hydrolocked sportsman 850 won't run quite right - Polaris ATV Forum
ATV Repair and Maintenance Having problems? Doing a rebuild? All Repair/Maintenance Discussions here.

 
LinkBack Thread Tools Display Modes
post #1 of 4 (permalink) Old 09-11-2019, 02:55 PM Thread Starter
Junior Member
 
tvr12speed3's Avatar
 
Join Date: Oct 2018
Posts: 2
Hydrolocked sportsman 850 won't run quite right

I got sucked into a hole and went deeper than I wanted to and the water sucked into my engine and shut off. I took it home and drained water from the clutch, the air box, pulled out the air filter, pulled out the spark plugs to push the water out, replaced the sorry plugs, changed oil few times (so far), plugged the clutch out, checked fuel pressure which was good (58psi). I pulled fuel from the top of tank, bottom of the tank, from fuel pump and from fuel rail, all were clean of water. At first it wouldn't run but now it will run at an idle while sounding like a misfire. If I touch the throttle at all it shuts off. I don't know what else to try to do. It doesn't sound like a bent rod
tvr12speed3 is offline  
Sponsored Links
Advertisement
 
post #2 of 4 (permalink) Old 09-16-2019, 03:04 PM
Junior Member
 
Recon's Avatar
 
Join Date: Jun 2012
Location: new hampshire
Posts: 25
cam gear on the end of the crankshaft slipped.
Recon is offline  
post #3 of 4 (permalink) Old 09-16-2019, 03:32 PM
Polaris ATV Junkie!
 
shane-o's Avatar
 
Join Date: May 2010
Location: wroxeter ontario
Posts: 839
Send a message via MSN to shane-o
Loosen air box from throttle body make sure intake is empty ...it has a low spot water can sit in

2015 xp 1000 black pearl,
-polaris front and rear bumpers
-polaris hand/thumb warmers
-polaris body guard
-gse slip on
-front diff fix
-cecco frame braces
-lock and ride front box.
-dobeck fuel controller
-big horn originals/mega mayhems depending on the ride
shane-o is offline  
Sponsored Links
Advertisement
 
post #4 of 4 (permalink) Old 09-16-2019, 05:47 PM
Premium Member
 
stave7119's Avatar
 
Join Date: Oct 2013
Location: Lena, IL
Posts: 3,404
When it hydro locked it could have broken a piston or bent a rod. Was there water in a cylinder? I am afraid you did some damage inside. If it isn't running right, its time to pull it apart.

Mine: 2018 Sportsman 850SP - 26" Bear Claw HTRs on OEM steel wheels(I really don't like the Aluminum ones)
Polaris Hand warmers, Mirrors.
Hers: 2019 Sportsman 450. 26" Bear Claw HTRs on Moose 427X Wheels.

2007 Sportsman 500 EFI, Polaris Winch, 25" Bear Claws QSC Clutch Kit, Hand Warmers
2001 Magnum 325 MOSE 12" rear wheel conversion. 25" Sedona Coyote tires
2017 Polaris Ranger 1000XP - Roof and front glass
2018 Kawasaki KLR650
2001 Magnum 325 Warn winch and Moose 60" plow-Sent to Daughter and Son-In-Law since his blew up
SOLD 2004 Sportsman 600 Twin
stave7119 is offline  
Reply

  Lower Navigation
Go Back   Polaris ATV Forum > Polaris ATV Technical Discussions > ATV Repair and Maintenance

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Polaris ATV Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome